Published June 23, 2008
| Version 15012
Journal article
Open
Design of an SNMP Agent for OSGi Service Platforms
Authors/Creators
Description
On one hand, SNMP (Simple Network Management
Protocol) allows integrating different enterprise elements connected
through Internet into a standardized remote management. On the
other hand, as a consequence of the success of Intelligent Houses
they can be connected through Internet now by means of a residential
gateway according to a common standard called OSGi (Open
Services Gateway initiative). Due to the specifics of OSGi Service
Platforms and their dynamic nature, specific design criterions should
be defined to implement SNMP Agents for OSGi in order to integrate
them into the SNMP remote management. Based on the analysis of
the relation between both standards (SNMP and OSGi), this paper
shows how OSGi Service Platforms can be included into the SNMP
management of a global enterprise, giving implementation details
about an SNMP Agent solution and the definition of a new MIB
(Management Information Base) for managing OSGi platforms that
takes into account the specifics and dynamic nature of OSGi.
Files
15012.pdf
Additional details
References
- P. J. Muñoz, "Diseño de un módulo de gestión de red para un PLC de Siemens S7", Master Thesis, Valencia, 2003. Award for the Best Master Thesis in Telematics Engineering for the Association of Spanish Telecommunication Engineering.
- Network Working Group, "A Simple Network Management Protocol (SNMP)", RFC 1157, may 1990.
- W. Stallings "SNMP, SNMPv2, SNMPv3, and RMON 1 and 2", 3rd Ed., Adisson-Wesley, 1999.
- S. Landis and S. Maffeis ÔÇÿÔÇÿBuilding reliable distributed systems with CORBA,-- Theory and Practice of Object Systems, John Wiley & Sons Publishers, New York, 1997.
- V. Krishnaswamy, D. Walther, S. Bhola, "Efficient Implementations of of Java Remote Method Invocation (RMI)", Proceedings of the 4th USENIX Conference on Object-Oriented Technologies and Systems (COOTS), 1998.
- Innovation Center Intelligent House, "INHAUS", http://www.inhausduisburg. de/en/index.htm
- OSGi Alliance, "OSGi Service Platform release 3", March 2003, available at http://osgi.org
- Network Working Group, "Structure and Identification of Management Information for TCP/IP-based Internets", RFC 1155, may 1990.
- Prosyst Software AG, "SNMP Package", Manual of Prosyst, 2001-2003, available at. http://www.prosyst.com/osgi.html [10] M. L. Santill├ín, "Desarrollo de una herramienta de gesti├│n remota de pasarelas de servicios domésticas", Master Thesis, Madrid, 2004. [11] Network Working Group, "Management Information Base for Network Management of TCP/IP-based Internets: MIB-II", RFC 1213, march 199.