Published December 28, 2010
| Version 2387
Journal article
Open
A Comparative Analysis of Performance and QoS Issues in MANETs
Authors/Creators
Description
Mobile Ad hoc networks (MANETs) are collections
of wireless mobile nodes dynamically reconfiguring and collectively
forming a temporary network. These types of networks assume
existence of no fixed infrastructure and are often useful in battle-field
tactical operations or emergency search-and-rescue type of
operations where fixed infrastructure is neither feasible nor practical.
They also find use in ad hoc conferences, campus networks and
commercial recreational applications carrying multimedia traffic. All
of the above applications of MANETs require guaranteed levels of
performance as experienced by the end-user. This paper focuses on
key challenges in provisioning predetermined levels of such Quality
of Service (QoS). It also identifies functional areas where QoS
models are currently defined and used. Evolving functional areas
where performance and QoS provisioning may be applied are also
identified and some suggestions are provided for further research in
this area. Although each of the above functional areas have been
discussed separately in recent research studies, since these QoS
functional areas are highly correlated and interdependent, a
comprehensive and comparative analysis of these areas and their
interrelationships is desired. In this paper we have attempted to
provide such an overview.
Files
2387.pdf
Files
(346.3 kB)
| Name | Size | Download all |
|---|---|---|
|
md5:e2f6da8b9c38a9fcdbff29f7a723e0f9
|
346.3 kB | Preview Download |
Additional details
References
- Abdrabou A, Zhuang W (2006) A position-based QoS routing scheme for UWB mobile ad hoc networks. IEEE J. Select. Areas Commun. 24:850-856.
- Ahn G S, Campbell A T, Lee S B, Zhang X (1999) INSIGNIA. Internet Draft. comet. columbia.edujinsigniajdraft-ietf-manet-insignia-01.txt Accessed 18 March 2008.
- Ahn G S, Campbell A T, Veres A, Sun L H (2002) Supporting service differentiation for real-time and best effort traffic in stateless Wireless Ad Hoc Networks (SWAN), IEEE Transactions on Mobile Computing 1 (3): 192-207.
- Badis H, Agha K A (2005) QOLSR: QoS routing for ad hoc wireless networks using OLSR. Wiley European Transactions on Telecommunications 15(4):427--442.
- Barolli L, Koyama A, Shiratori N (2003) A QoS routing method for adhoc networks based on genetic algorithm. Proc. 14th Int. Wksp. Database and Expert Systems Applications 175-179.
- Bharghavan V, Demers A, Shenker S, Zhang L (1994) MACAW: A media access protocol for wireless LANs. Proc. ACM SIGCOMM 212- 225.
- Blake S, Black D, Carlson M, Davies E, Wang Z, Weiss W (1998) An architecture for differentiated services. IETF RFC2475. www.ietf.orgjrfcjrfc2475.txt.
- Bluetooth SIG (2001) Specification of the Bluetooth System - Version 1.1 B.
- Braden R, Clark D, Shenker S (1994) Integrated services in the internet architecture - an Overview. IETF RFC1633. www.ietf.orgjrfcjrfcl633.txt. [10] Braden R, Zhang L, Berson S, Herzog S, Jamin S (1997) Resource reSerVation Protocol (RSVP) - Version I Functional Specification. RFC 2205. www.ietf.orgjrfcjrfc2205.txt. [11] Brach J, Maltz D A, Johnson D B, Hu Y C, Jetcheva J (1998) A performance comparison of multi-hop wireless ad hoc network routing protocols. Proc. 4th Annual ACM/IEEE International Conference on Mobile Computing and Networking 85-97. [12] Vivek V, Sandeep T, Manoj B S, Murthy C S R (2004) A novel out-ofband signaling mechanism for enhanced real time support in tactical ad hoc wireless networks. Proc. IEEE RTAS 56-63. [13] Chang J H, Tassiulas L (2000) Energy-conserving routing in wireless ad-hoc networks. Proc. IEEE INFO COM 1:22-31. [14] Wang M, Kuo G S (2005) An application-aware QoS routing scheme with improved stability for multimedia applications in mobile ad hoc networks. Proc. IEEE Vehicular Technology Conf. 1901-1905. [15] Chen T W, Tsai J T, Gerta M (1997) QoS routing performance in multihop, multimedia, wireless networks. Proc. IEEE 6th Int. Conf. Universal Personal Communications 2:557-561. [16] Chen Y, Tseng Y, Sheu J, Kuo P (2002) On-demand, linkstate, multipath QoS routing in a wireless mobile ad-hoc network. Proc. European Wireless 135-141. [17] Chua K C, Xiao H, Seah K G (2003) Relative service differentiation for mobile ad hoc networks. Proc. IEEE Wireless Communications and Networking Conference (WCNC) 2:1379-1384. [18] Wroclawski J (1997) Specification of the controlled-load network element service. RFC 2211. www.ietf.org/rfc/rfc2211.txt. [19] De S, Das S K, Wu H, Qiao C (2002) Trigger-based distributed QoS routing in mobile ad hoc networks. ACM SIGMOBILE Mobile Computing and Communications Review 6(3):22-35. [20] Xiao H, Seah W K G, Chua K C (2000) A flexible quality of service model for mobile ad hoc networks. Proc. IEEE Vehicular Technology Conference (VTC) 1:445-449. [21] Dharmaraju D, Chowdhury A R, Hovareshti P, Baras J S (2002) INORA - A unified signalling and routing mechanism for QoS support in mobile ad hoc networks. Proc. ICPPW 86-93. [22] Doshi S, Bhandare S, Brown T (2002) An on-demand minimum energy routing protocol for a wireless ad-hoc network. Mobile Computing and Communications Review 6(2):50-66. [23] Fan Z (2004) QoS routing using lower layer information in ad hoc networks. Proc. Personal, Indoor and Mobile Radio Communications Conf., 135-139. [24] Gerharz M, de Waal C, Frank M, James P (2003) A practical view on quality-of-service support in wireless ad hoc networks. Proc. IEEE Workshop on Applications and Services in Wireless Networks (ASWN), citeseer.ist.psu.edu/jgerharz03practica1.html. [25] Gupta P, McKeown N (1999) Packet classification on multiple fields. Proc. ACM SIGCOMM Conference on Applications, Technologies, Architectures, and Protocols for Computer Communications 147-160. [26] Hanzo L, Tafazolli R (2007) A survey of QoS routing solutions for mobile ad hoc networks. Communications Surveys & Tutorials, IEEE 9(2):50-70. [27] Yu C, Lee B, Youn H Y (2003) Energy-efficient routing protocols for mobile ad-hoc networks. Wiley J. Wireless Communications and Mobile Computing Journal 3(8): 959-973. [28] Ibanez J, Nichols K (1998) Preliminary simulation evaluation of an assured service. Internet Draft (Work in progress) www3.tools.ietf.org/html/draft-ibanez-diffserv assured-eval-OO. [29] IEEE Computer Society (2006), Wireless Medium Access Control (MAC) and Physical Layer (PHY) Specifications for High-Rate Wireless. Amendment I: MAC Sublayer IEEE Std 802.15.3b-2005 (Amendment to IEEE Std 802.15.3-2003) 1-146. [30] IEEE Standards Board (1999) Part II: Wireless LAN Medium Access Control (MAC) and Physical Layer (PHY) Specifications. The Institute of Electrical and Electronics Engineers Inc. www.csse.uwa.edu.au/adhocnets/802.1l-1999.pdf. [31] JacquetP, Muhlethaler P, Clausen T, Laouiti A, Qayyum A, Viennot L (2001) Optimized link state routing protocol for ad hoc networking. Proc. IEEE Multi Topic Conf. 62-68. [32] Karn P (1990) MACA - a new channel access method for packet radio. Proc. ARRLI CRRL Amateur Radio Ninth Computer Networking Conf. 134-140. [33] Kim D, Min C H, Kim S (2004) On-demand SIR and bandwidthguaranteed routing with transmit power assignment in ad hoc mobile networks. IEEE Transactions on Vehicular Technology 53:1215-1223. [34] Lee S B, Campbell A T (1998) INSIGNIA: in-band signaling support for QOS in mobile ad hoc networks. Proc 5th International Workshop on Mobile Multimedia Communications (MoMuC). [35] Lin C R (2002) On-demand QoS routing in multi-hop mobile networks. Proc. IEEE INFOCOM 3:1735-1744. [36] Lin C R, GerIa M (1997) MACA/PR: an asynchronous multimedia multihop wireless network. Proc. IEEE INFOCOM. 1:118-125. [37] Lin C R, Liu J (1999) QoS routing in ad hoc wireless networks. IEEE Journal on Selected Areas in Communications 17(8):1426-1438. [38] Lu S, Bharghavan V, Srikant R (1997) Fair scheduling in wireless packet networks. Proc. ACM SIGCOMM. 27(4):63-74. [39] Misra A, Banerjee S (2002) MRPC: maximizing network lifetime for reliable routing in wireless environments. Proc. IEEE Wireless Communications and Networking Conf. pages.cs.wisc.edu/~suman/pubs/wcnc02.pdf. [40] Yu C, Lee B, Youn H Y (2003) Energy-efficient routing protocols for mobile ad-hoc networks. Wiley J. Wireless Communications and Mobile Computing Journal 3(8): 959-973. [41] Nichols K, Jacobson V, Zhang L (1999) A two-bit differentiated services architecture for the internet. IETF RFC2638. www.ietf.org/rfc/rfc2638.txt. [42] Nikaein N, Bonnet C, Nikaein N (2001) Hybrid ad hoc routing protocol- HARP. Proc. Int. Symp. Telecommunications. [43] Perkins C E (2001) Ad Hoc Networking. Ch. 3, Addison Wesley, Reading, MA. [44] Perkins C E, Bragwat P (1994) Highly dynamic destination-sequenced distance-vector routing (DSDV) for mobile computers. Proc. ACM SIGCOMM 234-244. [45] Perkins C E, Royer E M, Das S R (2000) Quality of service for ad hoc on-demand distance vector routing. IETF Internet Draft (Work in progress). draft-ietf-manet-aodvqos- 00.txt. [46] Perkins C E, Royer E M, Das S R, Marina M K (2001) Performance comparison of two on-demand routing protocols for ad hoc networks. IEEE Personal Communications Magazine 8:16-28. [47] Rappaport T S (1996) Wireless Communications - Principles & Practice. Prentice Hall Communications Engineering and Emerging Technologies Series, 2nd Edition, ISBN-I 0: 0130422320, Prentice Hall, Upper Saddle River, NJ. [48] Reddy T B, Karthigeyan I, Manoj B S, Murthy C S R (2006) Quality of service provisioning in ad hoc wireless networks: a survey of issues and solutions. Ad Hoc Networks 4:83-124. [49] Rubin I, Liu Y C (2003) Link stability models for QoS ad hoc routing algorithms. Proc. 58th IEEE Vehicular Technology Conf. 5:3084-3088. [50] Zhang B, Mouftah H T (2005) QoS routing for wireless ad hoc networks: problems, algorithms and protocols. IEEE Communications Magazine 43: 110-117. [51] Shah S H, Nahrstedt K (2002) Predictive location-based QoS routing in mobile ad hoc networks. Proc. IEEE ICC 2002 2:1022-1027. [52] Sheng M, Li J, Shi Y (2003) Routing protocol with QoS guarantees for ad-hoc network Electronics Letters 39:143-145. [53] Shenker S, Partridge C, Guerin R (1997) Specification of guaranteed quality of service. RFC 2212. [54] Sivakumar R, Sinha P, Bharghavan V (1999) CEDAR: a core extraction distributed ad hoc routing algorithm. IEEE Journal on Selected Areas in Communications 17: 1454-1465. [55] Sobrinho J L, Krishnakumar AS (1999) Quality-of-service in ad hoc carrier sense multiple access wireless networks. IEEE Journal on Special Areas in Communications 17(8): 1353-1368. [56] Stine J, de Veciana G (2004) A paradigm for quality of service in wireless ad hoc networks using synchronous signaling and node states. IEEE Journal on Selected Areas in Communications 22:1301-1321. [57] Talucci F, Gerla M (1997) MACA-BI (MACA By Invitation): A wireless MAC protocol for high speed ad hoc networking. Proc. IEEE ICUPC. 2:913-917. [58] Zhu C, Corson M S (2002) QoS routing for mobile ad hoc networks. Proc. IEEE INFOCOM, 958-967. [59] Vidhyashankar V, Manoj B S, Murthy C S R (2003) Slot allocation schemes for delay sensitive traffic support in asynchronous wireless mesh networks. Proc. The International Journal of Computer and Telecommunications Networking 50(15):2595-2613.