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This	document	presents	the	protocols	developed	to	visualize	skeletal	and	dental	elements	on	2D	
computed	tomography	scan	(CT)	slices	and	3D	renderings	of	these	elements,	as	well	as	the	
segmentation	protocol	to	extract	element	surfaces	(Stock	et	al.	2020).	The	protocols	were	
developed	as	part	of	National	Institute	of	Justice	Awards	2015	DN-BX-K009	and	2017	DN-BX-0144.	

If	the	methodology	discussed	herein	is	used	in	a	presentation	or	publication,	then	this	document	
needs	to	be	cited.	We	strongly	encourage	all	research	using	this	protocol	to	be	submitted	to	the	
Subadult	Virtual	Anthropology	Database	Zenodo	Community	to	facilitate	sharing	and	discovery	of	
information	(https://zenodo.org/communities/svad/?page=1&size=20).		

	

	

	

	

	

	

	

	

	

	

	



Contents	
Isosurface & Surface Generation Protocol in Amira™ (v. 2020.2) ............................................................ 3 

CT Scan Visualization and Measurement Protocol in Amira™ (v. 2020.2) ............................................... 9 

References .............................................................................................................................................. 14 

	

	 	



Isosurface	&	Surface	Generation	Protocol	in	Amira™	(v.	2020.2)	
 

First	Steps	

1.	Open	Amira	and	choose	[Open	Data…]	(green	button	in	the	“Project	View”	pane	in	the	upper	left	
corner).	

	
2.	Find	the	individual	you	are	interested	in	and	select	all	of	the	DICOMs	in	that	folder	(not	the	
DICOM	directory).	Click	[Open].	

	
If	you	get	a	warning	about	the	file	size	being	too	large,	choose	the	radio	button	for	“Load	complete	
volume	into	memory”	and	click	[OK].	

	
A	dialog	box	called	“DICOM	Loader”	will	prompt	you	to	check	the	parameters	of	the	DICOM	stack.	
Scroll	through	the	window	and	if	everything	looks	good	(no	out	of	order	numbering,	gaps	in	the	
data,	etc.),	press	[OK].		

	
	
3.	The	file	appears	as	a	green	lozenge	in	the	“Project	View”	pane.	Before	selecting	anything	else,	
click	the	perspective	button.	The	button	is	located	in	a	bar	of	other	buttons	just	above	the	viewing	

panes	and	looks	like	an	eye	with	this	symbol	in	front:	 	Clicking	the	button	will	change	the	

symbol	in	front	of	the	eye	to	parallel	lines:	 .	Use	the	parallel	line	setting	for	all	specimen	
editing	and	measuring.	

	
4.	Save	the	project.		
Click	File	>	Save	Project	As.	Save	the	project	as	the	Case	Number	in	that	corresponding	
Individual’s	folder.	Saving	the	project	enables	you	to	pull	up	all	of	the	objects,	commands	and	
settings	at	the	time	you	save,	preserving	your	workspace	just	how	you	left	it.	
	
A	dialog	box	titled	“Save	Project	policy”	may	appear	asking	how	if	you	want	to	save	only	
necessary	data	to	the	disk	and	compute	it	later,	or	save	all	data.	Unless	inappropriate	for	your	
project,	Select	“Minimize	project	computation”	to	save	all	data,	and	click	[OK].	
	

5.	Save	the	data.		
While	the	green	data	lozenge	is	selected,	click	File	>	Save	Data	As.	Save	the	data	as	the	“Patient	
name”	with	the	file	extension	automatically	chosen	by	Amira.	This	links	the	loaded	DICOM	stack	
to	the	Amira	project.	Save	the	data	file	every	time	you	load	in	a	new	set	of	DICOMs.			
	
Occasionally,	Amira	will	automatically	create	an	orange	lozenge	titles	“Ortho	Slice”	that	shows	a	
single	slice	of	the	CT	data.	You	can	choose	to	keep	this	on	until	the	Isosurface	is	created,	or	should	
you	choose	to	turn	it	off	for	a	cleaner	work	space,	simply	click	the	little	red	box	within	the	orange	
lozenge.	The	Ortho	Slice	should	now	be	removed	from	the	workspace	until	you	wish	to	turn	it	
back	on.	Through	this	process	it	might	be	useful	to	turn	different	surfaces	on	and	off	to	compare,	



or	keep	a	clean	work	space.	Just	remember	to	click	the	red	box	inside	the	lozenge	to	switch	it	on	
or	off.	

	
If	your	individual	is	comprised	of	two	or	more	stacks	of	DICOMs,	load	and	save	all	of	the	data	
using	Steps	1	&	3.	Because	of	UNM’s	scanning	procedures,	some	of	the	z-coordinates	of	the	
patient’s	location	may	be	off,	resulting	in	misplacement	of	one	set	of	scans	relative	to	the	others	
along	the	body’s	long	axis.	To	fix	this	we	can	reset	the	coordinates	of	the	segmented	and	
smoothed	surfaces	or	Generated	Surface	(but	it	won’t	fundamentally	change	your	data	file).	Select	
the	green	data	lozenge	that	has	the	scan	you	want	to	move,	look	in	the	“Properties”	pane	in	the	
lower	left	corner,	and	click	the	Transform	Editor	button.	It	looks	like	a	bunch	of	green	balls	
arranged	in	a	hexagon	with	lines	connecting	them.	You	may	have	to	increase	the	size	of	the	
property	box	for	it	to	appear.	In	the	“Manipulator”	section	of	the	area	that	appears,	click	[Dialog].	
A	new	window	pops	up	with	several	different	options,	select	the	“Relative	to	Global	Axes”	tab.	
Adjust	the	z-axis	in	small	positive	and/or	negative	increments	until	the	scan	is	properly	placed	
relative	to	its	counterpart.	Warning:	Once	you	move	a	scan	there	is	no	reset	or	CTRL-Z	to	put	the	
image	back	where	it	started.	Also,	note	that	this	procedure	should	be	followed	both	for	
Isosurfaces	and	Generated	Surfaces	(instructions	in	the	next	several	Steps).	

	
	
6.	Selecting	the	bone,	excluding	the	surrounding	soft	tissue	(bone	segmentation)	
		
This	presents	the	steps	for	semi-automatic	segmentation	of	bone	elements,	with	some	manual	
adjustments.		
	
Navigate	to	the	“Segmentation”	pane.	Make	sure	the	data	file	you	are	working	on	appears	in	the	
“Image:”	area.	If	not,	select	your	file	from	the	pull-down	menu.		
	
Create	a	new	material	by	clicking	[Add]	at	the	bottom	of	the	Material	window.	You	can	rename	
your	material	something	pertinent	(like	“Diaphyses”)	as	well	as	change	its	color	in	this	pane.		
	
Scroll	through	the	CT	slices	until	the	bone	you	would	like	to	select	is	at	least	partially	visible	
within	the	slice.	Below,	select	the	“Magic	Wand”	tool	in	the	lower	left	hand	pane.		
	
Using	the	histogram	sliders,	encompass	the	range	of	values	that	you	think	belong	to	bone.	You	can	
type	an	exact	value	within	the	right	number	box	to	expedite	the	process	of	finding	a	beginning	
threshold.	Usually,	begin	with	160	as	a	default	threshold	value	to	and	then	roll	to	higher	or	lower	
values	using	the	cursor	until	you	reach	a	satisfactory	level	of	segmentation	(only	the	bone	is	
highlighted	and	the	edges	are	smooth).	Once	you	have	attained	an	appropriate	threshold	level,	
make	sure	to	record	the	value	in	a	separate	excel	file	or	notebook.		
	
To	check	your	selection,	next	to	“Preview”	below	the	histogram,	check	the	“2D”	and	“3D”.	Ensure	
the	3D	viewing	window	is	open	by	clicking	a	pane	viewer	box	that	has	more	than	one	pane,	which	
would	be	the	three	buttons	farthest	to	the	right	on	the	bar	above	the	viewing	panes.	An	example	
of	the	viewing	pane	options	are	shown	below	with	the	series	of	5	white	boxes	with	varying	lines	
in	them.	The	voxels	whose	grayscale	values	are	encompassed	within	the	histogram	range	that	you	
set	will	then	glow	blue	in	the	viewing	window	to	the	right,	and	a	3D	representation	of	the	selected	



material	will	appear	in	the	3D	viewing	pane.	Then	click	on	part	of	the	bone	in	the	pictures	shown	
in	the	viewing	window.	This	should	highlight	the	bone	in	red.	

	
	
A	red	line	will	appear	on	the	masking	slider	at	the	value	of	the	point	you	have	just	selected	on	the	
bone.	Adjust	the	slider,	or	by	typing	in	the	numbers	in	the	box	to	the	left	of	the	histogram,	until	all	
of	the	bone	is	selected,	but	no	other	materials	are	selected	in	the	slice	in	which	you	are	currently	
viewing	the	scan.	Once	you	feel	happy	with	your	selection,	click	the	“All	Slices”	check	box	above	
the	histogram.	This	now	applies	your	selection	to	all	of	the	slices,	and	if	you	navigate	to	the	3-D	
view	in	the	Segmentation	pane,	you	should	see	a	red,	3D	image	of	the	specimen.	Rotate	the	3-D	
image	and	see	if	it	looks	complete,	and	scroll	through	the	sliders	in	the	various	plane	viewing	
windows.		
	
You	can	change	orientation	by	going	to	Segmentation	à	Orientation	à	(whichever	orientation	
you	haven’t	done	yet).	An	easier	way	to	toggle	between	views	of	the	orientations	is	using	the	
toolbar	above	the	viewing	pane	that	looks	like	this:		

	
	
In	this	toolbar,	clicking	on	the	different	rectangular	boxes	gives	you	from	one	up	to	four	(x-,	y-,	z-
planes	and	3D)	planes/surfaces	open	simultaneously	in	your	viewer	window.	To	toggle	between	
different	views	in	the	one-view	option,	just	click	on	the	single	rectangle	repeatedly.		
	
If	you	notice	parts	of	the	skeleton	not	in	the	selection	or	extra	bits	of	soft	tissue	material	that	
aren’t	bone	in	the	selection,	you	may	want	to	adjust	the	number	to	the	left	of	the	histogram	slider.	
	
Once	you	have	selected	the	skeleton	(or	part	of	the	skeleton),	highlight	the	Material	that	you	want	
to	add	your	selection	too,	navigate	to	“Selection”,	and	click	“Interpolate”	(or	just	ctrl	+	i).	Then	
click	the	Add	[+]	button	under	Selection	in	the	bottom	left	hand	pane.	Multiple,	non-contiguous	
areas	can	be	selected	with	consecutive	clicks	if	the	Shift	key	is	held	down	during	clicking.	You	can	
also	subtract	selected	areas	from	a	Material	as	well	by	clicking	the	Subtract	[-]	button.	
	
There	are	other	tools	that	can	be	used	for	segmenting	as	well.	These	include	the	paint	brush	tool,	
the	lasso	and	the	blow	tool	(buttons	as	they	appear	below).	Voxels	selected	using	all	of	these	tools	
can	be	added	to,	as	well	as	removed	from,	a	material.		

	The	paint	brush	tool	lets	you	select	a	wider	area,	and	you	can	change	the	size	and	shape	
of	the	brush	strokes.	You	can	select	some	helpful	options	for	this	tool,	like	‘Select	only	current	
material’	to	only	allow	the	brush	to	select	the	Material	that	is	currently	highlighted.	
	

	 	The	lasso	tool	operates	just	like	in	Photoshop.	It	is	one	of	the	only	tools	that	can	be	used	
in	the	3-D	option	of	the	Segmentation	viewer,	but	be	forewarned	that	it	will	then	select	



everything	behind	(from	your	perspective)	whatever	you	are	lassoing.	Also,	this	is	can	be	a	very	
time	intensive	process.	

	The	blow	tool	works	like	blowing	up	a	really	irregular	balloon,	whose	edges	conform	to	
the	boundaries	of	different	grayscale	values.	Click	and	drag	around	an	area	of	interest	to	grow	
the	balloon.	The	higher	the	’Tolerance’	value,	the	easier	it	will	be	for	your	balloon	to	jump	over	
boundaries.		
	
Remember	that	CTRL-Z	always	works	to	undo	a	mistake,	and	you	can	zoom	in	and	out	using	the	
+/-	magnifying	glass	buttons	(just	don’t	mistake	them	for	the	[+]	or	[-]	buttons	to	add/subtract	
your	selection	from	the	materials!!)	
	

7.	Smoothing	the	slices		
Re-select	all	of	the	area	that	you	just	segmented	into	your	new	Material	above	by	clicking	the	
‘Select’	box	next	to	the	Material	you	are	working	with.		
From	the	menu	bar,	choose		Selection	à	Grow	à	Volume.	
	
Next	choose	Selection	à	Smooth	à	All	Slices.	Smooth	all	slices	in	this	manner	in	all	three	
orientations	(XY.	YZ,	and	XZ).	See	Step	5	above	for	help	toggling	between	views.	
	
Choose	Selection	à	Shrink	à	Volume.		
	
Click	the	[+]	button	to	add	the	selection	to	your	material	

	
	
8.	Saving	the	raw	file.	Return	to	the	Project	View	pane	by	clicking	the	tab	in	the	upper	left.	Right	
click	on	the	green	lozenge	that	ends	in	“labels”	navigate	to	the	“Compute”	folder,	and	click	on	the	
red	gear	labeled	“Generate	Surface”	from	the	options	that	appear,	click	[Create].	Within	the	
surface	generating	dialog	that	appears	in	the	lower	left,	change	the	Smoothing	option	to	“None”	
then	click	the	green	[Apply]	button	at	the	bottom.	

	
A	dialog	box	may	appear,	warning	you	that	the	image	is	rather	large.	Click	[Continue].	

	
A	new	green	lozenge	is	generated	(ending	in	.surf).	Select	it,	then	in	the	menu	bar	go	to	File	à	
Save	Data	As…	and	save	the	generated	surface	as	“(Record	number).surf.am”.	This	is	“.am”	is	the	
file	type	to	save	surfaces	for	viewing	in	Amira.		

	
Select	the	newly	created	green	lozenge	again,	then	in	the	menu	bar	go	to	File	à	Export	Data	As…	

	
Choose	.ply	as	the	file	type,	and	name	the	file	so	that	it	reads	“(Record	number)_raw.ply”.	Be	
sure	you	are	in	the	folder	for	the	correct	individual	and	click	[Save].	

	
If	you	would	like,	click	the	yellow	[Surface	View]	button	to	see	what	the	specimen	looks	like	at	
this	stage	in	the	main	Amira	viewing	window.	To	manipulate	the	Surface,	the	left-click	rotates	the	
view,	the	center-click	transposes	the	view	and	the	center	scroll	ball	zooms	in	and	out.	

	



	
9.	Filling	in	all	the	holes	in	the	specimen.	Return	to	the	Materials	Selection	Area	(upper	left	
corner)	in	the	“Segmentation”	pane.	You	want	the	same	selection	that	you	had	when	you	created	
the	raw	file,	so	click	the	‘Select’	box	next	to	the	Material	into	which	the	bone	is	segmented.	This	
will	make	all	the	voxels	belonging	to	this	material	glow	red.	
	
There	are	two	ways	to	fill	holes	in	the	specimen:	
1)	Go	to	Selection	à	Fill	à	All	Slices.	This	method	will	indiscriminately	fill	every	hole	in	every	
slice.	So	be	careful!	It	is	easy	to	accidentally	fill	up	unintended	areas,	especially	if	your	surface	
isn’t	watertight.		
	
2)	Fill	in	slice	by	slice	using	the	paintbrush	tool	(see	explanation	in	Step	5).	This	method	is	
painstaking	but	highly	accurate.	You	will	probably	need	to	use	it	to	fill	up	any	holes	that	
communicate	with	the	air	outside	the	specimen	(such	as	tooth	roots	with	holes	at	the	bottom	of	
them).	If	you	do	need	to	do	manual	paintbrush	filling	to	block	holes	that	communicate	with	the	
‘outside	world’	as	in	step	#2	above,	unless	you	completely	fill	the	empty	space	manually,	you	will	
need	to	go	back	and	run	step	#1	above.	This	is	probably	a	good	idea	after	manually	filling	holes	
anyway,	just	to	double-check	as	erroneously	missing	voxels	are	hard	to	catch.	
	
Once	you	have	selected	the	full	specimen,	with	no	internal	bubbles,	click	the	Add	[+]	button	to	add	
your	selection	to	the	Material.		

	
	
10.	Saving	the	filled	surface.	Once	you	are	satisfied	with	your	highlighted	selection,	return	to	the	
Project	View	tab,	located	in	the	upper	left.	Highlight	the	.labels	lozenge	again	and	click	the	red	
[Generate	Surface]	above.	Once	the	surface	is	generated	click	the	red	lozenge	that	is	created	and	
change	the	smoothing	drop	down	bar	to	‘None’.	Once	that	is	changed	click	‘Apply’.	A	message	may	
appear	warning	you	that	your	surface	will	be	large,	click	‘Continue’.	A	new	green	lozenge	will	
appear	ending	in	“record	number.surf’.		

	
Click	the	red	“Generate	Surface”	lozenge	to	create	a	new	surface	(green	lozenge)	and	save	your	
work.	Use	File	à	Export	Data	As…	to	save	the	newly	generated	surface	as	a	.ply	file	with	the	name	
“(Record	number)_fill.ply”	to	the	same	file	folder	as	before.	Create	a	new	Surface	View	if	you	
desire.	

	
	
11.	Smoothing	the	surface.		

	
Click	the	green	lozenge	ending	in	‘.surf’	that	corresponds	to	the	filled	surface.	Now	that	you	have	
segmented	the	bone,	you	can	smooth	the	surface	by	pressing	the	red	[Smooth	Surface]	button	at	
the	top	of	the	Project	View	pane.	If	the	button	is	not	there,	smoothing	can	be	accessed	by	right-
clicking	the	green	lozenge,	going	to	Surface	Transforms	à	Smooth	Surface,	and	pressing	[Create].	
	
Once	the	Smooth	Surface	dialog	has	opened	in	the	lower	left	corner	of	the	screen,	change	the	
iterations	to	20	(but	do	not	change	the	lambda	value—should	always	=	0.6)	and	press	[Apply]	
in	the	bottom	right	corner.	This	will	create	a	new	lozenge	in	the	Project	View	pane.		

	



12.	Saving	the	segmented	surface	

Use	File	à	Export	Data	As…	to	save	the	final	green	lozenge	created	as	“(record	
number)_smooth.ply”	in	the	same	folder	as	the	other	.ply	files.	

Create	a	surface	view	by	clicking	the	yellow	[Surface	View]	button.	To	manipulate	the	Surface,	the	
left-click	rotates	the	view,	the	center-click	transposes	the	view	and	the	center	scroll	ball	zooms	in	
and	out.	This	is	the	surface	view	from	which	all	diaphyseal	measurements	will	be	taken!	

	
13.	Final	steps		
	
Before	closing	out	the	window	or	moving	on	to	the	next	scan,	make	sure	to	save	the	project	and	
its	contents.	Go	to	File	>	Save	Project.	Since	you	already	saved	the	project	in	Step	#	3,	the	.hx	file	
should	already	exist.	When	saving,	a	Dialog	box	may	pop	up	that	notes	if	you	haven’t	saved	
aspects	of	the	project	that	would	need	to	get	saved	in	order	to	re-open	the	project.	Save	the	files	
using	the	same	Record	number	and	into	the	same	folder	where	the	rest	of	the	data	for	this	
specimen	are	stored.	

	 	



CT	Scan	Visualization	and	Measurement	Protocol	in	Amira™	(v.	2020.2)		
	

1.	Opening	Amira	and	loading	CT	scan	stacks	

Open	Amira™	by	double	clicking	the	Desktop	icon	and	choose	[Open	Data…]	(green	button	in	the	
[Project	View]	pane	in	the	upper	left	corner).	

Find	the	individual	you	are	interested	in	and	select	all	of	the	DICOMs	in	that	folder	(NB:	not	the	
DICOM	directory).	Click	[Open].	Always	select	the	folder	that	has	“ST”	in	the	name.	This	stands	
for	“Soft	Tissue”	and	has	a	better	resolution	than	“Bone”.	You	can	choose	folders	with	names	
including	“Head,	Head-Neck”,	or	“Whole	Body”	as	they	all	include	the	upper	body	and	skull.		

If	you	get	a	warning	about	the	file	size	being	too	large,	choose	the	radio	button	for	“Load	
complete	volume	into	memory”	and	click	[OK].	

A	dialog	box	called	“DICOM	Loader”	will	prompt	you	to	check	the	parameters	of	the	DICOM	stack.	
Scroll	through	the	window	and	if	everything	looks	good	(not	out	of	order	numbering,	gaps	in	the	
data,	etc.),	click	[OK].	Any	errors	will	be	shown	as	red	numbers	in	the	list	of	DICOMs.	If	that	is	
the	case,	only	select	the	DICOM	files	that	appear	in	black	by	pressing	shift	and	clicking	on	the	
first	and	last	DICOM	of	the	stack	that	you	want	to	open.	

	

2.	Visualizing	the	CT	slices.		
The	file	appears	as	a	green	lozenge	in	the	“Project	View”	pane.	Before	you	do	anything,	make	sure	

the	‘Perspective’	tool	is	set	to	orthogonal.	The	button	looks	like	this:	 	and	you	want	the	lines	in	

front	of	the	eye	to	be	parallel,	not	angled,	like	this:	 .	The	button	is	located	in	a	bar	of	other	
buttons	just	above	the	viewing	panes.	Use	the	parallel	line	(orthographic)	setting	for	all	specimen	
editing	and	measuring.	

	

Save	the	project.	Click	File	>	Save	Project	As.	Save	the	project	as	the	Case	Number	in	that	
corresponding	Individual’s	folder.	Saving	the	project	enables	you	to	pull	up	all	of	the	objects,	
commands	and	settings	at	the	time	you	save,	preserving	your	workspace	just	how	you	left	it.	

A	dialog	box	titled	[Save	Project	policy]	may	appear	asking	how	if	you	want	to	save	only	
necessary	data	to	the	disk	and	compute	it	later	or	save	all	data.	Unless	inappropriate	for	your	
project,	Select	“Minimize	project	computation”	to	save	all	data,	and	click	[OK].	

	 Select	the	orange	[Orthoslice]	tab	in	the	“Project	View”	pane.	The	CT	slice	should	appear	in	the	
viewing	console	on	the	right.	You	can	change	the	plane	of	the	slice	view	by	selecting	xy,	xz,	or	yz	
in	the	console	header.	If	the	hand	is	selected	in	that	header,	you	can	use	it	to	move	the	exam	
around.	You	can	also	scroll	through	the	slices	by	clicking	the	box	next	to	the	Slice	Number	line	
in	the	“Properties”	pane	and	using	the	mouse	to	scroll,	or	moving	the	cursor	between	the	two	
triangles.		

	



Save	the	data.	While	the	green	data	lozenge	is	selected,	click	File	>	Save	Data	As.	Save	the	data	
as	the	[Patient	name]	with	the	file	extension	automatically	chosen	by	Amira™.	This	links	the	
loaded	DICOM	stack	to	the	Amira™	project.	Save	the	data	file	every	time	you	load	in	a	new	set	of	
DICOMs.			

Occasionally,	Amira™	will	automatically	create	an	orange	lozenge	titles	[Ortho	Slice]	that	shows	
a	single	slice	of	the	CT	data.		

If	your	individual	is	comprised	of	two	or	more	stacks	of	DICOMs,	load	and	save	all	of	the	data	
using	Steps	1	&	3.	Because	of	some	facilities’	scanning	procedures,	some	of	the	z-coordinates	of	
the	patient’s	location	may	be	off,	resulting	in	misplacement	of	one	set	of	scans	relative	to	the	
others	along	the	body’s	long	axis.	To	fix	this	we	can	reset	the	coordinates	of	the	segmented	and	
smoothed	surfaces	or	Generated	Surface	(but	it	will	not	fundamentally	change	your	data	file).	
Select	the	green	data	lozenge	that	has	the	scan	you	want	to	move,	look	in	the	[Properties]	pane	
in	the	lower	left	corner,	and	click	the	Transform	Editor	button.	It	looks	like	a	bunch	of	green	
balls	arranged	in	a	hexagon	with	lines	connecting	them.	You	may	have	to	increase	the	size	of	the	
property	box	for	it	to	appear.	In	the	[Manipulator]	section	of	the	area	that	appears,	click	
[Dialog].	A	new	window	pops	up	with	several	different	options,	select	the	[Relative	to	Global	
Axes]	tab.	Adjust	the	z-axis	in	small	positive	and/or	negative	increments	until	the	scan	is	
properly	placed	relative	to	its	counterpart.	Warning:	Once	you	move	a	scan	there	is	no	reset	or	
CTRL-Z	to	put	the	image	back	where	it	started.	

	

3.	Navigating	through	the	CT	slices		

To	scroll	through	the	slices,	select	the	orange	[Orthoslice]	lozenge.	Go	to	the	Properties	pane	
below	and	select	one	of	the	three	planes	you	want	to	visualize	the	images	in.	Scroll	through	the	
slices	by	selecting	the	little	triangle	and	moving	it	up	and	down.	If	you	want	to	zoom	in	the	slice,	
place	the	cursor	on	the	slice,	press	the	roller	on	the	mouse	and	roll	it	to	zoom	in.		

	

4.a.	Creating	a	Volume	Rendering	of	an	element			
Select	the	green	lozenge.	Click	on	the	yellow	[Volume	Rendering]	button.	The	soft	tissue	of	the	
scanned	body	should	appear	in	the	viewing	console	on	the	right.	You	can	use	the	mouse	on	
hand	mode	to	turn	the	body	around	at	different	angles.		

In	the	“Properties”	pane,	move	the	left	cursor	of	the	“Colormap”	higher	to	adjust	the	masking	
value	(the	number	on	the	left).	This	allows	you	to	hide	soft	tissue	and	only	visualize	bones	or	
teeth,	the	further	you	adjust	the	value.	Higher	values	will	only	allow	to	visualize	the	densest	
elements	(metal,	teeth,	etc.).	You	can	also	type	a	value	in	that	left	box	and	lower	the	right	slider	
as	well.	If	you	cannot	see	the	teeth,	you	can	move	the	body	around	and/or	unselect	the	orange	
square	in	the	[Orthoslice]	lozenge	to	hide	the	contents	of	the	CT	slice.	A	good	range	of	values	
should	encompass	part	of	the	grey	peaks	you	can	see	in	the	“Colormap”.		

To	adjust	the	transparency,	in	the	“Properties	pane”,	click	on	the	[Edit	box]	of	the	Colormap	
line.	You	can	scroll	down	the	menu	and	choose	one	of	the	colormap	options.	You	can	always	
revert	back	to	the	original	setting	if	necessary	by	selecting	it	in	the	“Edit”	box.		



	

4.b.	Creating	an	Isosurface/segmented	surface	of	an	element		

See	protocol	for	segmentation/volume	rendering	of	bones	and	teeth	to	obtain	virtual	surfaces	of	
these	elements	(“Amira	Isosurface	&	Surface	Generation	Protocol”).		

	

5.	Measurements		

To	install	the	Amira	plug-in	for	exporting	measurement	sets,	follow	these	steps:		
	

• Open	Amira,	click	on	"Blank	project"		
• In	the	upper	banner,	click	on	"Project"	and	then	on	"Consoles"	below	that.	A	set	of	

consoles	should	appear	in	the	bottom	right:	"Tcl	console"	and	"Main	Python	
console".			

• Make	sure	you	are	in	the	Tcl	console	(the	name	is	highlighted	in	blue)	and	enter	
measure	useNewMeasureTools	0	(see	image	below),	then	hit	Enter.	It	should	say	
"Please	restart	the	application	to	take	new	setting	into	account".			

	

	
	

• Restart	Amira.		
• When	you	select	the	measuring	tool	now,	an	“Export”	button	should	appear	at	the	

bottom	of	the	Properties	pane	now	(see	second	image	attached).		
• When	you	click	on	that	"Export"	button,	a	green	lozenge	appears	in	the	"Project	

View"	pane,	called	"Measurement.SpreadSheet".	You	can	now	save	or	export	that	as	
a	.csv	file.	

• Re=open	the	stack	of	CT	scans/segmented	surfaces	to	take	your	measurements	
	

5.a.	Measurements	on	CT	slices	
		 Once	you	have	the	slice	you	want	to	take	the	measurement	on,	navigate	to	the	header	to	View	and	
scroll	down	to	select	[Measuring].	Or	go	to	the	panel	above	the	slice	and	select	the	ruler	image.	
This	will	make	a	new	yellow	lozenge	pop	up.	When	you	have	the	yellow	[Measurement]	lozenge	
selected	in	the	Project	View	pane,	various	options	will	pop	up	in	the	[Properties]	pane	in	the	
lower	left-hand	corner	of	the	screen.		



Then	click	[Line]	in	the	[Properties]	pane/the	ruler	icon,	and	a	new	measurement	line	will	pop	up	
in	the	box	below.	Navigate	the	cursor	into	the	viewer	window	and	click	and	drag	between	the	
points	to	take	the	measurement.	The	distance	will	be	displayed	both	next	to	the	line	in	the	viewer	
window	as	well	as	on	the	line	in	the	[Properties]	pane.	Scroll	through	the	slices	to	see	if	your	
measurement	is	ok.	Remember	that	left	clicking	will	rotate	the	image,	center	clicking	and	
dragging	will	transpose	the	image	and	scrolling	will	zoom	in/out.	If	you	wish	to	edit	the	
placement	of	a	point,	click	on	the	line	of	that	measurement	in	the	[Properties]	pane,	make	in	the	
line	in	question	become	highlighted	with	little	red	balls	on	its	endpoints.	Left	click	on	the	point	
you	wish	to	move	and	drag	it	to	its	appropriate	location.	When	you	are	satisfied	with	the	
measurement,	click	on	[Line]	to	start	a	new	measurement.	In	order	to	preserve	already-taken	
measurements,	you	can	click	on	the	lock	on	the	left	side	of	each	measurement	so	that	you	cannot	
change	them	accidentally.	Clicking	on	the	eye	next	to	the	lock	removes	that	measurement	from	
your	view.		

	
5.b.	Measurements	on	virtual	surfaces		
	
Diaphyseal	and	pelvic	measurements	are	taken	in	Amira	from	volume	renderings	(see	step	4.a.	
above)	the	filled	smoothed	surfaces	generated	after	following	the	segmentation	protocol	(see	
“Isosurface	&	Surface	Generation	Protocol	in	Amira”)	using	the	3D	measurement	tool	to	the	
nearest	hundredth	of	a	millimeter.	Before	you	do	anything,	if	you	have	not	done	this	before	in	the	
first	steps,	make	sure	the	‘Perspective’	tool	is	set	to	orthogonal.	You	want	the	lines	in	front	of	the	
eye	to	be	parallel,	not	angled.		
	
While	the	generated	Surface	is	open	in	the	viewer	window	in	the	“Project	View”	pane,	navigate	to	
View	>	Measuring.	This	will	make	a	new	yellow	lozenge	pop	up.	When	you	have	the	
“Measurement”	lozenge	selected,	various	options	will	pop	up	in	the	“Properties”	pane	in	the	
lower	left-hand	corner	of	the	screen.	Check	the	3-D	box—this	makes	sure	that	i)	the	
measurements	you	are	taking	will	stick	to	the	Surface	when	you	move	it	around,	and	ii)	you	must	
place	the	endpoints	of	a	linear	measurement	on	the	Surface	(i.e.,	it	will	not	allow	you	to	click	into	
thin	air).	
	
Then	click	[Line]	in	the	“Properties”	pane,	and	a	new	measurement	line	will	pop	up	in	the	box	
below.	Navigate	the	cursor	into	the	viewer	window	and	left	click	on	the	two	end	points	(or	click	
and	drag	between	the	points).	The	distance	will	be	displayed	both	next	to	the	line	in	the	viewer	
window	as	well	as	on	the	line	in	the	“Properties”	pane.	In	order	to	check	the	placement	of	your	
points,	switch	to	the	Hand	selector	tool	(in	the	toolbar	above	the	viewer	window)	to	manipulate	
the	surface	to	get	a	better	view.	Remember	that	left	clicking	will	rotate	the	image,	center	clicking	
and	dragging	will	transpose	the	image	and	scrolling	will	zoom	in/out.	If	you	wish	to	edit	the	
placement	of	a	point,	click	on	the	line	of	that	measurement	in	the	“Properties”	pane,	make	in	the	
line	in	question	become	highlighted	with	little	red	balls	on	its	endpoints.	Left	click	on	the	point	
you	wish	to	move	and	drag	it	to	its	appropriate	location.	When	you	are	satisfied	with	the	
measurement,	click	on	[Line]	to	start	a	new	measurement.	In	order	to	preserve	already-taken	
measurements,	you	can	click	on	the	lock	on	the	left	side	of	each	measurement	so	that	you	cannot	
change	them	accidentally.	Clicking	on	the	eye	next	to	the	lock	removes	that	measurement	from	
your	view.		
	



6.	Saving	your	measurements		
	
To	save	your	measurements,	go	to	File>Save	Project	as	and	save	your	project.		

	

	
	
You	can	also	export	your	measurement	set	as	an	Excel	spreadsheet	by	clicking	on	the	“Export”	
button,	at	the	bottom	right	of	the	Properties	box	of	the	measuring	tool.		
	

	 	
7.	Saving	the	Data	and	Saving	the	Project		

Go	to	File>Save	Data	and	enter	the	name	you	wish	to	save	your	data	and	the	path	to	where	your	
dta	will	be	located.		
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