Endnote file prep for export into HAWC
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Modified Endnote filters are available:
https://hawcproject.org/lit/ris-export-instructions/

* HAWC PubMed import filter

* HAWC WOS import filter

* HAWC Scopus_ RIS import filter

* HAWC Embase TEXT import filter
* HAWC Export RIS style

e HAWC EndNote Export style

* HAWC EndNote Import filter

Suggested Endnote columns displayed for Library preparation and de-duplication:
* Author

* Year

e Title

*  Volume

* Pages

* Journal

* Name of DB

¢ Custom 8 (PMID)
* DOI

e Accession #



Export your search results from databases
For PubMed, Use the Medline format and save the text file

For Web of Science, Search the Core Collection, Save to “Endnote Desktop” and
select “Full Record” for the record content

Send to EndNote

Number of Records: @ All records on page

Records to

Record Content: | Fy|| Record

Send Cancel

For Scopus use the RIS format and be sure to “Specify fields to be exported”
including the Citation information, DOI, PMID, Abstract etc.

H Save to Mendeley (® RIS Format

EndNote, Reference Manager

ocsv
Excel
O BibTeX
O Text
ASCIl in HTML

4y RefWorks direct export

Choose the information to export:

Choose the information you want to export to the reference manager or file.

| Specify fields to be exported v |
(O Citation information (O Bibliographical information (M Abstract and Keywords

1 Author(s) (O Affiliations (V¥ Abstract
(M Document title (¥ Serial identifiers (e.g. ISSN) (# Author Keywords
™ Year (¥ PubMed ID (¥ Index Keywords
™ Source title (O Publisher (O Funding Details
(M Volume, Issue, Pages (O Editor(s) (¥ Number
(O citation count (M Language of Original Document (O Acronym
(M Source and Document Type (O Correspondence Address (¥ Sponsor

™ pol

(O Other information
(O Tradenames and Manufacturers
(M Accession numbers and Chemicals
(O Conference information

(V¥ Abbreviated Source Title

(O References

For Embase, Use Export format “Plain Text” and choose “Full Record” Output

+ Export Data

Export format:  piain Text

Output: Full record a

Include search
query in export

Title

Original title

Author names

Author addresses
Correspondence address
Editors

Source

Conference name
Conference location
Conference date
Conference editors

ISSN

ISBN

Book publisher

Abstract

Emtree drug index terms (Major focus)
Emtree drug index terms

s —

The Full record export includes the following:

Emtree medical index terms (Major focus)
Emtree medical index terms
Drug trade name

Drug manufacturer

Device trade name

Device manufacturer

CAS registry number
Molecular sequence number
Embase classification
Clinical trial number
Language of article
Language of summary
Embase accession number
Medline PMID

Full text link

Copyright



Import Process steps

Import PubMed references:
Instructions include copying the PMID into the Custom § field

Import using PubMed filter customized for HAWC imports (HAWC_PubMed)
NLM will appear in Database Name field

When all PubMed citations are imported copy the PMID into the Custom field as follows:
Select the PubMed references (“ctl A” selects all showing references)
Select “Change Move and Copy Fields” from the “Tools" dropdown on the top menu

1

Change/Move/Copy Fields

Change Fields

A pop-up window will appear

Move Field
Copy Fi
1. Select: Move or Copy tab = Gt .
2. Select: COpy From: Accession Number B
3. From field: Accession Number To: Custom 8 B4
4. To Field: Custom 8 *
*Note if your Custom 8 is already 5 Oinsertafter i
assigned you will need to identify a ::seln bef°’f "effd;: LC
new custom field to use. epiace enfire e
5. “Insert after field’s text” is fine
(field should be empty) .
6. Click OK ) cancel | (I

The PMID will now appear in both the Accession Number field and in the Custom Field
identified as PMID

Import WOS references:

Instructions include manually adding the “Database name” not included in the export.
NOTE: When searching Web of Science, Be sure to search the “Core Collection”.

Import records using ICI filter customized for HAWC imports (HAWC_WOS)
All the other references in the library should be from PubMed and have “NLM” in the Database
Name field.

Select the imported references
*If you have multiple sets of WOS references you may either do the following steps for each
import of WOS references, or import them all then segregate the WOS references for processing
by selecting all those with nothing in the Database Name field and choosing “Show Selected
References” from the “References” drop-down on the top menu.

Add the text “WOS” to the Name of Database Field as follows:

Select “Change Move and Copy Fields” from the “Tools" dropdown on the top menu.



Il’l the pop_up window Change/Move/Copy Fields

1 Move/Copy Fields
1. Select: Change Fields tab

2. In field: Select “Name of In:2 Name of Database B Insert Special a
Database” Change wog 4
3. Leave “Insert after field’s text” 3 © Insert after field's text:
selected Insert before field's text:
4. In the box type “WOS” 2‘.’;‘2?22.;”“’" e
5. Uncheck the box to “Include a Change Case
space before new text” Senience cese
6. Click OK 5 Include a space before the new text B |1 |uRPy A A,
6
2 Cancel | (NS
Import Scopus references:
Scopus should appear in Database Name and The PMID should appear in Custom 8
Import using Scopus filter customized for HAWC imports (HAWC_Scopus RIS)
No need to modify results
Import Embase references:
Instructions include manually adding the Database Name not included in the export, and re-
formatting the DOI from the link in the URL field.
Import using Embase filter customized for HAWC imports (HAWC _Embase TEXT)
Add the database name (EMB), using the same process above in WOS instructions.
Copy URL field to DOI field using the same process as PMID in PubMed instructions.
Do a “find and replace” on DOI field to _
remove the text http://dx.doi.org/ as follows: Find and Replace
Select “Find and Replace” from the “EDIT " . 1 oo i Insert Special [
dropdown on the top menu Zsmn For:
A pop-up window will appear niplicdotore!
Match Case Match Words
1. Select “In” field: DOI T ———
2. In “Search For” box paste: 3
http://dx.doi.org/
3. Leave “Change the text to” box blank
4. Click: Change Retain Capitalization
4
Cancel



Remove Duplicates
Use your preferred method of ensuring there are no duplicates within your list.
Also remove duplicates of items already in your HAWC project.

If you have an Endnote file of your previous HAWC entries you may merge the new and old
libraries for de-duplication as follows:

Use the customized HAWC EndNote Export style to export your new references from their
library.

In your Library of the references already held in your HAWC project, (or a copy of that library),
create a group folder for the “old” set, and move all the references into the group folder. Label it
to differentiate it from the new import.

Use the customized HAWC EndNote Import filter to import your new references into your
library of existing HAWC references. (Remember to set your duplicate recognition preferences
as you see fit before the import.)

Use your preferred method of ensuring there are no duplicates within your list.

Your new set of references should be in the “Unfiled” grouping in your left hand “Library” pane.
You may make a new group folder for them or leave them unfiled.



Export appropriate references and upload to HAWC

Select references to be exported. *Your new export should contain only unique citations not yet
included in your HAWC project.

* Export using customized HAWC _ Export RIS filter. *Your file may have a .txt
extension, but it can still be processed.

* (o to the target HAWC assessment

¢ Click on Literature review in the left hand menu (1)
Then click the “Actions” button on the right top area of the screen (2).

e Select “New Import from File” from the drop-down list.

Home /' Goldenseal Root Powder (2015) / Literature Review

x References for Goldenseal Root Powder (2015)
Goldenseal Root Powder (2015)
AvAILABLE MODULES Literature summary Literature tags
Literature Review .
S— Total 0 (0 from searches, 0 from imports) =Inclusion
i

Y Tagged 0 Human Study
Endpoint List Animal Study
Visualizations Untagged 0 Mechanistic Study
Executive Summary = Exclusion

Tier Il
Tier Il

DOWNLOADS

Download datasets
Literature Searches & Imports

No previous literature searches available.

Search/import editing

New search

Reference editing

Add new reference (manually)
Tag manually-added references

Tag untagged references

In the form:
* leave RIS selected (even if your file has a txt extension)
* provide a meaningful title to help differentiate it from other uploads
* Include a description to further clarify the content of the individual upload
* Click “Browse” and select your exported file

Click Save and the upload will process.

Contact About Public Assessments Your HAWC ~



Other skills you may need to use this process

Adding a new filter (Output or Import) to your Endnote

Copy or drag the required filters from the source location (whether attached to an email or stored
in a shared folder) to the correct folder on your computer.

Locate you Endnote folder (probably under My Documents). Inside it you will see a Styles
folder and a Filters folder.

Favorites Today Previous 7 Days
E Al My Files 1 EndNote » [ Filters >
A L 71 HAWC » ['W Styles >
pesiapplicatcns | ] Microsoft User Data >
=) Desktop [ Quosa >
9 SWIFT >
3 Documents — )
7] Test files >
~ - =— ... _

For IMPORT Filters: Place the new files in your “Filters” folder
For OUTPUT Styles: Place the new files in your “Styles” folder

@ EndNote X7 File m References Groups Tools Window Help NCXt, go to your llbrary and
e select “Import Filters” from your
c BB e Edit menu
My Library . Copy #C

8 Al References ‘ tory effects of Scutellaria barbata D. L Chose “Open Filter Manager”

O unfiec > | Clear dis Rhizoma: protective effects againt A new window will pop up.
e Select All A ‘0 cytotoxicity of berberine against He
W Trash Copy Formatted sgK dlementary and alternative medicine: | . .
R Find and Replace... 3R :rine inhibits HIF-1alpha expression vi Scroll through the list of choices
' on noncovalent complexes of cytoto :
: in the new menu to select the
ﬂ' New Group ‘m Spelling > rns of gene expression upon infection
o AT Change Case » rine is a novel cholesterol-lowering di filter you saved.

tio-selective inhibition of (1R,9S)-and |
v glucosyl feruloyl quinic acid as a pot
Quick Search... “C38F ‘ential protein expression of the inhibit
ole of Coptidis Rhizoma extractinare

Font >

Output Styles == — S

Import Filters > New Filter...

Connection Files > Edit "JGembase test" i
- |__Open Filter Manager... _ ol

Start Dictation... fafn s or natwrar neann proaucts on piood

Emoji & Symbols  ~3Space lation of apoptosis by berberine throu



[ ] [ ] EndNote™ Filters

) Q All Filters H v

i Showing 389 of 389 filters.

| Favorites Name ~ Information Provider
Glopbal Keporter (UL)  UIALUG
GPO (OCLC) OCLC

| GreenFILE (EBSCO) EBSCO

! HAPI (EBSCO) EBSCO
HAPI (OvidSP) OvidSP

| Harvard Business Rev | DIALOG

\ HAWC endnote import Generic

B HCAplus (STN) STN

Health Source Cons Ec EBSCO
Health Source Nurs Ed EBSCO
Health Tech Assess (EE EBSCO
Health Wellness (DL) DIALOG

Click the box to the left of the filter you would like to make available in your library. Anything
with a blue check in the box will be available in your choices for the import process.

Close the box when you finish, and return to your library to use the filter.

For new output styles, use the same process but choose “Output Styles” from the Edit menu
instead.

Changing the displayed fields in your Endnote window

You may display 10 fields at a time in your library view window. You may change them in the
library screen (one at a time) or go to the Preferences window to make multiple changes at one
time.

To change which fields are showing within the library window, right-click in the header bar
where you would like to add a column

A list of fields will open showing the fields in use in black text with a check, and fields not
displayed grayed out.

Author Year Title

Alonso Ma, J. 1998 Some frequently 1pr
Carvalho, L. J.C.B;; L... 2012 Characterizatior ¥ Author and
Efferth, T.; Chen, Z; K... 2005 Molecular detert j\T(?t?e’ tol
L 2000 MTreatment el v Journal/Secondary Title

Kao, D.; Raja, H. A,; P... 2015 Triggering epipo ynt
Komala, M.; Bhowmik... 2013 Urinary tract inf sis
Li,Z.; Geng, Y.N.; Jia... 2014 Antioxidant and ber
Naik, S. R.; Thakare,... 2010 Functional foods juvi
Ozbalci, C.; Karaosm... 2010 Comparative tra i fo

If you don’t have 10 fields showing already, you may simply check an additional field and it will
be added. (You will have to add them one at a time, as the choice list closes after each selection)



If you already have 10 displayed, you will need to click one of the checked fields to remove it,
then re-open the choice list to add the new field.

If you have several fields to add or remove it may be easier to open the utility and assign the
fields there.

Go to “Endnote” in the top menu and select “Preferences”
In the window that pops up, chose “Display Fields”

& RECUTEOY M File Edit References Groups Tools Window Help

About EndNote X7.2.1 ) EndNote™ Preferences g-
o
Customizer... Change Case , . , ) .
Check for Updates... Display Fields Fields to display in the Library window: E
Display Fonts Position Field Heading
=0 D.uphcates Column 1: Author a Author
@¥un  Services > Find Full Text f—
p Folder Locations Column 2: Year H Year
¥ ™ Hide EndNote X7.2.1  3H Formatting Column 3: Title B Tite
. Hide Others X #H Libraries —
M ShowAll PDF Handling Column 4: Volume o Volume
Read / Unread . B
¥ FIb - Quit EndNote X7.2.1  #Q Reference Types Colpale: Pages 9 Pages
| - | i Column 6: Journal/Secondary Title | Journal
Ozbalci, C.; Sorting E’
Pradhan, P Sync o Column 7: Name of Database §J  Name of Database
Temporary Citations _—
Raja, H. A, Term Lists Column 8: Custom 8 H Custom 8
Safavt. URLs & Links Column9: | DOI B ool
Sunila, E. S —
Yarnell, E.; Column 10: Accession Number B Accession Number
Yarnell, E.;
Note: Selecting the 'Figure' and 'File Attachments' fields will display an icon in the
Gentry, E.« library window.
Abde"“"l; Display all authors in the Author field.
Inbaraj, J. «
Weber, H.J
Little, J. W. EndNote Defaults
Richard, C. .y

Select the fields by their systematic fields name in the left column *Here you will need to know
the number for any custom field you wish to display.

In the right column you have the option to edit the way the field is displayed in your library.
You may chose to change the heading for Custom 8§ to “PMID”.

You may set the order here with the top (Column 1) representing the first column on the left,
proceeding to the right as you go down. You may also drag and drop the headings in your
library window to change the order.



