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OBJECTIVES

Read quality bands coded in bits
Work with quality bands
Export image to a common .tif file format

Read datatypes from the metadata

KEY ELEMENTS

Bit-coded bands, format exchange, metadata

SOFTWARE

SNAP & QGIS

DATA

Level-1 and Atmosphere Archive & Distribution System Distributed Active Archive Center (LAADS DAAC)
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1. OPEN AND EXPLORE IMAGE FORMAT

Go to materials folder and search for the original Landsat 8 image file
‘LCO8_L2SP_190022 20200723_20200911_02 Ti.tar’.

Open the compressed file and inspect the content files. Extract the compressed .tar file in a new folder.
- Can you see any image insdie? Which file format does It have? Do you see any other files?

Open a SNAP session and import the image by clicking to ‘Import -> Optical Sensors -> Landsat -> Landsat 8 in
30m’.

Open the uncompressed folder location and select one of the MTL or ANG files.
Explore the object:

- Can you link all the rasters present in the ‘Bands’ and ‘Masks’ folders of the object to the .tif files in the
uncompressed tar file folder?

Check on the Landsat 8 Collection 2 Level 2 Science Product (L2SP) Guide the bands delivered in the the
product. Can you guess which bands should be opened to display a true colour image?

E [1] LCO2_LasP_190022_20200723_20200911_02_T1 - [C:\Usersr.lopez\Desktop\CREAP\EOTIST\WWP4_virtual_training\SR2_Main_data_sources\LC0¢

Pixelinfo | Product Explorer X =
File Edit View Analysis Layer Vecter Raster Optical Radar Tools Window Help =} @ [1] LCOB_L2SP_190022_20200723 20200311 02 T1
: & # =] 3 Metadata
S openproduct. A PR AnWORlL: LBE AT :
&3 Flag Codings
Reopen Product ¥ )
& ’ = sr_ga_aerosal
Product Libi ;
%4 Product Library i@ ga_pixel
Close Product @ qa_radsat
Close All Products (22 vector Data
Close Other Products -a;nds
il S G55 s
Save Product - [@ sr_b1(243nm)
Save Product As... Bl sr_b2(482nm)
Session > B s b3(s61.5mm)
Projects > B srb4(654.50m)
sr_b5 (865 nm]
Import 3] DEM 5 mﬂ b5 (¢ )
[El sr_bs (1608.5nm)
Export B Generic Formats » M@ sr_b7(2200.5nm)
Exit | optical Sensors > Alos AVNIR-2 > @ sr_os_aerosol
SARFormats > Alos PRISM > 2 st
SAR Sensors > lkonos > - [E st_b10 (10885 nm)
Vector Data > Kompsat N ~[E st_trad
- [@ st_urad
Landsat 2] Landsat8 in 15m (GeoTIFF) B st_drad
Pleiades > || Landsstin30m (GeoTFR) | [ st_atran
RapidEye B Landsat 5 TM (FAST) B st emis
Seadas > Landszt (GeoTIFF) ~[E st_emsd
Sentinel-2 H - [E st_cdist
Sentinel-3 > - stes
Spot > =] Es qa
@ ga_pixel
WorldView > H
@ ga_radsat
Aquarius -3 Masks
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2. DATA VISUALIZATION

Open a single band of the ‘Bands/sr’ folder by double click upon it in the
product explorer window. As it can be seen, this folder contains the surface
reflectance bands.

Can you spot differences in the differnt spectral bands? Could you link this
difference in reflectance values to the wavelength captured?

By picking one image tab and moving it, you can tile windows and link zooms,
which makes easier to compare different images or bands.

Now open the termic band from the ‘Bands/st’ folder. Which is the main
dfference with the solar spectrum wavelenths? What can you observe in the
clouds?

Oppen an RGB combination: Right-click to the image object and click ‘open
RGB image window’. Select the correspondant landsat bands to display a true
colour image ( R: Band 4, G: Band 3 and B: Band 2).

Can you see clearly the true clolur image? Which influence do you think the high amount of clouds have in the
image display?

3. AUXULIARY DATA

Landsat 8 Collection 2 level 2 data provide ||Pietinfo x| Product xplorer = =
. . . [=] Position
auxiliary quality and atmosferic state bands: ImageX suselpixel
Image-Y €792 |pixel
Longitude 15°15'55" E|degree
. H H . Latitude 53°47'17" H|degree
- QA_RADSAT: Radiometric saturation |75 Seoisoob
. Map- 53€1240.0/m
- QA_AEROSOL: Aerosol presence S
- QA_PIXEL: Pixel quality =] Bands
a_pixel 22280
[+] Tie-Point Grids
(check L2SP Guide, page 11). (=) Flags
or na asrnanl fill I £aleal

QA_PIXEL band, in the ‘bands/qa’ folder, is a bit coded band with information about several quality parameters.
Display the band and open the pixel info window ( ‘View -> Tool windows -> Pixel info’). Navigate through the
image and check the different values of the image. Open the statics of the image ( ‘Analysis -> Statistics’) and

=
select the band or reload the plot () to check the values distribution.

To read the image properly, it has to be considered the bit-coding of the image. Bit coding is usefull to pack
auxillary information as masks or quality flags in bits, which can be concatenated to merge all masks in a single
band. QA_PIXEL is a 16 bit band, but when reading the band in decimal format it is presented as 26 values
(65536 possible bits combination). The band is coded as follws:

EOTIST Standard Course Page3of3



Remote Sensing

LESSON SR2 — EXERCISE Remote sensing data sources

Being the fist column the bit position, and the third column the

possible combinations and the meaning of it:

For example, considering the cloud flag, the bit in the fourth
position, each combitanion of bits with a 1 in the fourth position will

indicate that the pixel is covered by cloud. { XXXIXXXXXXXXXXXX).

This results in 2%/2 theoretical possible combinations for a cloudy

pixel.
impossible under

probability (for example, combination of cloudy and clear pixels) .
Some of the most common values are listed in the table 6.3.

SNAP can read this band and build the
correspondant masks, located in the
‘Masks’ folder of the image. Open this
folder and display ‘clear’ and ‘cloud’
bands. By visual inspection. It can be
seen that this two bands are almost
(table
6.2) that clear pixels aslo include non-

complementary, considering

dilated clouds.

Open both QA_PIXEL and cloud and
move the cursor over the detected
clouds in the mask. Check in the Pixel
info window if you can see the
correspondant QA_PIXEL values for
cloudy pixels. To find less common
values, you can use other overlapping
masks, as cloud_shadow, or water (see
in Table 6.3 in the L2SP Guide).

Pixel Info X | Product Explorer

certain terrain conditions

Nevertheless, some combinations are rare or hardly
or

Bit Flag Description Values
0 for image data
o | 1 for ill data
" 0 for cloud is not dilated or no cloud
! Dilated Gloud 1 for cloud dilation
0 for Cirrus Confidence: no confidence level
2 Cirrus set or Low Confidence
1 for high irrus
0'for cloud confidence is not high
3 Cloud 1 for high loud
0 for Cloud Shadow Confidence is not high
4 | Cloud Shadow 1 for high loud shadow
0 for Snow/Ice Confidence is not high
§ | Snow 1 for high snow cover
6 Clear 0if Cloud or Dilated Cloud bits are set
1if Cloud and Dilated Cloud bits are not set
Ofor land or cloud
’ Water 1 for water
00 for no confidence level set
89 | Cloud Confidence @1 Low confidence

10 Medium confidence
11 High

10-11

Cloud Shadow Confidence

00 for no confidence level set
01 Low confidence

10 Reserved

11 High confidence

occurence

12413

Snow/lce Confidence

00 for no confidence level set
01 Low confidence

10 Reserved

11 High confi

14-15

Cirrus Confidence

00 for no confidence level set
01 Low confidence

10 Reserved

11 High

Table 6-2. Landsat 8 Pixel Qualify Assessment (QA_PIXEL) Bit Index

Cloud (Snow/

Pixel Dilated Cloud Ice | Cirrus|
Valug | Fill | Cloud Water |Conl. | Conl. | Conl. | Gonf. Pisxel

1 ‘es | No No | Mo No Mo | Mo | Mo [Mone | Mone | None | Mone (Fill
21824 | No No No | No No Mo | Yes [ Mo | Low | Low | Low | Low (Clearwith lows set
21836 | Mo | Yes No Mo No Mo [ Yes | Mo [ Low | Low Low | Low |Dilated cloud over land
21888 | No No No | No No Mo | Mo [ Yes | Low | Low | Low | Low [Watarwith lows set
21890 | No | Yes | No | Mo No Mo | Mo [ Yes | Low | Low | Low | Low (Dilated cloud over water
22080 | No | No No | Mo No Mo | Yes | Mo [ Mid | Low | Low | Low (Mid conf cloud
22144 | No No No | No No Mo | Mo [ Yes | Mid | Low | Low | Low [Midconf cloud over water
22280 | No No Mo | Yes No Mo | Mo [ Mo |High [ Low | Low | Low (High conf Cloud
23888 | No | No No | Mo Yes Mo | Yes [ Mo | Low | High | Low | Low [High conf doud shadow
23952 | No Na Mo [ Mo Yeg Mo | Mo [ Yes | Low | Hegh | Low | Low [Water with cloud shadow
24088 | No No Mo | Yes | Yes Mo | Mo [ Mo | M | High | Low | Low [Mid conf cloud with shadow
24216 | No [ No No | Yes | Yes Mo | No [ Yes | Mid | High | Low | Low [Mid conf cloud with shadow over water
24344 | No No No | Yes | Yes Mo | Mo [ Mo |Hgh | High | Low | Low [High conf coud with shadow
24472 [ No | No | Mo | Yes | Yes | Mo | Mo | Yes | Hgh | High | Low | Low [High conf coud with shadow over water
30048 | No [ No No | Mo No | Yes |Yes | No |Low | Low | Hgh | Low [High conf snowlce
54596 | No No [ Yes | No No Mo | Yes [ Mo | Low | Low | Low | High [High conf Cirmus
54852 | Mo No Yes | Mo No Mo [ Yes | Mo | Md Low Low | High |Cirrus, mid cloud
556052 [ No | No | Yes | Yes | Mo | Mo | Mo [ Mo |Hgh | Low | Low | High [Cirmus, high eloud
56856 | Mo No Mo | Yes | Yes Mo | Mo [ Mo | Med | High | Low | High (Cirrus, mid conf doud, shadow
56084 [ No | Mo | Mo | Yes | Yes | Mo | Mo | Yes | Mid | High | Low | High [Cirrus, mid conf doud, shadow, over water
57240 | No | No No | Yes | Yes Mo | No [ Yes |Hgh | High | Low | High [Cirrus, high conf clowd, shadow

Table 6-3. Landsat 8 Pixel Quality Assessment (QA_PIXEL) Value Interpretations

= Position

Image-X

Image-¥

Longitude

Latitude

Map-X

Map-Y

FH Time:

(=] Bands

jga_pixel

[ Tie-Point Grids
= Flags
= _az_aerosol.fil

false

s_ga_aerosol.aerosol_retrieval_valid

false

sr_ga_aerosol. water

false

sr_ga_aerosol.interpolated_serosol

true

s_ga_aerosol.acrosol_level_dimatology

false

sr_ga_aerosol.acrosal_level low

false

sr_ga_aerosol.acrosol_level_medium

false

sr_qa_serosol acrosol_level_high

true

ga_pixel.designated_fill

false

ga_pixel.dilated_cloud

false

ga_pixel.cirrus

false

fga_pixel.cloud

True

Ga_pixel.cloud_shadon

Talse

|ga_pixel.snow
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4. MASKS AND VISUALIZATION

To avoid cloud influence in reflectance derived products, such as NDVI or spectral classification this provided
bands can be used to set these pixels to NODATA.

Open the ‘Raster -> Band Math’ module and mask the non-clear pixels using the clear band for the bands 2,3,
and 4, corresponding to the true colour RGB bands. Introduce the following Expression: sr_b2 * clear, and a
recognizable band name. Notice the divisor parameter /255’ in the Expression formula. This parameter is
needed because the synthetic mask is coded in 8-bit (0 to 255) even though it just contains TRUE and FALSE
values, represented by 255 and 0 respectively. Make sure to untick the ‘Virtual’ box.

Open the resulting raster B Band Matns X | Colour NULE] -
. . Target product: ©ORed ()Green ()Blue 3 “
and repeat this operation : B
. |[1] LCO8_L2SP_190022_20200723_20200911_02.T1 - |
with the sr b3 and — | LTI
- ame: sr_b2_dear |
sr_b42_clear bands. Description: | |
o | | e———
Make true colour RGB Spectral wavelength:|0.0 | ° =
combinations both for [ virtual (save expression only, don't store data)
masked a nd ori inaI ba ndS Replace NaN and infinity results by ¥ Less Options
g ’ . . Histogram Brightness/Contrast
MOd If the COlOU r Generate assodated uncertainty band
y Band maths expression: Brightness ' 100
parameters in the Colour or_b2 = dear / 255 100 0 100
Manipulation window to e ¥ |
-100 0 100
get more contrasted Load... Save... Edit Expression...
images. Which of the two Saturation v o
; ; oK C | Help e E o
RGB combinations can you == Reset ®

see more clearly?

5. FORMAT CONVERSION

File Edit View Analysis Layer Vector Raster Optical Radar Tools Wir
. o - e R L XX N

To export the true colour images in a single file, it can g P —————— I speciy Product Subset
be used the multiband GeoTiff file format, among Gormase R S el

Close Other Products Bt Coastal Aerosol (Operatii
others. SoveProduct | B2 Biue (OLY

Save Product As.

[ EX-S Green (OL})

Session >
Go to’ File -> Export -> Geo Tiff’ and click to ‘Subset’. Projects » 8= L)

Import > Bsobs Near-infrared (NIR) (OL])
Here it is possible to choose the area to export, the — e ; @ose oo taveiensn nrwe

. . @ sr_aa_serosol SMOS EE Files to NetCDF... B =67 SWIR 2 (OL)
spectral and quality bands and the linked metadata. P e T
. . . o SMOS Grid Points
Select the True RGB bands (see it on the description) o oo Jpe-200 :ﬂ—“" TR
. . s csv st_urad Upwelled Radiance
and export to GeoTiff. Make a spatial subset of the o 81 Mo GeaFF /BT @sdes  Downwelied Radionce
. . . . SEAM-DIMAR 8 st_atren Atmospheric Transmittanc
total area by selecting in the image. Repeat this — o P
Colour Manipulation - [1] RGB X | GeoTIFF
operation with the three masked bands. Oret Ouen Ome | 0 B sciectal [ Sekectnone
I NetCDF4-CF

Tip: You can see the estimated file size of the export in the lower-right side of the window.
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Check the total image size of the new files. Why do you think the cloud-masked image is twice the size of the
original bands one? Do you think it is related to the data format? (Integer, Float...)

Open and visualize the files in a new Qgis session. Check the Image info the data type of each file.

Q@ "Untited Project — QIS - 8 x
Project Edt View Layer Settngs Plugins Vector Baster Ditabase Wieb Mesh Progessing Help

BLRH Des20 PPL. BatIOR a-D 0 CHTE-eo-m-

RQV./Zw B sy B ® ~a B

Pracessing Toolbox

- o

Search
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