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Image analysis workflow with OMERO
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Connections with Image Analysis Software

Non Exhaustive list of tools able to connect to OMERO directly or through plugins:

l ' Fiji napari P OMERO python API
J ezOMERO
CellProfiler Orbit @ rOMERO Gateway
QuPath llastick OMERO.matlab toolbox

https://www.openmicroscopy.org/omero/features/analyze/ Easing OMERO adoption with ezomero. Ratamero et al. bioRxiv 2023.06.29.546930;
https://omero-guides.readthedocs.io/en/latest/external_tools.html doi: https://doi.org/10.1101/2023.06.29.546930
https://omero-guides.readthedocs.io/en/latest/api_usage.html



FIji
Three ways of working with Fiji and OMERO:
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https://github.com/GReD-Clermont/omero_batch-plugin

https://omero-guides.readthedocs.io/en/latest/fiji/docs/index.html

[&¥ OMERO Batch Plugin

Connection
Source
Input
Images folder.

Macro

Macro file:

Output

Warning: all windows will be closed

Connection status: Disconnected Connect

Where to get images to analyse: OMERO i Local

Browse Recursive
Browse Set arguments
The macro returns:
New image(s) Results table(s) ROIs Log file

Where to save results: OMERO Local

Start

https://jipipe.hki-jena.de/




Opening the OMERO Fiji Plugin

[5° (Fiji Is Just) Image) - [m] X
i File Edt Image Process Analyze Window Help
1. Open Fiji and go to PN

Plugins » OMERO - Connectto OMERO ot o |

Utilities
New
Compile and Run...

2. Loginto OMERO with your user credentials.

Install Plugin...

| &Ri]>
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3D Viewer
Analyze

.:.:. O M E RO .insight z:gomavwer

Bio-Formats
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omero-training.gerbi-gmb.de wion & < Examples

Feature Extraction
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Image5D
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* v ¥ w w

Integral Image Filters
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LOCI
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Landmarks

Multiview Reconstruction _
Optic Flow *Save Image(s) to OMERO
.: :. OME Process *| Save ROIs to OMERO
Registration *| Save Results to OMERO
Ridge Detection
The Fiji-OMERO plugin looks almost precisely like SPM Registretion

Segmentation 1

OMERO.insight, butis, in fact, part of the open Fiji application v

Schindelin, J., Arganda-Carreras, |., Frise, E. et al. Fiji: an open-source platform for biological-image analysis.

Nat Methods 9, 676—682 (2012). https://doi.org/10.1038/nmeth.2019



Selecting images in the OMERO F

Select image(s)
from the file tree
Open in Fiji by
clicking

Full Viewer

and then

View In ImageJ..
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Taken from: Schmidt, C., Bortolomeazzi, M., Boissonnet, T., Fortmann-Grote, C., Dohle, J., Zentis, P., Kandpal,

N., Kunis, S., Zobel, T., Weidtkamp-Peters, S., & Ferrando-May, E. (2023). I3D:bio's OMERO training material:
Re-usable, adjustable, multi-purpose slides for local user training. Zenodo. https://doi.org/10.5281/zenodo.8323588
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Opening iImages in the OMERO F

Use your prefered settings
to open the image(s) as
required for your work, |
would recommend:

- Use virtual stack

- Import ROIs to ROI
manager if needed

]I Plugin

g Bio-Formats Import Options

Stack viewing

View stack with: | Hyperstack

Metadata viewing

v | [ Display metadata

Stack order: [xvezr

Dataset organization

I~ o
[~ Swap dimensions
™ Open all series

[ Concatenate series when compatible

[ Stitch tiles

Color options

~| I [Dispiay GME-XML metadata)

Color mode: Default

[V Autoscale

I Display ROIs

Memory management

" Group fik ‘ ir NAm Use virtual stack

[~ Specify range for each series

™ Crop on import

Split into separate windows

[V spiit channels

[~ Spit focal planes

~| [ Spit timepoints

ROIs import Mode: |Rowmanagcr 'l

-XML metadata -  °
a tree of metadata

ized into the OME data

odel. This structure is the same

file format, though

will populate more

n than others.

Examples:

@ The title of the dataset is
listed under OME >
Image > Name.

@ The time and date when
the dataset was acquired
is listed under OME >
Image > CreationDate.

@ The physical pixel sizes
of each plane in microns
is listed under OME >

-_—c A

OK I Cancel I




Practical 1: Let‘s count some cells.

Open one image from the ,,structuring_exercise” project using the OMERO Fiji Plugin.

Duplicate the image.

File Edit Image Process Analyze Plugins Window Help

ELO_G@/,Aﬁ*_‘\A,O_m‘_/Ii Ow [su || g | 4| &
thre

‘and (tracing) tool

Smooth the image (Process -> Smooth).
Run a Threshold (Image -> Adjust -> Threshold).
Analyze Particles (Image -> Analyze Particles, select ,Add to Manager”).

Close the segmented image.

Run Measure

Please leave the results and ROl manager Open for the next practical




Saving ROIs and Results Back to OMERO

[U°% (Fiji Is Just) Image) — [m]
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Taken from: Schmidt, C., Bortolomeazzi, M., Boissonnet, T., Fortmann-Grote, C., Dohle, J., Zentis, P., Kandpal,
N., Kunis, S., Zobel, T., Weidtkamp-Peters, S., & Ferrando-May, E. (2023). I3D:bio's OMERO training material:
Re-usable, adjustable, multi-purpose slides for local user training. Zenodo. https://doi.org/10.5281/zenodo.8323588




Viewing the ROIs and Results in OMERO
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Taken from: Schmidt, C., Bortolomeazzi, M., Boissonnet, T., Fortmann-Grote, C., Dohle, J., Zentis, P., Kandpal,

N., Kunis, S., Zobel, T., Weidtkamp-Peters, S., & Ferrando-May, E. (2023). I3D:bio's OMERO training material:
Re-usable, adjustable, multi-purpose slides for local user training. Zenodo. https://doi.org/10.5281/zenodo.8323588




Uploading images back to OMERO

Choose upload destination (Group, User, Project, Dataset) and upload

1 2

e Import Location - Select where to import your data. X “** Import Data — | X
5 Window Help
Group ., GROUP ~
v
Import For Mary Mayperson v o0

@ Projects gy Screens
Select Data toImport | Spedify MetaData V’Inwtﬂq

Project 2017 Nuc-Intens_Tcells ~ New...
Dataset 20130130_M42_totalERK v New...
' Report: 2 out of 1 uploadad Show Failed When upload is complete, the import
Import Size: 7 ME window and OMERQO session can be closed.
Add to the Queue | Reading will continue on the server.

Close Refresh

. 20180130_X_tERK_3h_02_czi-C=2--OMEROID_58037.ome.tif Upload NNNIENELCNNN Frocessing N

Taken from: Schmidt, C., Bortolomeazzi, M., Boissonnet, T., Fortmann-Grote, C., Dohle, J., Zentis, P., Kandpal,
N., Kunis, S., Zobel, T., Weidtkamp-Peters, S., & Ferrando-May, E. (2023). I3D:bio's OMERO training material:
Re-usable, adjustable, multi-purpose slides for local user training. Zenodo. https://doi.org/10.5281/zenodo.8323588




Practical 2: Let‘s save our results.

1. Save the ROIs and measurements back to OMERO.

2. Find and download the measurements from OMERO.web (Select the correct image and look
under , Attachments®)

3. Find and examine the ROIls in OMERO.web (Double click the image and go the the , ROI” tab).
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#OMERO  bs o & 3, oot
-r Y

Help  Figure
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How do | make this
workflow reproducible?



From manual workflows to Macros

Install....

File Edt Run

0 Ol( e
Magnifying g Startup Macros...
Interactive Interpreter. .

Set Drawing Color...

About Startup Macros...

Save As JPEG... [j]
Save Inverted FITS

Ctrl+J

Record... Ctrl+U Install....

Macros 4

Shortcuts

Utilities

New

Compile and Run...
Ctrl+Shift+M
Install Plugin_..

3D Viewer
Analyze

Bl
BigDataViewer

e

Attached to your data in OMERO
Added to a repository in github/gitlab and
then linked from your data in omero

File Edit Language Templates Run Tools

File Explorer

mo31i

Outline | *DetectNuclei.ijm

Window Options Help

*Analyse_dataset_and_save_rois.ijm

*Analyse_dataset_and_save_rois.i). -

1 // @String(label="Username") USERNAME

// @String(Label="Password”, style='password’, persist=false) PASSWORD
// @String(label="Host", value='wss://workshop.openmicroscopy.org/omero-ws") F

// @Integer(label="Port", value=443) PORT
// @Integer(label="Dataset ID", value=2331) dataset_id

"OMERO Extensions™);
connected = Ext.connectToOMERO(HOST, PORT, USERNAME, PASSWORD);
t (true);
if(connected == "true”) {

images = Ext.l
14 image_ids =

images”, “"dataset”, dataset_id);

lit(images, ,");

for(i=0; i<image_ids.length; i++) {
ij_id = Ext.getImage(image_ids[i]);
ij_id = (ij_id);

image_ids[i],
(“Image * + image_ids[i] + "

Run Batch REPL

T e e
Attachments 2 v
I}o e
DetectNuclei.ijm (487 B) - x
DetectNuclei_autoDataset ijm (1.90 KB) - X%

= O German-Biolmaging / fiji_omero_workflows

@ Issues

{> Code 19 Pullrequests (¥ Actions

@ fiji_omero_workflows ( Public




Practical 2: Running the macro

1. Download the , DetectNuclei.ijm“ macro attached to the ,structuring_exercise” Project
2. Drag the macro into Fiji
3. Open an image from the OMERO Fiji Plugin

4. Run the Macro

But I still need to interact with OMERO manually!

Tom Boissonet



Working with OMERO in FiJi Macros

OMERO Macro Extensions plugin

Plugin for simple access to OMERO objects from Fili macros.

https://github.com/GReD-Clermont/omero_macro-extensions = i o R o et

mo31i

Imagel2
Image) 1.x

‘ h e C k O u t t h e OMERO > Macro Extensions > Analyse dataset and save rois (Image) Macro)

template menu for
many examples.

>
>
>
Intro >
>
>
>

Tutorials

Analyse particles for another user (Image) Macro)

Annotate dataset (Image) Macro)
Background subtract batch (Image) Macro)

Crop rectangle from image (Image) Macro)

Import local file (Image) Macro)

Open image after download (Image) Macro)
Open omero image no download (Image) Macro)
Read key-value pairs (Image) Macro)

Remove rois dataset (Image) Macro)

Subregion from rois (Image) Macro)

Subregion save rois (Image) Macro)

Template run macro for another user on dataset (Image) Macro)

A

Run Batch Kill REPL Show Errors Clear 4
Autocompletion: Scilava supported triggered by Ctrl+Space & auto-display
Started DetectNuclei.ijm at Fri May 10 ©8:39:11 CEST 2024

Already installed in the Fiji app provided for the workshop




Getting an image from the macro

// @String(label="Username") USERNAME .

// @String(label="Password", style='password', persist=false) PASSWORD Make the user input the
// @String(label="Host", value='omero-training.gerbi-gmb.de') HOST credentials and address
// @Integer(label="Port"”, value=4664) PORT for OMERO

// @Integer(label="Image ID", value=2331) image_ 1id

run("OMERO Extensions");

Activate the OMERO plugin

W 00 N O BT H W N =

connected = Ext.connectToOMERO(HOST, PORT, USERNAME, PASSWORD); Connect to OMERO

=
w

Check if the connection worked

=
H

if(connected == "true") {

(R
o wn

Y Py

Get the image

[
~N

ij id = Ext.getImage(image_id);
Add your image processing
} code here

23 Ext.disconnect();

N NN =
N B © O

Disconnect from OMERO

L'J

Tom Boissonet



Practical 3: Run the macro

1. Download the ,,DetectNuclei_OMERO.ijm“ macro attached to the
,structuring_exercise” Project

2. Drag the macro into Fiji

3. Run the Macro

Now the macro is fully integrated with OMERO!




| nee
d to process a lot
Images! o
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Running the macro over a dataset

// @String(label="Username") USERNAME . .
// @String(label="Password"”, style='password', persist=false) PASSWORD Make the user lnpUt the CrEdentlaIS
// @String(label="Host", value='wss://workshop.openmicroscopy.org/omero-ws"') HOST and addreSS for OMERO

// @Integer(label="Port"”, value=443) PORT
// @Integer(label="Dataset ID", value=2331) dataset_id

run("OMERO Extensions");}- Activate the OMERO plugln
connected = Ext.connectToOMERO(HOST, PORT, USERNAME, PASSNORD} Connect to OMERO

1f(connected == “trye®) {} Check if the connection worked

images = Ext.list("images", "dataset", dataset_id); } Get |dS Of a” the images in the dataset

image_ids = split(images, ",");

for(i=0; i<image_ids.length; i++) {

ij_id = Ext.getImage(image_ids[i]);} Get the image from OMERO

ij_id = parseInt(ij_id);

NPT ———— — Add your image processing code here - Repeat for every

close("Results"); . . .
selectImage(ij_id); } Close image and remove all ROIs for the next cycle image in the dataset
close();
} —
o it~ Vi vl } Attach the results to the dataset
Ext.saveTable(table_name, "Dataset", dataset_id);

}
Ext.disconnect(); } Disconnect from OMERO




Practical 4: Run the macro on a dataset

1. Download the ,DetectNuclei_autoDataset.ijm“ macro attached to the
,structuring_exercise” Project

2. Drag the macro into Fiji

3. Have a look at the macro, where is the image processing code? How many times will it
be executed?

4. Run the Macro




Exploring tables in OMERO

Attachments 1 v

2024-05-11_15-52-15_Summary_from_Fiji (74.60 KB)

Download as CSV: | Whole Table |

2024-05-11_15-52-15_Summary_from_Fiji Show current page as: CSV | JSON

To filter rows you can use a query based on named columns. For example, to filter for rows where
TotalArea is greater than 322845.6777206989 add ?query=TotalArea>322845.6777206989 to the URL.
For a more complex example, try ?query=(TotalArea>322845.6777206989)&
(TotalArea<322845.6777206989)

Table rows: 4.

Image ImageName TotalArea Meanlintensity CellCount
343  Week1_150607_B02_s3 c1.tif 322845.6777206989 796.5457763671875 185.0
347  Week1_150607_B02_s4 c1.tif 322845.6777206989 901.1114013671875 267.0
491  Week1_150607_B02_s2_c1.tif 322845.6777206989 921.122509765625 253.0
576  Week1_150607_B02_s1_c1.tif 322845.6777206989 965.2109375 285.0

https://wiki-biop.epfl.ch/data-management/omero/omero-tablesttables-on-dataset-level




OMERO  Data History

Workshop Metadata Annotation

Explore Tags Shares
% N i}
|l example_data 2
[l example_data 2
[l example_data 2
[l structuring_exercise 60
B Week1_18746_B02 4
Week1_150607_B02_s1_c1.tif
Week1_150607_B02_s2_c1.if
Week1_150607_B02_s3_c1.tif
Week1_150607_B02_s4_c1.if
[C Week1_18746_B03 4
Week1_150607_B03_s1_c1.if
Week1_150607_B03_s2_c1.tif
Week1_150607_B03_s3_c1.tif
Week1_150607_B03_s4_c1.if
(B3 Week1_18746_B04 4
(B8 Week1_18746_C02 4
B8 Week1_18746_C03 4
(B8 Week1_18746_C04 4
B8 Week1 18746 D024

Figure

Q

Key-Value

Tag Search

OMERO.Parade setup

Admin

Thumbnails | general

[Add filter v |

§ ' root root
[\ ]

| Thumbnails NEy-vdiug rdiis 1

Auto Tag

Parade Add Key

Added by: Tom Boissonnet
compound

concentration

sample ID

week

Attachments 2

| Add filter.. v |

|Add table data... v |

Add table data...
ROI_count

Table_Image

Table_ImageName
Table_ TotalArea
Table_MeanIntensity

Table_CellCount
WEEK1_18746_C02

Add Value

5uM
18746

-

Show Datasets

{ Parade

-

Show Datasets oo




**OMERO

Data

Filtering data with OMEROQO.parade

History Figure

- Workshop Metadata Annotation

12-A-12 ome. tif

Value  Tag Search

Admin

| Parade

09-A-09_ome.tif

B 3. ot

Explore Tags Shares | Add filter... v | Show Datasets = L Eﬁ m| (g
% i o | Add table data... module3_data ’
[ module3_data 96 )
(£ module3_data 96 module3_data Dataset 2059
{3 module3_data 96 Lk _
@ module3_datage Name Table_Meanlntensity Table_CellCount Owner: g]clﬁglilieazzi (Showall |
3 module3_data 96 .
il module3_data 96 . 01-A-01.ome.tif Dataset Details =
(£ module3_data o o
B module3_data . Add Description ¢
02-A-02_ome. tif
(& moaule3_data Creation Date: 2024-05-11 14:35:44
3 module3_data 95
B3 module3_data 96 . T Tags O »
[ module3_data 95
i module3_data 96 Key-Value Pairs 0 v
5 moaule3_data 04-A-04.ome tif
[E3 module3_data . _
[E3 module3_data 96 e THE e
(£ module3_data 96 . 05-A-05.ome.tif
01-A-01.ome.tif Attachments 1 .
02-A-02.ome.tif
03-A-03 ome tif . 06-A-06_ome tif %
DA sl 2024-05-11_16-13-04_Summary_from_Fiji (74 63 KB)
05-A-05.ome.tif
06-A-06.ome tif . 07-A-07 ome tif S
07-A-07.ome.tif N S
08-A-08.ome.tif
09-A-09.ome tif . 08-A-08.ome.ti Ratings 0 b
10-A-10.ome tif
11-A-11_ome.tif Others 0 ’

https://wiki-biop.epfl.ch/data-management/omero/omero-tablest#tables-on-dataset-level




Viewing data with OMERO.parade

!:I:r OMERO Data
Workshop Metadata Annotation

Explore Tags Shares

I rruesd udka Ho
3 module3_data 95
£ module3_data 95
B module3_data 95
01-A-01.ome tif
02-A-02.ome tif
03-A-03.ome tif
04-A-04 ome tif
05-A-05.0me tif
06-A-06.0me tif
07-A-07.ome.tif
08-A-08.ome tif
09-A-09.ome tif
10-A-10.0me_tif
11-A-11_ome.tif
12-A-12 ome tif
13-B-01.ome tif
14-B-02.ome tif
15-B-03.ome tif
16-B-04 ome tif
17-B-05.ome tif
18-B-06.0me tif
19-B-07.ome.tif
20-B-08 ome tif
21-B-09 ome {if
22-B-10 ome {if
23-B-11 ome tif
24-B-12 ome tif
25-C-01.ome.tif
26-C-02.0me.tif

Q

ch Admin

Parade - General

| Add filter... v | Show Datasets ]
| Add table data... v
A
44200
[
® [
) [ |
[
[
[
— 35734 ®
> _|
[
5 °
5 °
= ® ® [ J
(o}
{IJI i
E ° Image Name: 26-C-02.ome-.tif
— 27547 _| Table_MeanlIntensity: 9.6486474609375
° Table_CellCount: 314
o §° o
[ ) ® o o
°® °
[
[
19300 | () I I
433 12,53 16.63 2072
|Tab|e_MeanInten5'rty v |
v

https://wiki-biop.epfl.ch/data-management/omero/omero-tables#tables-on-dataset-level

L

A

ln"

root root

Acquisition Preview
g | ol (v ool [ m | s Y
| Full viewer | |@| |ﬂ| |E| Atk i| [==a
26-C-02.0me tif 2]
Image 10768
1D:
Owner:  Michele ——————
Botolomeazzi [ Showall v |
Image Details =
Add Description |Z|
Import Date: 2024-05-11 14:35:44
Dimensions (XY): 640 x 640
Pixels Type: uintd
Pixels Size (XYZ) (um): -
I sections/Timepoints: 1x1 -
Channels: 0,1 Cd
ROI Count: 0
Tags O »
Key-Value Pairs 0 =
Add Key Add Value
Tables 1 »
Attachments 0 v
(%) [+
Comments 0O 4
v



Practical 5: Projects and Beyond

Try to answer the following questions (no code needed):

* How would you make the macro work on all datasets in a project?

* | want the macro to process only specific datasets or images whitin the project, how
could | select the images/datasets | need?




Can‘t | just use the macros
| already have?



OMERO Batch Plugin for FiJi

[F OMERO Batch Plugin — O X

OM ERO BatCh Plugin for Fiji Waming: all windows will be closed.
. Connection
Runs a macro on a dataset of images (local or

in OMERO) and saves the results (locally orin | sou
OMERO). Very efficient way to build OMERO

Connection status: Disconnected Connect

Where to get images to analyse: OMERO (®) Local

Input
based workflows from pre-existing macros. images flder Browse [ | Recursive
https://github.com/GReD-Clermont/omero_batch-plugin Hecre _— e
The macro returns:
New image(s) Results table(s) ROls Log file
Output

Where to save results: OMERO Local

Start

Pouchin P, Zoghlami R, Valarcher R et al. Easing batch image processing from OMERO: a new toolbox

for ImageJ [version 2; peer review: 2 approved]. F1000Research 2022, 11:392
[ 10.12688/f1000research.110385.2)



https://doi.org/10.12688/f1000research.110385.2

| would still prefer a
graphical interface



JiPipe: visual batch processing with Fiji

JIPipe - C:\Users\m031i\omero_workflow_test.jip

Plugin for visual macro programming, it can ™ m= ™ Eitresirecs | Mo

© Projectoverview © By Analysis © IR Logviewer @ B4 Compartments ©

CO n n ect to O M E RO a n d a I IOWS t h e S Adddata [ File system @ Annotations ¥ Images ROl HH Tables [3 Export ¢ Miscellaneous ) 1J
L3

. . : ®
eX p O rt/l m p O rt Of ' ; @ +*» Define dataset IDs @ = Define image IDs
- Images [ owa 3 ouma :
[
- ROls = )
‘».* Input
= Ta b | es ; (») © Download image from OMERO
" £ Ooutput

]

£ image
@ m Extract ROI from OME image

Very flexible, can support complex pipelines. -
[ nput

@ ¥ Splitinto individual ROl lists

Very nice Ul, and documentation. B o

:

2023-08-27 14:34:52 Activated tool 'No tool’

Gerst, R., Cseresnyés, Z. & Figge, M.T. JIPipe: visual batch processing for Imagel. Nat

Methods 20, 168-169 (2023). https://doi.org/10.1038/s41592-022-01744-4



Resources

Fiji

* Documentation on all macro Functions
https://wsr.imagej.net/developer/macro/functions.html

 OMERO and Fiji macro tutorial
https://omero-guides.readthedocs.io/en/latest/fiji/docs
/threshold scripting macro language.html

* Fiji + Python Bioimage analysis tutorials
https://www.youtube.com/watch?v=e-2DbkUwKk4&|
ist=PL5ESQNfM5Ic7SAMstEu082ivW4BDMvdOU

OMERO

e BIOP guide for all things OMERO:
https://wiki-biop.epfl.ch/en/data-management/omero

*  OMERO Traning material:
Image Data Management with OMERO at the DKFZ - Overview

https://zenodo.org/records/8323588

e Official OMERO user guides
https://omero-guides.readthedocs.io/en/latest/



https://wsr.imagej.net/developer/macro/functions.html
https://omero-guides.readthedocs.io/en/latest/fiji/docs/threshold_scripting_macro_language.html
https://omero-guides.readthedocs.io/en/latest/fiji/docs/threshold_scripting_macro_language.html
https://www.youtube.com/watch?v=e-2DbkUwKk4&list=PL5ESQNfM5lc7SAMstEu082ivW4BDMvd0U
https://www.youtube.com/watch?v=e-2DbkUwKk4&list=PL5ESQNfM5lc7SAMstEu082ivW4BDMvd0U
https://wiki-biop.epfl.ch/en/data-management/omero
https://intracoop.dkfz-heidelberg.de/sites/OMERO-DKFZ/SitePages/Overview.aspx
https://zenodo.org/records/8323588
https://omero-guides.readthedocs.io/en/latest/

Summary

Different ways to use OMERO and Fiji for workflows that are:

 Reproducible
* Automated

For any questions please get in touch

| would like more...
— P OMERO python API
ezOMERO
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