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Generating a high-quality 3D model using the Artec Leo Scanner 

 

This document illustrates the procedure for obtaining a high-quality 3D model complete with textures, 

starting with a 3D scan of an object (in this case a runestone) using the Artec Leo scanner.  

The following steps will be explained in the tutorial: 

- Scanning  

- Processing of data 

- Model creation 

- Creation and application of textures 

- Exporting the model 

 

Overview of the scanner 

Leo is a structured light scanner that emits a known light pattern and observes how it deforms to 

calculate the geometry of an object. It has a built-in NVIDIA graphics processor for real-time 

processing, so Leo does not need to be connected to a computer to scan. It is capable of capturing 

medium (20-50 cm) and large (50-200 cm) objects and surfaces. 

 

1. Scanning 

1.1. How to scan  

Scanning objects is a straightforward process, however, it is essential to follow specific steps. This 

summary outlines the necessary steps for successful scanning (source https://support.artec-

group.com/hc/en-us/articles/202386772-3D-scanning-in-6-easy-steps): 

- Ensure an adequate number of features are available for tracking. 

- Maintain the surface centered on the screen while scanning. 

- Focus solely on the screen, avoiding distraction by the object. 

- Continuously observe the distance meter. 

- Avoid rapid movements of the scanner. 

- Approach the object from various angles by adjusting wrist movements. 

 

- More detailed instructions concerning the full procedure (it might slightly change depending 

on the object to be captured) can be found here (https://docs.artec-

group.com/leo_/1.8/scan.html#le-scan) 

mailto:danilo.marco.campanaro@ark.lu.se
https://support.artec-group.com/hc/en-us/articles/202386772-3D-scanning-in-6-easy-steps
https://support.artec-group.com/hc/en-us/articles/202386772-3D-scanning-in-6-easy-steps


 
 

1.2 Processing of data 

For data processing, this tutorial will make use of the Artec Studio which is a software developed by 

Artec 3D featuring tools for aligning, merging, and cleaning up 3D scan data to produce precise and 

comprehensive 3D models ( https://www.artec3d.com/3d-software/artec-

studio?utm_source=google&utm_medium=cpc&utm_campaign=1954117596&utm_term=%2Bartec

%20%2Bstudio||kwd-

335990212475&utm_content=72277307938||&keyword=%2Bartec%20%2Bstudio&gad=1&gclid=Cj

wKCAiAxreqBhAxEiwAfGfndOh9GdX14jd7h4UGZebtmJGMPXSsNm9vTzrN4JH0SXEkxrufvL9i

AhoCdOQQAvD_BwE) 

Once the data is acquired, it must be transferred to a personal computer. This can be accomplished using 

various methods: 

- Copy the project using a shared network 

- Upload the project to Artec Cloud 

- MicroSD Memory Card 

- For this tutorial we have used the third method. For the first two methods, please refer to the 

official guide https://docs.artec-group.com/leo_/1.8/projects.html#copy-project 

 

Copy data from device’s internal storage to SD card. 

- Take out the microSD card from Leo. 

- Place the card into a microSD reader linked to the computer running Artec Studio. 

- Transfer files to the computer. 

- Launch Artec Studio. Choose File → Import → Leo project. Browse through the folder 

structure to locate the desired project (See Fig.1). 

 

Figure 1. The scans are imported in Artec Studio (image credit: the author). 

Maximum Error and Registration Quality 

An essential factor to consider is the error, which indicates the quality of frame recording that comprises 

each individual scan. A higher value indicates less accurate alignment. The Artec scanner includes 
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reference ranges for error, which are available here https://docs.artec-

group.com/as/18/en/process.html#maximum-error-and-registration-quality 

For scans conducted with Leo errors ranging from 0.0 to 0.5, they are deemed good, while those between 

0.6 and 1.3 are acceptable, and errors above 1.4 are deemed unacceptable. 

It is recommended to eliminate frames with a value exceeding 0.5 (Fig. 2) to ensure consistency. 

This procedure should also be repeated after Fine Registration and Global Registration are complete. 

 

Figure 2. The error associated with the frames is showed in the quick toolbar on the right (image credit: the author). 

 

1.3 Editing Scans 

Erasing Portions of Scans 

Various scans may show parts of surfaces that are not relevant to the object of our interest, such as the 

surface of a rotating table when 3D scanning a small object. We may need to remove these sections by 

going to: 

Editor → Eraser 

Various methods are available for eliminating unnecessary points. For extremely regular surfaces, such 

as the turning table in the previous example, Base selection and Cutoff-selection may prove most 

effective. In this specific instance, however, the Lasso selection method was used. This option permits 

the creation of a customised selection either through freely outlining an irregular area using Ctrl+LMB 

or by releasing LMB (not Ctrl) and then selecting a desired shape by clicking. 



 

 

Figure 3. The Eraser tool in Artec Studio (image credit: the author). 

 

Figure 4. The lasso selection in the Eraser tool (image credit: the author). 

 



 
1.4 Fine registration 

Fine registration is a process created to accurately align captured frames. To perform a scan registration, 

simply mark the frames in the Workspace panel. 

Subsequently, it's critical to assess whether the error level has altered and, if necessary, eliminate all 

misaligned frames (labeled as "failed") or those with an error level exceeding the predetermined limit. 

 

Figure 5. The Fine Registration tool in Artec Studio (image credit: the author). 

 

1.5 Alignment 

The process of aligning brings together the individual scans. There are different methods to align scan 

groups in Artec Studio. For a complete explanation, please refer to this guide. https://docs.artec-

group.com/as/18/en/process.html?highlight=incorrect#alignment 

For the specific instance, we have decided to use the auto alignment method as it is the easiest approach. 

Its advantages include the ability to align multiple scans at the same time without the need for specifying 

points. The only downside is that the scans being aligned must have overlapping areas of at least a 

minimum size. 

These are the steps to be followed: 

- Indicate the scans for alignment purposes. 

- Choose the "Best fit" option within the Align panel. 

- Activate the Auto toggle under the Points setting, then proceed to click on Align. 
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Figure 6. The alignment tool window in Artec Studio (image credit: the author). 

 

1.6 Global Registration 

Once the scans are lined up, they must be registered with Global Registration. 

To do so, select all the aligned scans in the Workspace panel, then click on Tools → Registration. Make 

sure to choose Global as the registration type in the Registration pop-up. Check the Preset field located 

on the Tools panel and make sure it displays the scanner you used for the selected scans (in this case 

Artec Leo). Leave the default setting as shown in the figure (the different parameters are explained in 

detail in this guide https://docs.artec-group.com/as/18/en/process.html?highlight=incorrect#global-

registration) and click Run. 
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Figure 7. The Global registration tool in Artec Studio (image credit: the author). 

2 Model Creation (Fusion) 

2.2 Outlier Removal 

Before creating the models, it is recommended to remove any outliers that represent small, unconnected 

surfaces (fig). Go to Open Tools → Fusion → Outlier removal. Here there are two parameters that can 

be changed: 

3D-noise level 

3D resolution 

3D-noise level. It can be set to 2 for noisier surfaces or 3 for less noisy surfaces. In this specific case, 

we have applied the default setting of 3. 

3D Resolution. This refers to the resolution of the Fusion process that will be conducted later, which is 

dependent on the type of scanner used during acquisition. For this particular case, we utilized the default 

value of 0.5.  



 
Click Apply. 

 

Figure 8. The outlier removal tool (image credit: the author). 

2.3 Fusion 

Once the model has been cleaned, we can proceed with the creation of the fusion (or the model) using 

Tools → Fusion 

Several options exist depending on the type of scans. Refer to the Artec guide for a comprehensive 

description of the algorithm: 

https://docs.artec-group.com/as/18/en/process.html?highlight=incorrect#creating-models-fusion 

Three main types of fusion are available: 

- Smart Fusion (smooth) – designed for noisy datasets. 

- Smart Fusion (sharp) – tailored for scans with intricate details. 

- Fast Fusion (legacy) – delivers rapid outcomes for extensive datasets. 

For the particular instance, the smart fusion was applied with the default value of 0.5 while activating 

the fill holes attribute - All(watertight). It is suggested to use the latter only if the scans cover most of 

https://docs.artec-group.com/as/18/en/process.html?highlight=incorrect#creating-models-fusion


 
the geometry and there are no alternatives to cover areas not captured by points (e.g., conducting a new 

scanning campaign). 

Apply the Fusion algorithm. A sharp fusion model should appear in the layers tab on the right. 

 

Figure 9. the Sharp Fusion algorithm in Artec Studio (image credit: the author). 

 

2.4 Creation and application of textures 

The sharp fusion model was created without any colour information. To add it to the model, we need to 

run the texture algorithm (figure) 

First we select the model we want to texture in the 'Select model to texture' box. Then we select the 

texture source. This can be a series of scans (which retains the colour information captured by the 

scanner) or a Photoset, which is a series of images taken for a specific purpose.  

In this section we will examine both the techniques. 

2.4.1 Color from scans. 

The scans associated with the fusion model appear in the "Select texture source" box. We can select one 

scan and add more by pressing CTRL+LBM. Once this is done, a texture destination should be selected. 

Two methods are offered: 



 
Preview (triangle map) 

Export (texture atlas) 

Preview gives a quicker result, allowing you to evaluate the final effect of the textures on the model. A 

full description of the different parameters can be found here: https://docs.artec-

group.com/as/18/en/process.html?highlight=incorrect#texturing 

For this tutorial we will create a texture for export using the default values and resolution with the 

following steps: 

- Select the required Output texture size. 

- Click Apply to start the texturing process. 

 

When the texture is ready, you can also adjust it if necessary (see the guide here https://docs.artec-

group.com/as/18/en/process.html?highlight=incorrect#adjust-texture) 

 

Figure 10. Textures generate from the scan color (image credit: the author). 

 

2.4.2 Photo Registration  

The photo registration algorithm in Artec Studio allows textures to be applied to models using 

photographs. Using photos of the object, this algorithm projects textures onto fused models. This 

sophisticated texturing method is effective for capturing intricate textures and greatly enhances models. 

Taking photo 

The following steps should be followed to use photo for the Photo Registration (see also 

https://support.artec-group.com/hc/en-us/articles/4409061047826-Photo-Registration-HD-texturing-

tips-and-tricks): 

- Ensure that the object can be reached from all angles without obstruction. 

- Keep the object still when capturing photos. 

- Decide on a suitable distance for photographing the object, avoiding being too near or too far. 
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- Use a consistent focal length for all photos so that they can be properly aligned. Avoid altering 

focus or using auto-focus as it can affect registration. If different focus settings are necessary, 

organize photos in separate folders, import them individually, and register them separately. 

- Make sure the images are well-lit and adjust the white balance as needed. 

- Avoid using a photo flash to prevent glare. 

- Maintain a consistent camera orientation throughout the capture process and refrain from 

rotating the camera. 

- When taking multiple photos, make sure to move the camera with a 66% or 2/3 overlap. Follow 

the rule that every point on the subject should show up in at least three photos. 

 

Photo Registration 

Go to Tools → Registration →Photo Registration 

Select the Photo set the Fusion model and the related scans and apply the algorithm with default settings 

on. 

- Define the Feature density is related to the number of feature present (e.g. upholstery would 

require higher settings).  

- Tick Image pre-processing applies contrast to the images from the scanner. This is needed for 

Artec Eva and Artec Leo. 

- Apply 

Texture creation 

Go to Texture on the left panel and follow the same procedure as in the previous paragraph “Color from 

scans” selecting Photo set in the Select texture source and then apply. 

 

Figure 11. The color information from the texture are applied to the model (image credit: the author). 

3 Exporting the model 

Select the Sharp fusion model you want to export in the quick toolbar on the right (layers) and then go 

to File → Export → mesh  

Assign a path, a name for the model and a format and click OK. 


