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Abstract
The use of porous templates for controlled formation of nanostructures and nanosystems
requires reliable method of pore size, shape, quantity per unit area (porosity), distance to nearest
neighbors and porous matrix thickness monitoring. The scanning electron microscopy method allows
to estimate these parameters, however, manual processing of obtained images is a very timeconsuming task. The use of ImageJ software makes it possible to significantly simplify the process
of obtaining detailed statistical information about templates surface. Taking that into account, the
work describes in detail the methodology for analyzing of scanning electron microscopy images of
SiO2/Si ion-track templates surface to control pore size, shape, unit area and distance to the nearest
neighbors. The method for estimating thickness of SiO2/Si ion-track template based on processing of
data about surface is also proposed. It is important to note, that the techniques described in this paper
not only allow to effectively control SiO2/Si ion-track template pore parameters, but also suitable for
other types of porous templates.
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1. Introduction
Nowadays nanoindustry is involved in many fields: environmental protection, biotechnology,
medicine, electronic devices and etc. [1–6]. Depending on potential applications, materials with
unique physical properties are required. This determines relevance of searching of methods for
controlled synthesis of nanoobjects with predetermined characteristics. Among the wide variety of
techniques template synthesis can be distinguished due to its simplicity, low price and high quality
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[7–14]. The method is based on using of porous matrices (which are templates based on polymer,
silicon or oxide materials) as a form-building basis for realization of nanostructures [15–22]. By using
such approach structures are formed by controlled self-organization of matter in pores. It makes
possible to obtain arrays of nanostructures with different morphologies: particles, rods, tubes,
dendritic structures [23–26], which can be useful for creation of new types of electronic devices,
sensors, systems of biological control and etc. [19,27]. Due to simple adaptation to standard of silicon
technology silicon-based templates are of great interest. The ion-track technology is a simple method
of templates based on silicon and its oxide layers forming [7]. With such approach, it is important to
control such templates parameters as height, external and internal pore diameters and their density.
For this purpose various software solutions can be used. In particular, one of the most effective
methods is using ImageJ software in analysis of scanning electron microscopy images. This method
allows to determine a wide range of pore parameters for obtaining a large amount of statistical
information. Therefore, in this paper we demonstrate the possibility of surface analysis by SEM with
ImageJ post-processing for SiO2/Si ion-track template parameters control.
2. Methods
Amorphous SiO2 ﬁlms were thermally grown on (100) n-type (P-doped) silicon wafers of 524
nm thickness in a pyrogenic environment at 1050 °C. Irradiation of the SiO2/Si substrate was carried
out at the DC-60 accelerator (Astana, Kazakhstan). Samples were bombarded at normal incidence
with 208Bi ion with an energy of 1.75 MeV/nucleon, at ﬂuence 2 × 107 cm2. Low ﬂuences were chosen
in order to minimize the spatial overlap of the individual conical pores appearing after etching of
latent tracks in SiO2. Conversion of ion tracks into pores was carried out by etching in hydrofluoric
acid at a concentration of 1% for 58 minutes at room temperature.
Morphology of the porous samples was characterized by field emission scanning electron
microscopy (SEM), using a JEOL JSM-7000F microscope at 5 kV accelerating voltage. At higher
accelerating voltage the sample surface will charged which greatly complicates the processing of
information. At a lower accelerating voltage, it is difficult to obtain a high-quality image. This
approach allows defining all the characteristic dimensions of the pores. However, only few pores can
be analyzed in this way, leading to poorer statistical representation. Image analysis was performed
with ImageJ software with ImageJ2 version [30]. The ImageJ package is a free cross-platform
software with an open architecture that allows calculating areas, statistical indicators of pixel values
of different areas on images, extracted manually or using threshold functions [31].
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3. Algorithm of porous templates SEM images post-processing by ImageJ software
Surface analysis by ImageJ post-processing of SEM images was carried out on images of the
SiO2/Si ion-track template surface, typical for the selected irradiation and etching modes (Fig. 1a).
From Fig. 1a it is seen that in connection with the random nature of the ion distribution in the
irradiating beam, the pores in the oxidized silicon layer are stochastically distributed. Determination
of pores characteristic parameters was carried out by using of Analyze Particles (Analyze → Analyze
Particles) command of ImageJ software. Running the Set Measurements command (Analyze → Set
Measurements) allows to set analyzed parameters. The selection of parameters in menu (Measure →
Set Measurements), Analyze Particles determines which statistical data about image (area and
perimeter of selection, tilt angles, pore coordinates and etc.) will be displayed in a special window
Results.

Fig. 1. (a) SEM image of porous SiO2/Si template surface, (b) setting the threshold by using of ImageJ command
Threshold, (c) image after binarization and (d) result of command Analyze Particles execution.

For efficient data processing, preliminary preparation of images by standard command of
ImageJ package Threshold (Image → Adjus → Threshold) and image binarization (Process → Binary

→ Make Binary) is necessary. Using of Threshold command allows you to interactively adjust upper
and lower threshold values for segment of area of interest and image background (Fig. 1b). The
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threshold level is determined by analysis of histogram of current selection or full image if there is no
selection. Setting of minimum and maximum exceptions ranges from different parameters after
binarization (Fig. 1c) allows to extract information from binary image.
A more detailed image description can be obtained by using of BioVoxxel Toolbox [29]. The
Extended Particle Analyzer is based on ImageJ command Analyze Particles and allows to restrict
particle analysis in accordance with many parametric descriptions of shape and angular orientations.
The results output types are the same as for Analyze → Analyze Particles, namely: converted image
and two-dimensional array of described above statistical data. It is possible to obtain information
about the pores like area, extent perimeter, circularity, roundness, solidity, compactness, aspect ratio,
Feret aspect ratio, ellipsoid angle (degree), max and min Feret, Feret angel and coefficient of variation
by using of Extended Particle Analyzer. Information about function, which is realized by separate
line, is shown in Fig. 2.
The output form of the results can be also set for working with them (display results, summarize,
reset after analysis, clear results, add to manager) and for include/exclude of objects located on border
of image and on area inside segmented regions (include holes, exclude edges).

Fig. 2. Setting parameters in Extended Particle Analyzer, where S – area, Sc - area of a convex domain, P – perimeter,
Dmax – maximum diameter, StdDev – standard deviation of the area, Mean – mean value of the area.
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It is possible to obtain information about distance between the nearest pores with the plugin
Nnd (Plugins → Nnd), which is added to built-in functions of ImageJ. As a result, the screen displays
an image with pore contours and their numbering (Fig. 1d), as well as a window with a table, which
contains information about distance to the nearest neighboring pore. The distance between the nearest
neighbors is determined on the basis of following approximations. In tightly-packed configuration of
pores having a circular cross-section in 2D space, there are 6 neighbors surrounding each particle. In
random system order the coordination number depends on visual perception and can be lower or
higher. Estimation of particle's distance to its neighbors is performed by following algorithm:
determination of coordinate of each particle gravity center (X, Y) based on the results table of builtin plug-in Analyze Particles constructing circle on each particle with center (X, Y) and radius r (Fig.
3) → determination of interval (wall thickness) between a pair of particles (dp) according to the
correlation:
𝑑 =

(𝑌 − 𝑌 ) +(𝑋 − 𝑋 ) − (𝑟 + 𝑟 )

(1)

Further, the distance from each pore relative to all other pores is stored in array and sorted, and
finally, average distance is calculated depending on coordination number [19].

Fig.3. Determination of pores radius and distance between pores by using of plugin Nnd.

4. Analysis of SiO2/Si ion-track template parameters
The results of determination of pores number, their total area, average size and standard
deviation from this value, substrate porosity, as well as pore deviations from the round shape and
average pore distance by using of Analyze Particles command and Nnd plugin are given in Table 1.
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Table 1. Basic pore parameters determined by using of ImageJ.
Number
of pores

Total pores
area, µm2

The average
pore size, µm2

69

8,2

0,12

Average
standard
deviation, %
4

Porosity, %
2,2

Pore deviation
from round
shape, %,
5

Average distance
between pores,
µm
1,45

On the basis of obtained results, the average value of upper pore diameter (D) – 0.39 μm is
easily determined. The total area of image was 371.84 μm2, it allows to calculate number of pores per
unit surface – 1.85 × 107 cm2. The obtained value is lower than irradiation fluence (2 × 107 cm2)
because selected parameters of command Analyze Particles were set so as to automatically exclude
pores, which are partially outside the image. The presence of such pores is easy to see during
comparing of SEM image and its processed version (Fig. 1a and 1d). The average distance to the
nearest neighbor of each pore was 1.45 μm, it agrees well with theoretical calculations for the chosen
fluence, given in [7]. It is important to note that standard deviation from average area value for each
pore does not exceed 4%, and shape deviation from an ideally round is less than 5%. The small values
of these parameters indicate the high quality of the SiO2/Si templates obtained by ion tracks chemical
etching.
Typically, the determination of pore parameters such as silicon oxide thickness after etching (l)
and internal pore diameter (d) requires study of SiO2/Si ion-track template cross section, which is
time-consuming task. In addition, information on thickness of template obtained by using of SEM
depends strongly on quality of prepared SiO2/Si ion-track template cross section and orthogonally of
sample cleavage plane electron beam. An example of SiO2/Si ion-track template cross section with
schematic representation of main pore parameters is presented in Fig.4.
It should be noted that for l and d determination, the method for estimating of thickness of
SiO2/Si ion-track template based on information on upper pore diameters obtained during postprocessing of SiO2/Si ion-track template surface images can be used. It is known that etching
parameters of irradiated SiO2/Si substrates and characteristics of resulting pores are interrelated
through a half-pore angle θ, which is determined by irradiation parameters. Earlier, in work [7] it was
shown that θ at high energies of irradiating ions (electronic energy value (dE/dx)e > 16 keV × nm-1),
pore characteristics do not depend on irradiating ion type, and the half-angles of etching cone are in
the range of 17° ± 2°. Calculation of silicon oxide thickness after etching and internal pore diameter
of SiO2 can be performed by correlations:
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Fig.4. SEM image of the SiO2/Si ion-track template cross section with schematic representation of main pore
parameters: D – upper pore diameter; l – silicon oxide thickness after etching; d – internal pore diameter; θ – halfpore angle.

𝑙=𝐿

,

−

𝑑 = 𝐷 − 2𝑙 · 𝑡𝑔𝜃.

(2)
(3)

During estimating of l and d, half angle was assumed equal to 17° and pore characteristic values
determined as a result of calculations were l = 0.257 and d = 0.231 μm. It should be noted that
information on θ is not known in advance, when irradiation energy of corresponding electronic loss
energy value 16 ≥ (dE/dx)e ≥ 4 keV × nm-1, but once obtained information on this parameter it can be
extrapolated to all experiments of pore SiO2/Si ion-track template etching with the selected energy
and ion type by using of equations (2) and (3). Thus, the conducted studies visually demonstrate that
using of ImageJ for processing of SEM images allows to obtain a large amount of statistical data on
template parameters and significantly saves time during research.
Conclusion
Ion-track SiO2/Si templates were formed by irradiation with swift heavy ions and subsequent
treatment in hydrofluoric acid. The study of oxide pores containing surface of silicon was made by
using of scanning electron microscopy. The technique of post-processing of obtained SEM images
by using of ImageJ software package for obtaining and analyzing statistical data is described. The
possibility of determining such template parameters as number of pores, their total area, average size
and standard deviation, porosity, as well as deviations of pore shape from the circular and average
distance between pores are demonstrated. It is shown that standard deviation from the mean value of
average area for each pore does not exceed 4%, and the deviation of shape from an ideally round less
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than 5%, it indicates high quality of SiO2/Si templates obtained by ion tracks chemical etching.
Taking into account univocal mathematical relationship of upper pore diameter determined by SEMstudy with thickness of silicon oxide after etching and internal pore diameter of SiO2 pores through a
half-pore angle, method for their evaluation is proposed. Since length and diameter can’t be directly
determined in the usual analysis of template surface, the described estimation method greatly
simplifies the process of SiO2/Si templates parameters analyzing and significantly saves time for
obtaining the data by eliminating the stage of complex sample preparation. Thus, due to the high
precision and low cost of research, the SEM method for studying of SiO2/Si templates surface is an
effective tool for characterization of pore parameters and, importantly, can be used for other types of
porous matrices.
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