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Research Plan

• Maximum one page
• Summarise what steps are needed to reach your 

research goal
• What GHRSST data will you use?
• What other data will you use?
• What problems do you expect to encounter?
• What are your expected outcomes?

• Present outline on Friday
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Next steps

• Implement your research plan
• Write up your results
• Submit a short report (4 pages max) on your findings  
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Potential Topics

• Coral bleaching
• Upwelling variability link to wind – orographic or coastal
• TIW – measure their wavelength and asymmetry
• Western boundary currents (e.g. inter-annual position 

variability)
• Aerosol impacts on SST retrievals (Cf IR and MW)
• Construct an ocean index (such as IOD) with uncertainty
• Coastal currents and fronts -- e.g. loop currents, hunt for 

semi-permanent features off E China
• Aghulas leakage (find rings that have gone into Atlantic)
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Activities
• Group 1 (Upwelling variability linked to wind - orographic or 

coastal)
– Mingfeng Wang
– Qianmei Li
– Brandon Bethel
– Yu Shujie
– Qianguang Tu

• Group 2 (Western Boundary Currents - interannual position 
variability)

– Fei Zhou
– Changgang Wang
– Tianyu Zhang
– Li Song

• Group 3 (Western Boundary Currents - interannual position 
variability)

– Runjie Ding
– Ke Zhao
– Rui Xu
– Sicong Li

• Group 4 (Aerosol effects on SST retrievals (cf IR and PMW))
– Liqin Qu
– Mingkun Liu
– Minglun Yang
– Mengyu Li

• Group 5(Aerosol effects on SST retrievals (cf IR and PMW))
– Shaoqing Wang
– Xanyu Ji
– Zhenzhen Song
– Hang Yang

• Group 6 (Coastal currents and fronts -- e.g. loop currents, 
hunt for semi-permanent features off E China)

– Xiaobo Yang
– Zhaoying Li
– Shuai Cong
– Haiqin Duan

• Group 7 (Coastal currents and fronts -- e.g. loop currents, 
hunt for semi-permanent features off E China)

– Miao Sun
– Yingjie Liu
– Changzhong Feng
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Regional/Global Task Sharing

• GHRSST products generated by RDACs
– Some RDACs are self-serve

• GHRSST offers to serve data on-behalf of RDACs
– Optional step but recommended
– Additional metadata for discovery services

• Real time
– Global Data Assembly Centre (GDAC)
– Primary system hosted by NASA JPL

• See http://podaac.jpl.nasa.gov/
– Secondary system hosted by Ifremer

• See http://cersat.ifremer.fr/data/collections/ghrsst
(requires simple registration)

• Not all datasets are mirrored
• Delayed mode

– Long-term Stewardship and Reanalysis Facility (LTSRF)
– Hosted by NOAA NODC

• See http://data.nodc.noaa.gov/ghrsst/

• Data can be accessed using many methods
– ftp, http, DAP, WMS, WCS, LAS, Geoportal, Granules, 

CWI

NOAA  National Centers for Environmental Information
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GDS2.0

• GHRSST Data Processing Specification (GDS) 2.0
• All data files are in NetCDF file format
• All data files contain COARDS/CF compliant file level 

metadata
• All GHRSST data products have a ISO 19115-2 

compliant metadata record
• All data are free and openly available to everyone
• Some RDACs require simple registration
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Example L2P and L4 data
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• Regional Data Assembly Centres

• GHRSST Data Producers
– Provide L2P, L3 or L4 data

• Self serve or pass to GDACs
– If self-serve then metadata should at least be passed to 

GDAC/LTSRF

RDACs
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• Global Data Assembly Centres
• GHRSST Data Distributors

– Mainly real-time (up to 30 days)

• Long-term Stewardship and Reanalysis Facility
• GHRSST Data Archive

– And much, much more…

• Both have many ways to access GHRSST data
• ftp, http, DAP, WMS, WCS, LAS, Geoportal, Granules, CWI

GDACs and LTSRF
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LTSRF Progression

2007 2008 2009 2010 2011 2012 2013 2014 2015*

Products 22 26 27 40 59 60 62 77

Accessions 39,048 49,957 59,982 67,906 92,282 105,046 112,182 123,325

Files 679,000 993,580 1,352,901 1,662,004 2,459,724 3,290,806 3,971,657 4,894,891

Volumes 
(TB)

13 20 28 34 57 69 81 92
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Some considerations in selecting a GHRSST product…

• Spatially complete?
– Analysis or native swath data

• Duration?
– Time series or single image

• Spatial resolution?
– High-resolution near coast or basin scale

• Level of uncertainty?
– Best quality only

• Depth?
– Skin or other defined depth

• Synergy?
– Co-located with other data

• Availability?
– Timeliness

• Volume?
– Local or remote processing
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GDAC Access

http://podaac.jpl.nasa.gov/



Group for High Resolution Sea Surface Temperature Committee on Earth Observation Satellites
Sea Surface Temperature Virtual Constellationhttp://www.ghrsst.org

LTSRF Access

http://www.nodc.noaa.gov/sog/ghrsst/accessdata.html
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Live Access Server
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SNAP – Sentinel Application Platform

http://step.esa.int/main/download/

• SNAP is an open source toolbox for visualisation, analysis and 
processing of the Sentinels 1, 2 and 3 EO data. All supports many 
third-party missions and generic formats (e.g. NetCDF).
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Example: SST gradients
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GMPE
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Finding the SST you need
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Other products/tools

• Globcurrent (ocean currents)
– http://www.globcurrent.org/

• OceanDataLab (online visualisation)
– http://www.oceandatalab.com/syntool-web/

• NANSAT (Python toolbox
– https://github.com/nansencenter/nansat

• NAIAD (visualisation and extraction
– http://naiad.ifremer.fr

• Nephelae (data mining and processing)
– http://cersat.ifremer.fr/oceanography-from-space/our-domains-of-research/mass-

data-processing-and-mining
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Uncertainty of measurement

• SST uncertainty is 0.5 K
• What is the uncertainty of the average SST?

300 300 300

302 302 302

304304 304

302
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ATSR Image analysis

• Open example ATSR L1b file using SNAP
– File -> Open Product -> Select file 

ATS_TOA_1PRBCM20091021_020809_000005092083_00317_39950_
0011 

• The data – look at the ATSR filename - what does it tell you?
• What is in ATSR L1b file?

– Expand arrow in Product Explorer

• Open 11 micron nadir image
– Select Bands -> Nadir –> btemp_nadir_1100
– What do you see?
– Set minimum BT to 283.15 (hint use Basic thresholds…)
– What do you now see?
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Tasks (1)

• Open the ATSR L1b image in SNAP
• Identify some geographic features

– Shanghai
– Hangzhou Bay
– Yangtze River
– Eastern tip of the Shangdong Peninsula
– Kyunggi Bay
– Seohan Bay
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Tasks (2)

• Imagery is very useful 
for understanding 
mesoscale dynamics

• Find and comment 
on the main frontal 
systems:

Frontal regions of 
the East China and 
Yellow Sea are 
identified as 
follows:

1. Kuroshio Front
2. Zhejiang-Fujian 
Front
3. Jiangsu Front
4. Shandong 
Peninsula Front
5. Bohai Sea Front
6. Seohan Bay Front
7. Kyunggi Bay Front
8. Western Chejudo
Front
9. Eastern Chejudo
Front
10. Yangtze Bank 
Ring Front

From Hickox et al. 
GRL, 2000
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Tasks (3)

• Apply ATSR land mask – easy in SNAP!
– Use Mask Manager Tool Window
– If not visible use View -> Tool Windows

• Cloud masking activities
– Basic cloud test – design your own mask based on 

knowledge from lectures
• Hint: Create a new band using Raster -> Band Maths; now add a 

new mask in the Mask Manager Tool Window

– Look again at the ATSR basic cloud test – can you find out 
from internet what they are and how they work?

– Which ones work – which ones don’t?
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Tasks (4)

• Open all 6 bands
– ATSR has three spectral channels and two views
– Compare and comment on differences between channels

• Look at NAD 11-12 differences
– Hint: Use Band Maths again
– What causes them?

• Look at dual minus nadir 11 differences
– What causes them?

• Why are FWD view colder than NAD view?
• What is going with cloud in middle of image?
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Tasks (5)

• Now retrieve SST
– Use default settings

• Optical -> Thematic Water Processing -> (A)ATSR SST Processor
• This will generate a SNAP format file by default

– Why is the image so sparse?
• How can we improve this?

– Compare dual to nadir results - why different?
– Compare SST and BT – are they different? If so, why?
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Tasks (6)

• Lastly
– Generate an RGB image

• Right-click the product name -> Open RGB Image Window - > 
Select defaults

– What do you now see in the image?
– Can we improve out SST map even further?
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Task 1: Averaging

• AMSR-E
– Download one day of REMSS L2P files (not L2P_GRIDDED) from the 

LTSRF
• Data provided on disk

– Create daily average SST using the L3 binner
• Raster -> Geometric Operations -> Level-3 binning
• Select 2 products to start with

– Click the + sign, then Add product file(s)…
– Configuration -> Aggregator -> Select defaults
– Select sea-surface_temperture as source band

• Now do all files
– This will take a while…

– Now look at the data
• Change the colour scale
• Comment on the average SST and variance
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Task 2: Gradients (1)

• Example
– Download OSTIA file for 1st January 2009 from LTSRF
– Generate SST gradients using SOBEL filters

• Activity
– Download ODYSSEA and AVHRR_OI for same day
– Generate SST gradients
– Comment on differences
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Task 2: Gradients (2)

• File -> Open Product -> Select OSTIA L4 file
• Open analysed_sst and apply a colour scale
• Raster -> Filtered Band -> Select Sobel West

– Right click on the new filtered band -> Properties
– Mask invalid data (mask == 1 AND abs(analysed_sst_sn) < 

100)

• Repeat for Sobel North filter. 
• Now calculate gradients

– sqrt(sq(analysed_sst_sn) + sq(analysed_sst_sw))
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LTSRF Access

http://www.nodc.noaa.gov/sog/ghrsst/accessdata.html
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Task 3: OPeNDAP (1)

• Easy access to GDS2.0 format through OPeNDAP
– Internally compressed NetCDF 4.0 format

• Can use IDL, MATLAB, etc., for direct access
url = 
‘https://data.nodc.noaa.gov/thredds/dodsC/ghrsst
/L4/GLOB/CMC/CMC0.2deg/' $

+ '2015/' $
+ '311/' $
+ '20151107120000-CMC-L4_GHRSST-SSTfnd-

CMC0.2deg-GLOB-v02.0-fv02.0.nc'

file_id = NCDF_OPEN(url, /nowrite)
NCDF_VARGET, file_id, 'analysed_sst', sst
NCDF_CLOSE, file_id

No flags applied
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Task 3: OPeNDAP (2) – Time series

• More advanced – use OPeNDAP to generate a time 
series
– Activity: Plot the SST at one location for one month

• Try the GHRSST LTSRF…
– https://www.nodc.noaa.gov/SatelliteData/ghrsst/accessda

ta.html

• Try the ESA CCI data portal…
– http://cci.esa.int/data
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LTSRF
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THREDDS: ABoM
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THREDDS: ABoM
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THREDDS: ABoM
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THREDDS: ABoM
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Geoportal: GHRSST Search
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Geoportal: Sensor Search



Group for High Resolution Sea Surface Temperature Committee on Earth Observation Satellites
Sea Surface Temperature Virtual Constellationhttp://www.ghrsst.org

Geoportal: Granule Search


