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2 Getting started

Below is a figure which shows the main window of the GID - pre processor and its different
parts. Within the manual, references will be made to these different parts.

1 Download KratosGeoMechanics from the buildserver (Deltares only) Download Kratos-
GeoMechanics. As work is still in progress, not all tests succeed on the build-server.
However, when a compilation error did not occur, KratosGeomechanics can still be

used. Click on the icon of the latest build without a compiling error and download
KratosGeoMechanics.zip.

2 unzip KratosGeoMechanics.zip and place it in a convenient location.

3 Go to Download python 3.7 and download "Windows x86-64 embeddable zip file".

4 unzip the python zip file. From the unzipped directory, copy: "python37.dll". And paste
it in the "KratosGeoMechanics" directory.

5 Download GID from Download GID. The problemtype is made while using GID version
14*.

6 In the KratosGeoMechanics directory go to:
"applications/GeoMechanicsApplication/custom_problemtype/
GeoMechanicsApplication.gid"

7 right click and edit "GeoMechanicsApplciation.win.bat". Replace all the paths until
"*\\Kratos" with the location of the KratosGeoMechanics dir on your local drive. For ex-
ample : replace "D:\\src\\Kratos\\runkratos" by
"C:\\Users\\noordam\\Downloads\\KratosGeoMechanics\\runkratos". Note that the dou-
ble backslashes are required for path separations.
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Getting started

8 Copy the GeoMechanicsApplication.Gid problemtype paste it in the GiD problem-
types folder, e.g. : C:/Program Files/GiD/GiD 14.0.3/problemtypes/

� When performing this step, GID files can easily be transferred between different
PC’s, however admin rights on your computer are required for this step.

� If you do not have admin rights, it is still possible to use GID and to transfer GID
files between different PC’s, however, more effort is required to retain all data.
Explanation is given in section @@@.

9 Open GiD (it is recommended to have your GiD window on your main screen, since GiD
pop-up messages appear on your main screen)

10 If you performed Step 2, perform Step 4.1, else perform Step 4.2.

10.1 In the top menu bar choose: Data -> Problem type-> GeoMechanicsApplication

10.2 In the top menu bar choose: Data -> Problem type-> Load. . . and choose file:
GeoMechanicsApplication.gid from any locations

11 In the top menu bar choose: Utilities -> Preferences.

12 In the Preferences window choose: Grid

� Alter the domain size to your liking (X Extents / Y Extends)

� In General options: activate the options as preferred.

� In Spacing: alter the spacing for which your pointer snaps to a location.
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3 Create geometry

3.0.1 Create lines

1 In the geometry toolbar click on either:

� Create line

� Create arc

� Create nurbs line

2 Create the line by clicking on the domain or fill in the coordinates in the command line
below. When the line is finished, press ESC.

3 In order to change the location of the line, press the “move a point” button on the
left toolbar. In the domain click on a point of the line to select it. Click somewhere else
in the domain or fill in the new coordinates to move the point to that location.

4 Lines always have to be connected to other lines by points. In order to add extra points
on an existing line, there are the following options

� Divide a line in a number of divisions

� Divide a line near a point

� Divide a line on intersecting lines

3.0.2 Create surfaces

1 To create a surface there are 2 options:

� click on create object and choose either: Rectangle, Polygon or Circle.
And draw the surface in the geometry view, or fill in the coordinates in the com-
mand line.

� Create lines as described before. Connect the lines until a closed shape is formed.

Click on "Create NURBS surface" and select the lines in the geometry view
which should form the boundary of your surface. Press ESC to finish.

(Note that lines have to be connected through points, when one line finishes
halfway on another line, this is not considered as a closed surface. Another point
has to be added to the second line to form a closed surface.)

2 In order to divide a surface into multiple surfaces click on either of the following buttons
on the Geometry toolbar:
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Create geometry

� Divide the surface in n even parts

� Divide the surface through a path of lines

� Intersect the surface through lines

� Intersect the surface with other surfaces

3.0.3 Create volumes

1 In order to create volumes there are multiple options:

� click on create object and choose either: Sphere, Cylinder, Cone, Prism
or Thorus. And draw the volume in the geometry view, or fill in the coordinates in
the command line.

� In this option, a volume is created by stretching a surface in the 3rd dimension.

1.1 In the top menu bar go to: Utilities -> Copy. . .

1.2 In the Copy window set entities type to “Surfaces”

1.3 In the Copy window set Transformation to “Translation”

1.4 In the Copy window set the first and second point (there should be a difference
between the z values in order to create a volume)

1.5 In the Copy window set Do extrude to “Volumes” and unselect “Create con-
tacts” in order to create a volume with more than 1 element in the Z-direction

� An other option is to create a volume from connected surfaces. Create surfaces
and connect them until a closed 3 dimensional shape is formed. Click on "create

volume" and select the surfaces in the geometry view which should form the
boundaries of the volume. Press ESC to finish.
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4 Define problem

When the geometry is created, the problem can be defined.

4.0.1 Materials

todo

4.0.2 Boundary conditions

todo

1 Before the boundary conditions can be assigned to the geometry, it is important to
understand the following box:

� Use the text box to fill in the identifier of the condition (for example the condition
name) or select an existing boundary condition

� Click on to assign the boundary condition to lines, click on to assign the
boundary condition to surfaces.

� Click on to assign the filled in boundary condition values to an existing
boundary condition which is selected in the text box.

� Click on to create a new group and assign the group to the geometry (lines
or surfaces, depending which option is chosen)

4.0.3 Structural elements and interfaces

1 To create a structural element, on the top menu bar click on GeoMechanicsApplication
=> elements.

2 From the Elements window which appeared, from the top drop-down menu. Select
the preferred structural element (Beam, Shell thin corotational, Shell thick corotational,
Truss or Cable). The structural element can then be assigned to the geometry.

3 In order to create an interface between the soil and the structural element. Multiple
GiD-layers need to be created in GiD. One layer needs to be the layer of the structural
elements, the next layer is the soil on one side of the structural element, the next layer
being the soil on the other side of the structural element.
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5 Meshing

Before a calculation can be done with KratosGeoMechanics, it is required to generate the
mesh. Every time something is changed in the geometry, the mesh has to be regenerated.
So for example:

� The geometry has been changed

� A new or different boundary condition is assigned

� A different material is assigned to an existing surface or volume

1 In the top menu bar click: Mesh->Element type to choose the element type of your
mesh. For a 2D domain choose either triangle elements or quadrilateral elements. For
a 3D domain choose either Tetrahedra, hexahedra or Prism elements. Line elements
are automatically set as Bar elements.

2 The size of the mesh can be set locally.

� In the top menu bar click: "Mesh->Unstructured->Assign sizes on lines/surfaces/volumes"
to assign the size of the unstructured mesh on respectively lines,surfaces or vol-
umes.

� In the top menu bar click: "Mesh->Structured->Assign sizes on lines/surfaces/volumes"
to assign the size of the structured mesh on respectively lines,surfaces or volumes.

3 To alter the size transition from small elements to large elements in an unstructured
mesh, In the top menu bar click: Utilities->Preferences. In the Preferences window,
go to Meshing->Unstructured. In this window, the "Unstructured size transition" can
be altered. It controls whether the transitions between different element sizes are slow
(near to 0) or fast (near to 1), where the default is 0.6. Select the preferred size transition
number and click on apply.
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6 Calculating

TODO

A staged calculation cannot be calculated via GiD. This has to be done via the command
prompt or python.

4 Take the template file "MainKratos_multiple_stages_template.py" from ./KratosGeoMe-
chanics/applications/GeoMechanicsApplication. And copy it to the main KratosGeoMe-
chanics directory. Rename the file to "MainKratos.py"

5 right click on "MainKratos.py" and select "edit".

6 Edit the project_paths variable such that it refers to the correct *.gid files. Note that the
file paths should stay within the quotation marks.

7 In windows explorer, go to the KratosGeoMechanics directory. In the adress-bar, type
in: "cmd" and press "enter", such that command prompt is opened while already refer-
ring to the correct directory. In the command prompt, type in: "runkratos MainKratos.py".
Now the calculation should start running with as many stages as preferred.
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7 PostProcess

Deltares 9 of 19



8 Tutorial 1: Dike

The first tutorial shows how to create a dike with multiple layers and multiple piezometric
levels. Note that this tutorial is meant to show the possibilities of KratosGeoMechanics in GiD,
rather than creating a realistic dike.

8.1 Geometry

1 In GiD, press the icon and draw the outlines of your geometry according to Table
8.1. Make sure to press "Join" in the Create point procedure when connecting the last
line to the first point.

Table 8.1: Outline geometry tutorial 1

Line ID Point 1 (x,y) Point 2 (x,y)
1 -50, -15 50, -15
2 50, -15 50, 0
3 50, 0 10, 0
4 10, 0 0, 5
5 0, 5 -5, 5
6 -5, 5 -15, 0
7 -15, 0 -50, 0
8 -50, 0 -50, -15

2 Now create lines to set the outlines of the soil layers. According to Table 8.2.

Table 8.2: Outline soil layer tutorial 1

Line ID Point 1 (x,y) Point 2 (x,y)
9 (-50, -10) (50, -10)
10 (-15, 0) (10, 0 )

3 Create vertical lines at the location of the turning points of the phreatic level which will
be created in a further step, according to Table 8.3.

Table 8.3: Verticals turning points phreatic line tutorial 1

Line ID Point 1 (x,y) Point 2 (x,y)
11 (-7.5, 5) (-7.5, -15)
12 (-15, 0) (10, 0)

4 Create all the intersections between the lines by clicking on the button and select-
ing everything. The outlines should look as displayed in Figure 8.1. Further references
to line ID’s are done using the line ID’s as shown in the figure.

5 Create surfaces by clicking on the button and selecting the lines as displayed in
Table 8.4.

6 Delete line (19) and the attached point by clicking on the and the in the
Geometry toolbar. The geometry should look like as displayed in Figure 8.2. Further
references to surface ID’s are made to the ID’s as shown in the figure.
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Tutorial 1: Dike

Figure 8.1: All outlines tutorial 1

Table 8.4: Surfaces tutorial 1

Surface ID line ID’s
1 (7, 27, 35, 33, 21)
2 (28, 25, 34, 35)
3 (3, 16, 24, 25)
4 (33, 36, 13, 22)
5 (34, 26, 31, 36)
6 (24, 15, 32, 26)
7 (18, 29, 27)
8 (17, 5, 4, 28, 29)

Figure 8.2: Geometry tutorial 1

8.2 Boundary conditions

7 The next step is setting the boundary conditions. In this tutorial, the side boundaries
can move freely in vertical direction; the bottom boundary is fixed. In the top menu
bar, select GeoMechanicsApplication->Dirichlet Constraints. The window as shown in
Figure 8.3 should appear.

8 For the side boundaries, deselect "SOLID DISPLACEMENT Y ". Now in the bottom left
corner of the Dirichlet Constaints window, fill in "side boundary". In this same window

click on the line button . And click on the create new group button, . Now
select the lines (21, 22, 15, 16) in the geometry and press "ESC".

9 For the bottom boundary, in the Dirichlet Constaints window, select all the SOLID DIS-
PLACEMENT buttons and keep the values at 0. Name this boundary "bottom bound-
ary", and assign this boundary condition to the lines (13, 31 ,32).

8.3 Materials

10 Now the materials have to be assigned to the surfaces. In this tutorial, 3 materials will
be created. In the top menu bar, select GeoMechanicsApplication->Elements. A new
window should appear.

11 In the elements window which appeared, from the top drop-down menu, select "soil-
drained". And fill in the values as shown in Figure 8.4. For the parameter, "UDSM
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Figure 8.3: Dirichlet constraints window

Name", fill in the address of the "MohrCoulomb.dll", including extension. For the de-
scription of the Mohr Coulomb parameters, see @@@. Assign the material to the
surfaces (1, 2, 3).

Figure 8.4: Clay parameters tutorial 1
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Tutorial 1: Dike

12 For the second material, select "soil-drained" and fill in the parameters as shown in
Figure 8.5. Again for the "UDSM Name" fill in the address if the "MohrCoulomb.dll",
including extension. Assign the material to the surfaces (4, 5, 6)

Figure 8.5: Sand parameters tutorial 1

13 For the last material, again select "soil-drained" and fill in the parameters as shown in
Figure 8.6, again referring to "MohrCoulomb.dll" for "UDSM Name". Assign the material
to surfaces (7, 8).

8.4 Water

14 The first water level to be added is the river water level. Click on GeoMechanicsApplica-
tion -> Dirichlet Constraints. In the Dirichlet Constraints window, select Fluid Pressure
from the top drop-down menu. Fill in the parameters as shown in Figure 8.7. Assign
this fluid pressure to line 7.

15 Now rename the previous Fluid pressure condition to "river_level_surface".
And assign the condition to surface 7

16 The water pressure due to the river water level is now set, however since the water
level lies above the surface, it is required to explicitly define the normal load due to the
water. Click on GeoMechanicsApplication -> Loads. From the top drop-down menu in
de Loads window, select Normal Load. Fill in the values as shown in Figure 8.8. Assign
the condition to the lines 17 and 18.
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Figure 8.6: Dike parameters tutorial 1

17 The water level in the dike is an inclined phreatic line. Click on GeoMechanicsAppli-
cation -> Dirichlet Constraints. Select Fluid Pressure from the top drop-down menu in
the Dirichlet Constraints table and fill in the values as shown in Figure 8.9. Assign the
condition to surface 8.

18 For the last part of the phreatic level, select fluid pressure, choose Hydrostatic pressure
distribution. Set the reference coordinate on -15. In the Fluid pressure table fill in 0 on
time 0 and 2; fill in 15 at time 3 and 4. Name the condition "polder level" and
assign the condition to line 3.

19 Now for the water level in the aquifer, select fluid pressure, choose Hydrostatic pressure
distribution. Set the reference coordinate on -15. In the Fluid pressure table fill in 0 on
time 0 and 2; fill in 18 at time 3 and 4. Name the condition "aquifer_level" and
assign the condition to surface 4, 5 and 6.

20 Lastly, select Interpolate line pressure distribution, set Imposed Pressure on Table In-
terpolation and assign the condition to surface 1, 2 and 3.

8.5 Loads

21 In this tutorial, the only loads will be applied are water loads and the own weight of the
soils. The water loads are already applied in the previous section. To apply the soil
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Tutorial 1: Dike

Figure 8.7: River water level tutorial 1

weight, click on GeoMechanicsApplication -> Loads and select Body Acceleration from
the drop-down menu.

22 In the Loads window, for Imposed Body Acceleration Y select table interpolation. Fill in
0 for time 0; and fill in -9.81 for time 1 and 4. Name this load "body_surface" and
assign the condition to the surfaces: 1, 2, 3, 4, 5, 6.

23 For the self weight of the dike, in the Loads window, for Imposed Body Acceleration Y
select table interpolation. Fill in 0 for time 0 and 1; and fill in -9.81 for time 2 and 4.
Name this load "body_dike" and assign the condition to the surfaces: 7, 8.

8.6 Meshing

24 On the top menu bar, click on Mesh -> Unstructured -> Assign sizes on surfaces. Fill in
1.0 in the dialog window which pops up. And assign this size on the surfaces 7 and 8.

25 Now fill in 3.0 in the dialog window and assign this size to the surfaces: 1, 2, 3, 4, 5, 6.

26 On the top menu bar, click on Mesh -> Quadratic type -> Quadratic. Such that quadratic
elements are generated.

27 On the top menu bar, click on Mesh -> Generate mesh.... A Mesh generation window
pops up where the element size of the mesh can be filled in. However, since the mesh
size of all the surfaces is already defined in previous steps, the number which is filled in
into the mesh generation window does not matter.
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Figure 8.8: River load tutorial 1

8.7 Project Parameters

28 Before the model can be calculated, the project parameters should be filled in correctly.
Click on GeoMechanicsApplication -> Project Parameters. The problem data Window
should appear.

29 In the Problem data window on the Problem Data tab, set the Start Time to 0.0 and the
End Time to 4.0.

30 For the first calculation in this tutorial, in the Problem data window on the Solver Settings
tab, set Displacement Relative Tolerance on 1e-2. Keep the rest of the settings on the
default values. And press Accept.

8.8 Calculate

31 In order to calculated, on the top menu bar click on Calculate -> Calculate

32 Calculation progress can be monitored by clicking on Calculate -> View Process info...

33 Make sure to save after the calculation is done
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Tutorial 1: Dike

Figure 8.9: Dike water level tutorial 1

8.9 Post-process part 1

34 After calculation, check the results in the post-process window by clicking on the
icon on the Standard GiD Toolbar.

35 As an intermediate check before going on to the next part of the tutorial, check if the
Water Pressure, the x-displacement and the y-displacement are calculated correctly. In

Post-process, click on and select: "WATER PRESSURE", then "DISPLACEMENT
-> X-DISPLACEMENT" and lastly,"DISPLACEMENT -> y-DISPLACEMENT". Check if
the contours are the same as shown in Figure 8.10

36 Go back to the pre-process window. If the results are equal go on to the next part of the
tutorial, if not, check if all input is correctly filled in.

8.10 Staged construction

37 While Kratos GeoMechanics can handle staged calculation, the GiD problemtype can
not. In order to perform a staged calculation, some additional actions have to be per-
formed within and outside the Gid pre-processor. The following stages will be added:

� Initial stage

� Addition of dike load

� Addition of daily water level

� High water level
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Figure 8.10: Contour results tutorial 1 part 1, top to bottom: water pressure, x-
displacement, y-displacement

38 Stage 1:

38.1 Save the existing file as "tutorial_1_stage_1"

38.2 Go to GeoMechanicsApplication -> Dirichlet Constraints -> Excavation. Select the
option Deactivate soil. Name the condition dike_excavation and assign the
condition to the surfaces 7 and 8.

38.3 Go to GeoMechanicsApplication -> Problem data. On the Problem data tab, set
start and end time from 0.0 to 1.0.

38.4 On the Solver Settings tab, set Solution type to K0- procedure. And set the Dis-
placement Relative Tolerance on 1e-3.

38.5 Re-mesh.

38.6 Click on Calculate and then cancel process. Note that clicking on Calculate is
necessary to generate the input files. Results of the in between stages are not
relevant, therefore it is not required to wait until the calculation is finished.

38.7 Save the project again

39 Stage 2

39.1 Save the existing file as "tutorial_1_stage_2"

39.2 Go to GeoMechanicsApplication -> Dirichlet Constraints -> Excavation. Deselect
the option Deactivate soil of the dike_excavation condition.

39.3 Go to GeoMechanicsApplication -> Problem data. On the Problem data tab, set
start and end time from 1.0 to 2.0.

39.4 On the Solver Settings tab, set Solution type to Quasi-Static.
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39.5 Re-mesh.

39.6 Click on Calculate and then cancel process.

39.7 Save the project again

40 Stage 3

40.1 Save the existing file as "tutorial_1_stage_3"

40.2 Go to GeoMechanicsApplication -> Problem data. On the Problem data tab, set
start and end time from 2.0 to 3.0.

40.3 Click on Calculate and then cancel process.

40.4 Save the project again

41 Stage 4

41.1 Save the existing file as "tutorial_1_stage_4"

41.2 Go to GeoMechanicsApplication -> Problem data. On the Problem data tab, set
start and end time from 3.0 to 4.0.

41.3 Go to GeoMechanicsApplication -> Dirichlet Constraints -> Fluid Pressure, set Y
2 of the dike dike_level condition on -19.

41.4 Click on Calculate and then cancel process.

41.5 Save the project again

8.11 Calculate staged construction

A staged calculation cannot be calculated via GiD. This has to be done via the command
prompt or python.

42 Take the template file "MainKratos_multiple_stages_template.py" from ./KratosGeoMe-
chanics/applications/GeoMechanicsApplication. And copy it to the main KratosGeoMe-
chanics directory. Rename the file to "MainKratos.py"

43 right click on "MainKratos.py" and select "edit".

44 Edit the project_paths variable such that it refers to the correct *.gid files. Note that the
file paths should stay within the quotation marks.

45 In windows explorer, go to the KratosGeoMechanics directory. In the adress-bar, type
in: "cmd" and press "enter", such that command prompt is opened while already refer-
ring to the correct directory. In the command prompt, type in: "runkratos MainKratos.py".
Now the calculation should start running with as many stages as preferred.

8.12 Post-process part 2

when all the stages are calculated, all the stages can be viewed separately in post process.

46 In GiD go to post-processing.

47 Select "Open PostProcess" and go to the directory of your preferred stage. Click on the
*.bin file to open the postprocess file.

48 Note that "DISPLACEMENT" shows the displacement of the current stage. "TOTAL_DISPLACEMENT"
shows the total displacement over the previously calculated stages.
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