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1 Installations

1.1 Installing the Metamodel & Generator Project

To employ the metamodel and the generator, you can use the included Eclipse projects. In
the following, we will explain how to install and use them:

1. Download Eclipse IDE 2021-091 and install the EclipseModelling Tools (see Fig. 1.1)

2. Start Eclipse and create a new workspace (or choose an already existing one)

3. Under "Help" > "Install New Software..." click "Add" and enter add the following to
installation sites (each needs to be a single entry and the name can be arbitrary):

a) https://updatesite.mdsd.tools/metamodel-modeling-foundations/nightly/

b) http://download.eclipse.org/modeling/mdt/ocl/updates/releases

c) https://download.eclipse.org/modeling/tmf/xtext/updates/composite/marketplace/

d) https://kit-sdq.github.io/updatesite/release/commons

Afterwards choose "–All Available Sites–" in the drop-down menu next to the "Add..."
button and install the following packages:

• MDSD.tools Modeling Foundations

• OCL All-In-One SDK

• Xtend & Xtend IDE

• SDQ Commons

If a security warning is shown, just click "Install anyway". For completeness, you can
view a list of all installed software packages as well as their version for a running
eclipse configuration in Figure 1.4.

4. Restart Eclipse (you will be prompted to do so)

5. If you close the welcoming screen, the "Model Explorer" View should be open. If not,
you can open it under "Window" > "Show View" > "Model Explorer".

6. Import the Projects from the "MetamodelAndGeneratorProjects" folder as follows:

a) Right-Click in the "Model Explorer" View > "Import..."

b) Choose "General" > "Projects from Folder or Archive"
1https://www.eclipse.org/downloads/
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1 Installations

c) Choose the "MetamodelAndGeneratorProjects" Directory and select all available
projects as seen in Fig. 1.2. Click "Finish".

7. If there are over 200 errors in the edu.kit.kastel.sdq.soliditycodegenerator folder
that state that a certain sequence cannot be resolved to a type (e.g. "Â cannot be
resolved to a type."), you need to right-click on the folder > "Properties" > "Resource"
(should already be selected) and change the "Text file encoding" from "Inherited from
container" to "Other:" > "UTF-8". Now apply and close the properties window and
after a re-build there should be no errors left.

8. In the "Model Explorer", navigate to "AccessControlMetamodel" > "model" > "Access-
ControlMetamodel.ecore" > "AccessControlMetamodel" and either "AccessControl-
System or "SmartContractModel". To open the diagram in Eclipse, double click their
first child element that are marked in Fig. 1.3.

Figure 1.1: Screenshot of the Eclipse Installation that should be selected in step 1
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1.2 Looking at the Examples & Using the Generator

Figure 1.2: Screenshot of the Import-Window when importing the projects in step 6c.

1.2 Looking at the Examples & Using the Generator

To look at the created examples or create your own examples, as well as run the generator
on these examples, the following steps need to be followed:

1. In your set-up Eclipse environment from Ch. 1.1, Right-click on either the "Access-
ControlGenerator" or the "AccessControlMetamodel.editor" folder and "Run As" > "1
Eclipse application". Now, a new Eclipse window should open.

2. There should be no project open in the ProjectExplorer view, so you can click "Import
projects..." and follow the same steps from step 6 in the previous chapter. This time,
choose the "Examples" folder and select the only available option "Examples".

3. Now you have the different folders for each example and use cases available

4. To create a new metamodel instance, you need to make a right-click on any object
in the Project Explorer and choose "New" > "Other...". In the newly opened window,
naviagte to "Example EMF Model Creation Wizards", where you can select either the
"AccessControlSystem Model" or the "SmartContractModel Model". Press "Next".

5. Now you can choose the filename and its location. Press "Next".
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1 Installations

Figure 1.3: The files you need to open to see the whole diagram as explained in step 8.
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1.2 Looking at the Examples & Using the Generator

Figure 1.4: All installed software versions in an Eclipse environment where the metamodel
and the generator work without any problems.

5



1 Installations

6. Now you can choose the "Model Object" and the "XML Encoding". For the "Model
Object" you need to choose either "Access Control System" or "Smart Contract". The
Encoding does not need to be changed ("UTF-8"). Finish the creation.

7. Now the newly created file is opened and new elements can be added with a right-
click. Their properties can be looked at and changed in the "Properties" view.

8. If you want to generate Solidity code based on the models, you need to select at least
one ".smartcontractmodel" and one ".accesscontrolsystem" file and right-click. Now
the generator can be started by selecting "Access Control Generator" > "Generate
Smart Contract with Access Control". Now a soundness check is started before the
generation. If that check finds any problems, it communicates them back to the
developer. In any case, a new folder called "gen" is created. The generator puts the
created smart contracts there or a .log file if the soundness check fails.

1.3 Installing the Slither printer

To use slither and our implemented printer on a Solidity smart contract, we use Linux. To
setup all necessary tools and packages, you need to follow these steps:

1. Install Python 3.6+ with pip (no further instructions are given since it is often pre-
installed or the installation depends on the linux system you are using)

2. Install solc, the Solidity compiler by following these instructions

3. Install Slither using the following command:
$ g i t c l one h t t p s : / / g i t hub . com / c r y t i c / s l i t h e r . g i t
$ cd s l i t h e r
$ python3 se tup . py i n s t a l l

If for some reason that does not work, you can see some alternatives in Slithers
documentation2

4. Copy the "influence_and_calls_plugin" folder provided with these instructions to
the same folder where slither was installed

5. Navigate inside the "influence_and_calls_plugin" folder and open a new terminal

6. Enter the following command to install the custom printer:
$ python3 se tup . py deve lop

7. If no errors occured during the installation, the printer is now successfully installed.
To test it, you can enter the following command in any folder that contains the
Solidity file <Filename> that you want to analyze:
$ s l i t h e r <Fi lename > . s o l −− p r i n t i n f l u e n c e −and− c a l l s

2https://github.com/crytic/slither#how-to-install
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2 Metamodel

Our created metamodel consists of two different packages that are separated to enhance
the separation of concerns. The first package can be seen in Fig. 2.1 and covers all aspects
of our model needed to describe a basic Solidity contract. This includes the functions, state
variables and the needed data types as well as the possible balance modifications. This
package uses elements from the SolidityMetaModel1.

StateVariable

mutability : VariableMutability = default
visibility : VariableVisibility = public

Function

mutability : FunctionMutability = default
virtual : EBoolean = false
content : EString
 returnVariables : ReturnVariable
 modifiers : Modifier
 parameters : FunctionParameter

Type

FunctionBalanceModification

modifiesMsgSenderBalance : 
BalanceModificationType = modifiesBothWays
modifiesThisContractsBalance : 
BalanceModificationType = modifiesBothWays

SmartContract

BalanceModificationType

modifiesBothWays
onlyIncrease
onlyDecrease
doesNotModify

[1..1] type

[1..1] function

[1..*] functions

[0..*] balanceModifications

[1..*] variables

[1..*] datatypes

Figure 2.1: First half of our newly created metamodel to describe RBAC requirements for
smart contracts. This package contains all aspects that rely on smart contract /
Solidity specific aspects.

The second package covers the remaining aspects of our approach by describing all
elements needed to model RBAC policies for the smart contract described with the first
package. It can be seen in Fig. 2.2 and covers roles as well as all relation elements that
relate functions, state variables and roles with each other. Additionally, a context can be
provided for certain kinds of relations.

1https://github.com/KASTEL-CSSDA/SolidityMetaModel
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2 Metamodel

FunctionToFunctionRelation

 caller : Function
 callee : Function

AccessControlSystem

VariableToVariableRelation

 influencer : StateVariable
 influenced : StateVariable

FunctionToVariableRelation

function : Function
RoleToFunctionRelation

function : Function

Role

description : EString
cardinality : EInt = -1

RoleToVariableRelation

modifies : EBoolean = true
 variable : StateVariable

MutualRoleExclusion

Context

TimeContext

isUpperBound : EBoolean = false
timeValue : EInt
timeUnit : TimeUnits = second

TimeUnits

second
minute
hour
day
week
year

BooleanVariableContext

valueToCheck : EBoolean = false
 variable : StateVariable

FunctionToCsmRelation

accessWholeMapping : 
EBoolean = false
 csm : StateVariable

FunctionToStateVariableRelation

 variable : StateVariable

[1..1] role

[1..1] role

[2..2] roles

[0..*] prerequisite

[0..*] superior

[0..*] roleToVariableTuples

[0..*] roles
[0..*] roleToFunctionTuples

[0..*] roleExclusions

[0..*] functionToVariableTuples

[0..*] functionToFunctionTuples

[0..*] variableToVariableTuples

[0..*] conditions[0..*] conditions

Figure 2.2: Second half of our newly created metamodel to describe RBAC requirements
for smart contracts. This package contains all aspects that are needed to model
the RBAC policies.

2.1 Project Overview

This guideline comes with the relevant projects ready to be imported into an Eclipse
project as explained in step 6 of Ch. 1.1. However, not all of them need to be reviewed
since most of them are only needed to correctly run the projects:

• AccessControlGenerator - This folder contains the implemented code generator
that will be explained in more detail in Ch. 3. However, only the packages contained
in the "src" folder are relevant for the review since the files in the "xtend-gen" folder
are derived automatically from the ones in the "src" folder.

• AccessControlMetamodel - This folder contains the metamodel and the generated
Java source code. To access the models, follow step 8 from the instruction in Ch. 1.1.
This project also contains the OCL constraints that are topic of the next chapter.
However, to access them, you need to open the ecore file (see Fig. 1.3) with a double-
click. In the now opened tree hierarchy, you can navigate to the model elements that
contain OCL constraints. The constraints definition can be found under [Element] >
"Pivot". Here, all constraints are saved as a key-value-pair, with the key giving the
constraint a name and the value containing the actual constraint (see Fig. 2.3).

• AccessControlMetamodel.edit & .editor - Both folders are generated automat-
ically based on the model and are needed to create model instances. They do not
need to be reviewed.
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2.1 Project Overview

• edu.kit.ipd.sdq.mdsd.ecore2txt & .feature - Foundation for the generator imple-
mentation, taken from the GitHub repository2. They do not need to be reviewed.

• edu.kit.kastel.sdq.soliditycodegenerator - Solidity smart contract generator for
the SolidityMetaModel. The generator works as a foundation for our generator, is
taken from GitHub3 and does not need to be reviewed.

• edu.kit.kastel.sdq.soliditymetamodel - The SolidityMetaModel is an EMF meta-
model used to describe Solidity smart contracts that works as a foundation for our
metamodel. This is taken from its GitHub repo4 and does not need to be reviewed.

• edu.kit.kastel.sdq.soliditymetamodel.edit & .editor - Both are automatically
generated and do not need to be reviewed.

Figure 2.3: How to access the OCL constraints in our metamodel.

2https://github.com/kit-sdq/Ecore2Txt
3https://github.com/KASTEL-CSSDA/SolidityCodeGenerator
4https://github.com/KASTEL-CSSDA/SolidityMetaModel
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3 XTend Generator

The generator, which uses XTend1 to create the Solidity smart contracts based on the
metamodel instances, is based on the Ecore2Txt project2 and the SolidityCodeGenerator3.
The latter is the generator developed to create Solidity smart contracts based on the
SolidityMetaModel, which is referenced by our AccessControlMetamodel.
In general our generator can be found in the "AccessControlGenerator" project folder,

after it was imported into Eclipse (see Ch. 1.1 for the explanation). The Xtend classes that
contain the generation logic can be found in the "src" folder, the files in the "xtend-gen"
folder can be ignored for the review since they are automatically generated from these
XTend classes. All in all, the classes and methods we implemented are all documented
inside the code, so we provide only basic explanations in this chapter. All packages that
we explain in the following subchapters are part of the "src" folder.

3.1 edu.kit.kastel.sdq.accesscontrolgenerator.generators &
.handlers

These two packages contain only three classes that are mainly derived from the Ecore2Txt
project4 and are used as the starting point of the generator. Especially the AccessControl-
GeneratorHandler class is used to delegate the command that is issued when the generator
is selected in Eclipses context menu (see step 8 in Chapter 1.2). This class refers the call
to the AccessControlGenerator with the help of the AccessControlGeneratorModule. In the
AccessControlGenerator, the input files are preprocessed (using the soundness check ex-
plained in more detail in Ch. 3.3) before the file contents are generated using the different
generator classes explained below.

3.1.1 accesscontrolsystem Subpackage

This subpackage contains all generators and supporting classes necessary to create all
access control related aspects inside the generated smart contracts as well as the additional
access control contract:

• AccessControlConstants: This class contains all constant string values that are
needed throughout the generation and are relevant for access control. This includes,

1https://www.eclipse.org/xtend/
2https://github.com/kit-sdq/Ecore2Txt
3https://github.com/KASTEL-CSSDA/SolidityCodeGenerator
4https://sdqweb.ipd.kit.edu/wiki/Generating_code_with_Xtend_and_Xtext_triggered_from_the_

Eclipse_context_menu
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3 XTend Generator

for example, the access control contract name or the constant parts of the solc-verify
annotations.

• AccessControlContractGenerator: This class fills the SolidityContractGenera-
tionTemplate (see Ch. 3.2) with the contents that are relevant for the additionally
created access control contract.

• AccessControlSupportFunctionality: This class provides additional functionality
that is used throughout the generation, like removing duplicate elements from lists
and checking if the additionally created access control contract needs to be imported.

• AccessControlValidator: With this class, the soundness check and the validation
of OCL constraints is done. The aspects that are considered during this validation
are explained in more detail in Ch. 3.3.

• AnnotationGenerator: This class is used to generate the annotations for the
different functions using the solc-verify syntax to specify modifications to variables
by functions based on the modelled policies.

• ModifierGenerator: This class is used to generate the access control related modi-
fiers for the smart contract. This includes the role checks as well as the conditions
that can be modelled.

• ModifierRoleAndConditionsHelper: This helper class is used to handle the
connections between roles and the conditions defined for the functions they can
access. This is used in the ModifierGenerator to collect all necessary objects in one
class.

• TransitiveClosureCalculator: This class is given an AccessControlSystem from the
model and calculates the needed transitive closures. These include the transitive
closure of variable to variable influence as well as the function calls.

3.1.2 smartcontract Subpackage

This subpackage contains all generators and supporting classes necessary to create the
basic smart contracts without their access control related aspects:

• SolidityConstants: This class contains all constant string values that are needed
throughout the generation and are connected mainly to the Solidity smart contract.
This includes, for example, the file extension and prefix for the target folder. This
class is copied from the SolidityCodeGenerator.

• SolidityContractGenerator: This class assembles the different parts of themodelled
smart contract and generates a Solidity file for it by filling the SolidityContractGener-
ationTemplate (see Ch. 3.2). To do so, it also uses access control related classes to get
the modifiers or the annotations.
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3.2 edu.kit.kastel.sdq.accesscontrolgenerator.generators. templates

• SolidityFunctionGenerator: This class is used to create a Solidity function based
on a function from the model. To do so, it fills the SolidityFunctionGenerationTemplate
(see Ch. 3.2) with the fitting values.

• SolidityNaming: This class is used to convert all strings related to naming and
Solidity keywords to the right typing. This class is copied from the SolidityCode-
Generator.

3.2 edu.kit.kastel.sdq.accesscontrolgenerator.generators.
templates

This package contains the templates used by the generator classes. They provide the
general structure of a document or part of the document, whereas each structural part is
filled by at least one generator:

• M2T-Generator: Interface providing the generation functionality

• SolidityContractGenerationTemplate: Filling the generate() method of the M2T-
Generator interface with different methods for the structural elements of a Solidity
smart contract. This class is implemented by the contract generators, which fill these
methods with the needed content.

• SolidityFunctionGenerationTemplate: Filling the generate() method of the M2T-
Generator interface with different methods for the structural elements of a Solidity
function. This class is implemented by the SolidityFunctionGenerator, which fills
these methods with the needed content.

3.3 Soundness Check

To reason about the soundness of the metamodel instances, we use the AccessControlValida-
tor class. In addition to checking the defined OCL constraints, it checks the fulfillment of
the RBAC equations seen below. If any violations are found, they are communicated back
to the developer and the generator stops the generation by creating a log-file, allowing
only instances without any violations to result in functioning Solidity smart contracts.

Definitions:
R = Roles, F = Functions, S = State Variables
𝐴𝑅𝐹 : R × F (AccessRoleFunction - Role may call function)
𝑀𝑅𝑆 : R × S (ModificationRoleStateVariable - Role may modify state variable)
𝑀𝐹𝑆 : F × S (ModificationFunctionStateVariable - Function may modify state variable)
𝐼𝑅𝑆 : R × S (InfluenceRoleStateVariable - Role may influence state variable)
𝐼𝑆𝑆 : S × S (InfluenceStateVariableStateVariable - First state variable may influence the
second state variable)
𝐶𝐹𝐹 : F × F (CallFunctionFunction - First function may call the second function)
𝑀𝐸𝑅 : R ×R (MutualExclusionOfRoles - The two roles are mutually exclusive)
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3 XTend Generator

If a role may access a function, it also needs access to all functions called by it:

∀𝑟 ∈ R, 𝑓 , 𝑓𝑐 ∈ F : (𝑟, 𝑓 ) ∈ 𝐴𝑅𝐹 ∧ (𝑓 , 𝑓𝑐) ∈ 𝐶𝐹𝐹 → (𝑟, 𝑓𝑐) ∈ 𝐴𝑅𝐹 (3.1)

If a role may modify a state variable, it needs to have access to at least one
function that can modify the variable:

∀𝑟 ∈ R, 𝑠 ∈ S : (𝑟, 𝑠) ∈ 𝑀𝑅𝑆 → ∃𝑓 ∈ F : (𝑟, 𝑓 ) ∈ 𝐴𝑅𝐹 ∧ (𝑓 , 𝑠) ∈ 𝑀𝐹𝑆 (3.2)

If a role may modify a state variable, but may not influence a second state
variable, the first one may not influence the second one:

∀𝑟 ∈ R, 𝑠1, 𝑠2 ∈ S : ((𝑟, 𝑠1) ∈ 𝑀𝑅𝑆 ∧ (𝑟, 𝑠2) ∉ 𝐼𝑅𝑆) → (𝑠1, 𝑠2) ∉ 𝐼𝑆𝑆 (3.3)

If a role has access to a function, but may not influence a state variable, the
function should not be able to influence the state variable:

∀𝑓 ∈ F, 𝑠 ∈ S, 𝑟 ∈ R : ((𝑟, 𝑓 ) ∈ 𝐴𝑅𝐹 ∧ (𝑟, 𝑠) ∉ 𝐼𝑅𝑆) → ¬𝑑𝑜𝑒𝑠𝐼𝑛𝑓 𝑙𝑢𝑒𝑛𝑐𝑒 (𝑓 , 𝑠) (3.4)

Function f does not influence state variable s if it has no modifying access to
the variable itself, does not modify other state variables that may influence it and
if no function that f calls influences s:

¬𝑑𝑜𝑒𝑠𝐼𝑛𝑓 𝑙𝑢𝑒𝑛𝑐𝑒 (𝑓 , 𝑠) ↔ ((𝑓 , 𝑠) ∉ 𝑀𝐹𝑆 ∧ (∀𝑠𝑖 ∈ S : (𝑓 , 𝑠𝑖) ∉ 𝑀𝐹𝑆 ∨ (𝑠𝑖, 𝑠) ∉ 𝐼𝑆𝑆)∧
(∀𝑓𝑐 ∈ F : (𝑓 , 𝑓𝑐) ∉ 𝐶𝐹𝐹 ∨ ¬𝑑𝑜𝑒𝑠𝐼𝑛𝑓 𝑙𝑢𝑒𝑛𝑐𝑒 (𝑓𝑐, 𝑠)))

(3.5)
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4 Slither Printer

To collect the necessary data about the implemented smart contracts to reason about
the correct enforcement of access control policies, we extend the Slither framework1 by
implementing a custom printer that calculates direct, indirect and transitive influence
between variables as well as the transitive closure for function calls. The printer can be
found in the "influence_and_calls_plugin" folder provided with this instruction and it
contains the following files:

• SlitherCustomPrinter.md - README file summarizing the general development
approach. Also contains relevant links and hints to better understand the API and
its implementation.

• setup.py - Used to install the printer as mentioned in step 7 in Chapter 1.3. Also
it contains meta-information about the printer like the author and the version. Its
structure is normal for slither printer as explained in the example2.

• __init__.py - Also based on Slithers custom printer structure. Summarizes the printers
and detectors that should be added with this plugin.

• influence_and_calls.py - This file contains our printer and all its functionality, so
it should be reviewed. This is partly based on the data-dependency printer3, which is
a standard part of the framework. All necessary explanations about its functionality
are given in the comments.

It needs to be remarked that the printer provides an overapproximation of the influence
and function call relations since it "blindly" calculates the transitive closure at the end.

1https://github.com/crytic/slither
2https://github.com/crytic/slither/tree/master/plugin_example
3https://github.com/crytic/slither/blob/master/slither/printers/summary/data_depenency.py
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