JsonSchemaDSL and JsonGrammar installation tutorial

Introduction

In this tutorial we show how to install JsonSchemaDSL and JsonGrammar. JsonSchemaDSL
depends on JsonGrammar to generate the Xtext grammar associated with the JSON
Schema created with JsonSchemaDSL.
The prerequisites for JsonSchemaDSL and JsonGrammar are :
e Windows 10
Eclipse IDE 2021 03 R / Modeling Tools
Jdk 11
OCL
Maven
EMF Compare
ATL
o XText
In the following we show how to install all of them, to have an environment to practice.

Eclipse IDE 2021 03 R / Eclipse Modeling Tools package

1. Access the page htips://www.eclipse.org/downloads/packages/release/2021-03/r

@ edlipse.org/downloads/packages/release/2021-03/r
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The Eclipse Installer 2021-03 R now includes a JRE for macOS, Windows and Linux.

Try the Eclipse Installer 2021-03r Download

The easiest way to install and update your Eclipse Development macOS x86_64

Environment. Windows
Linux x¢

Find out more
& 2,517,844 Installer Downloads
2,906,737 Package Downloads and Updates

Eclipse IDE 2021-03 R Packages

2. Scroll down and install The Eclipse Modeling Tools.

Eclipse Modeling Tools
439MB 6,585 DOWNLOADS

The Modeling package provides tools and runtimes for building model-based Windows x86_64
applications. You can use it to graphically design domain models, to leverage

‘ those models at design time by creating and editing dynamic instances, to macOS x86_64
collaborate via Eclipse’s team support with facilities for comparing and merging Linux x86_64 | AArch64
models and model instances structurally, and finally to generate Java code from
those models to produce complete applications. In addition, via the package's
discover catalog, you can easily install a wide range of additional powerful, model-
based tools and runtimes to suit your specific needs

e

You can also go directly to the link:
https://www.eclipse.org/downloads/packages/release/2021-03/r/eclipse-modeling-tools

In all cases be sure that you are installing Eclipse IDE 2021 03 R / Modeling Tools. You have
to unzip the downloaded file to a folder of your PC.


https://www.eclipse.org/downloads/packages/release/2021-03/r
https://www.eclipse.org/downloads/packages/release/2021-03/r/eclipse-modeling-tools

3. Install java 11 in your PC

Once you have downloaded JAVA 11 on your PC, you have to add it to the installed JRE of
Eclipse (clicking on “Installed JREs”), and associate it to JavaSE-11 in the execution
environment as in the screenshot below. To open the Preferences click
Window->Preferences in the top Eclipse Menu.

= Preferences

type filter text

Gvow

Idioms This page displays the JREs compatible for each execution environment.
Install/Update When multiple JREs are compatible with an environment, a default JRE can be specified by ¢
v Java
Execution Environments: Compatible JREs:
Appearance
Build Path =\ CDC-1.0/Foundation-1.0 [] =\ jdk-11.0.10 [perfect match]
Code Style = OSGi/Minimum-1.0
Compiler =1 CDC-1.1/Foundation-1.1
Debug = JRE-1.1
Editor =1 05Gi/Minimum-1.1
v Installed JREs =i\ J2SE-1.2
Execution Environments B4 OSGi/Minimum-1.2
JUnit B\ J2SE-13
Properties Files Editor B4 J2SE-1.4
JsonSchemaDsl E\J2SE-1.5
Logic Diagrams =\ JavaSE-1.6
Maven &\ JavaSE-1.7
Model Editor B JavaSE-18
mcdzl Validation = JavaSE-9
M"f & JavaSE-10
vn =i JavaSE-11
ocL =i\ JavaSE-12
W Javabke-
Oomph
=i JavaSE-13
Overlays
Plug-in Development =i JavaSE-14
Run/Debug =i JavaSE-15
Sirius
Validation Environment description:
Version Control (Team) Java Platform, Standard Edition 11
Xcore <

v

Apply and Close Cancel

Once you have Eclipse IDE 2021 03 R/ Modeling Tools installed and running, install on it
the following required dependencies.

Required Eclipse plugins

All the required plugins have to be downloaded from the site
http://download.eclipse.org/releases/2021-03

4. Add a site
e Open Help -> Install New Software
e Click Add and fill the dialog box as in the picture below
o Name: 2021-03

o Location: http://download.eclipse.org/releases/2021-03
e Click Add

Available Software
'

Select a site or enter the location of a site.

Workwith: | type or selecta site Add. Manage..
Select Al
Name S Add Repository o x F Desclect Al
1@ There is no site selected.
Name: [2021-03 Local
Location: | httpy/download.eclipse.org/releases/2021-03 Archive...
oK
1


http://download.eclipse.org/releases/2021-03

5.

6.

7.

Install OCL

Open Help -> Install New Software

Select the previously added site for work with like in the screenshot below

[ ]
e Filter by “ocl” like in the screenshot below
e Tick the checkboxes like in the figure and install.

: Install

Available Software

Check the items that you wish to install.

‘Work with; | 2021-03 - http;//download.eclipse.org/releases/2021-03

|oc|

Name
v 00 General Purpose Tools
(gl OCL Classic SDK: Ecore/UML Parsers,Evaluator,Edit Developer Resources
+ [/ Modeling
(g- OCL Build Support
[g- OCL Build Support Developer Resources
(g OCL Classic SDK: Ecore/UML Parsers,Evaluator,Edit Developer Resources
(g OCL Examples and Editors SDK
(3 OCL Examples and Editors SDK Developer Resources.

Install Maven

e Open Help -> Install New Software

Version

5.14.0.v20210310-0557

6.14.0.v20210310-0557
6.14.0.v20210310-0557
5.14.0.v20210310-0557
6.14.0.v20210310-0557
6.14.0.v20210310-0557

e Select the previously added site for work with like in the screenshot below
e Filter by “maven” like in the screenshot below
e Tick the checkboxes as in the figure and install.

-
& Install

Available Software

Check the items that you wish to install

Work with: | 2021-03 - http://download.eclipse.org/releases/2021-03

‘ maven

Name
v 000 General Purpose Tools

[§- m2e - sIf4]j over logback logging (Optional)
v (00 Web, XML, Java EE and OSGI Enterprise Development

- m2e connector for mavenarchiver pom properties
{§- m2e-wtp - Maven Integration for WTP

Install EMF Compare

Open Help -> Install New Software

{§- m2e PDE - Maven Integration for Eclipse Plugin Development

Version

(§= m2e - Maven Integration for Eclipse (includes Incubating components)  1.17.2.20210219-1922

1.17.0.20200924-1339
1.17.2.20210225-0900

0.17.5.202002191804
1.4.4.20201128-1705

Select the previously added site for work with like in the screenshot below

[ J
e Filter by “emf’ like in the screenshot below
e Tick the checkboxes as in the figure and install.

Work with: | 2021-03 - http://download.eclipse.org/releases/2021-03

‘ emf

Name
~ []ill Database Development
[[] 4+ Data Tools Platform Model Base
~ [] Uil EclipseRT Target Platform Components
[[] 4+ EMF RAP Target Components
« W1 Modeling
[] 4+ Acceleo
[§- EMF - Eclipse Modeling Framework Xcore SDK
[] 4+ EMF ODA Driver SDK
[] 4+ Extended Editing Framework - EMF Edit generation using Acceleo
(3 Model comparison (EMF Compare) - UML2 support

Version

1.14.102.201911250848

2.25.0.v20210114-1734

3.7.11.202102190929
1.17.0.v20210125-0553
1.9.0.v20200917-0747
1.5.1.201601141612
3.3.14.202102231741



8. Install ATL
Open Help -> Install New Software

e Select the previously added site for work with like in the screenshot below
e Filter by “atl” like in the screenshot below
[ ]

Tick the checkboxes as in the figure and install.

Work with: ‘ 2021-03 - http://download.eclipse.org/releases/2021-03

| atl

Name
~ [#] 100 Modeling
(- ATL SDK - ATL Transformation Language SDK

Version

4.3.0.v202102220734

9. Install Xtext

e Open Help -> Install New Software

e Select the previously added site for work with like in the screenshot below
e Filter by “xtext” like in the screenshot below

[ J

Tick the checkboxes as in the figure and install.

: Available Software

Check the items that you wish to install.

{ Work with: ‘ 2021-03 - http://download.eclipse.org/releases/2021-03

‘ xtext

Name
v [“] 0 General Purpose Tools
§ Xtext Complete SDK
v [[]m Modeling
[]@: sirius Integration with Xtext
[]@ Xtext Complete SDK

Version

2.25.0.v20210301-1429

| 6.4.2.202103091337

2.25.0.v20210301-1429



JSON Schema DSL and JSON Grammar installation.

Once completed the installation of the required Eclipse and dependencies (and having
restarted it), it is time to install our artifacts.

These two artifacts can be found in the repository in the tag of the release.

9. For the release 1.0.1, access to the following link:
https://qgithub.com/lowcomote/ijsonschemadsl.parent/releases/tag/1.0.1

((agithub.com/lowcomote/jsonschemadsl parent/releases/tag/1.0.1
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Issues Pull requests Actions Projects Wiki Security Insights Settings
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1.0
alessandrocolantoni released this on May 17 - 40 commits to master since this release
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e Merge branch develop

©
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@ atjku.bise.ecore json.grammar.update.eclipse-repository-1.0.0-SNAPSHOT zip
@ jsonschemadsl.repository-1.0.1zip
[3) Source code (zip)

[?) Source code (tar.gz)

10. Download the two zip files

(i) at.jku.bise.ecore.json.grammar.update.eclipse-repository-1.0.0-SNAPSHOT.zip
(i) jsonschemadsl.repository-1.0.1.zip

11. Install JSON Grammar
(at.jku.bise.ecore.json.grammar.update.eclipse-repository-1.0.0-SNAPSHOT.zip).

Open Help -> Install New Software
Click Add to add a repository

Click Archive, and browsing to the location where you have downloaded
JSON Grammar zip file, as in the picture below

Available Software

Select a site or enter the location of a site.

Work with: | type or select a site

I@ S Add Repository = X :
Name [
] ® Thq Name: ‘ JSON GrammarZIP( ‘ Local...
Location: ‘jar:fiIe:/C:/Users/AIessandro.coIamoni/Desk‘top/atjku.bise.ecore.Jsom.grammar‘update.eclipse—repository—1‘D.D—SNAPSHOT.zip!/ ‘ Archive...
oK
@ Add Cancel



https://github.com/lowcomote/jsonschemadsl.parent/releases/tag/1.0.1

Click add

Select the JSON Grammar Update and Feature check boxes, like in the
screenshot below and install it. Restart Eclipse. Ignore the security warning.

Available Software

Check the items that you wish to install.

Work with: ‘ JSON Grammar ZIP - jarfile;/C:/Users/Alessandro.colantoni/Desktop/atjku.bise.ecore json.grammar.updat

type filter text

Name

M 10 JSON Grammar Update

L Feature

12. Install JSON Schema DSL.
The same steps for JsonGrammar have to be repeated for JsonSchema

Open Help -> Install New Software

Click Add to add a repository
Click Archive, and browe to the location where you have downloaded the file

jsonschemadsl.repository-1.0.1.zip

Click add

Version

1.0.0.202105171534

Tick the checkboxes like in the screenshot below.
Install it and restart Eclipse.lgnore the security warning.

Available Software

Check the items that you wish to install.

Work with: | jsonSchemaDSL ZIP - jarfile;/C;/Users/Alessandro.colantoni/Desktop/jsonschemadsl.repository-1.0.1-SNAPSHOT zipl/
| type filter text
Name Version
~ [] 00 JsonSchemaDsl
1.0.1.202105171106

|

(- JsonSchemaDsl Feature
000 JsonSchemaDsl (Sources)

13. Create your first project

Create a new general project with the New Project wizard, as shown in the

screenshot below.

Create a file with extension .jschema, as shown in the screenshot below.

Click Yes when asked if you want to convert your project to an Xtext project.

& New Project

Select a wizard

Create a new project resource

Wizards:

type filter text

2 Java Project
5 Plug-in Project
« & General
I Faceted Project
L Project
& ATL
& Eclipse Modeling Framework
& EMF Forms
= EME Parsl

File

Create a new file resource.

Enter or select the parent folder:

firstProject

= compareV2Vv3
1= firstProject

File name: | firstjschema

Advanced >>

S Configure Xtext

‘6 Do you want to convert firstProject’ to an Xtext project?
Ly

[J Remember my decision

Yes No

Cancel

Auvances




e Open your first.jschema, and use the context assist (CTRL+space) to better
edit it.

e Open the Eclipse Problems and Properties views, to see errors and warnings
details

Once completed the steps of this tutorial, you can continue on the JsonSchemaDSL Quick
Start.



