cork - a Scientific colour map”™ v s

Version 7.0.0

v Perceptually uniform

v Perceptually ordered

v Colour-vision-deficiency (CVD) friendly
v Readable as black and white print

v Provided in all major formats

v Citable & reproducible

% Diverging

% Light centred; no black

Crameri, F. (2018), Scientific colour-maps, Zenodo, doi:10.5281/
zenodo.1243862

Crameri, F. (2018), Geodynamic diagnostics, scientific visu-
alisation and StaglLab 3.0, Geosci. Model Dev., 11, 2541-2562,
doi:10.5194/gmd-11-2541-2018

Crameri, F., G.E. Shephard, and P.J. Heron (2020), The misuse
of colour in science communication, Nature Communications, 11,
5444. doi: 101038/s41467-020-19160-7

*www.fabiocrameri.ch/cork
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http://doi.org/10.5281/zenodo.1243862
http://doi.org/10.5194/gmd-11-2541-2018
https://doi.org/10.1038/s41467-020-19160-7
http://www.fabiocrameri.ch/cork
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1

Creators

Author:

Contributors:

Fabio Crameri

Grace Shephard - Conversion to .cpt format, promotion of Sci-
entific colour maps, and other contributions

Phil Heron - Promotion of Scientific colour maps

Clint Conrad - Wider compatibility of .cpt format

Matteo Albano - Conversion to .clr format; QGIS compatibility
Casper Pranger - Mathematica compatibility

Alexis Plunder - Wider compatibility of .xml format

Krister Stroete Karlsen - User instruction for use with python
Philippe Riviere - Conversion instruction for d3

Emilia - Plotly versions

Thomas Lin Pedersen - The ‘scico’ package for use with R
Paul Wessel - Built-in version for ‘GMT’

Wolfgang Schwanghart - Built-in version for ‘TopoToolbox’
Chad Greene - MatLab file exchange version

Sean Trim - Conversion to .pal format

George Edward Campbell - Conversion to .lut format
Christophe Leterrier - NeuroCyto LUTs Fiji add-on

Kirstie Wright - User instruction for use with Petrel

Craig Williams - Style file for ArcGIS Pro

Jennifer Levett - Conversion to SKUA-GOCAD .xcmap format
Sam Hatfield - Conversion to Ncview .ncmap format

Patrick Brockmann - Conversion to Ferret .spk format
Thomas Morrow - Conversion to QPS .cmap format

Mark Wieczorek - Import init file for Python

Anthony Jamelot - Additions to import init file for Python
Andy Emery - Conversion to Kingdom .clm and .clb format
Benjamin Witschas - Conversion to Originlab .pal format
Steven Reddy - Conversion to Photoshop .grd format

Callum Rollo - Python package via pip and anaconda
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http://www.fabiocrameri.ch/contact.php
http://www.mn.uio.no/geo/english/people/aca/ceed/gracees/
https://philheron.com
http://www.mn.uio.no/geo/english/people/aca/ceed/clinton/
https://twitter.com/matteo_albano?lang=en
https://www.erdw.ethz.ch/en/people/profile.html?persid=205634
https://sites.google.com/site/alexisplunder
http://www.mn.uio.no/geo/english/people/aca/ceed/krikarls/
https://twitter.com/recifs?lang=en
https://twitter.com/mathinpython?lang=en
https://twitter.com/thomasp85?lang=en
http://www.soest.hawaii.edu/GG/people/gg_profile_wessel_p.html
https://twitter.com/wschwanghart?lang=en
http://www.chadagreene.com
http://www.seantrim.com
https://twitter.com/geobellward
https://twitter.com/christlet
http://www.rocksandwiggles.com
https://twitter.com/williamscraigm
http://www.mirageoscience.com
https://samhatfield.co.uk/
https://github.com/PBrockmann
https://twitter.com/thethomasmorrow
http://www.oca.eu/fr/mark-wieczorek
mailto:jamelot@labogeo.pf
https://twitter.com/AndyDoggerBank
https://www.dlr.de/pa/desktopdefault.aspx/tabid-2357/3477_read-19538/sortby-lastname/
http://www.geoscienceatomprobe.org/contact.html
https://github.com/callumrollo

2 Sources of inspiration

3 Acknowledgement

I —

The ‘endrainbow’ campagn initiated by Ed Hawkins.

The Colorbrewer colour maps, the MPL colour maps, the cividis
colour map, the CMOcean colour maps, and the CET colour maps.

Peter Kovesi’s work, in particular, has helped to develop the Sci-
entific Colour Maps: some of the many excellent, openly acces-
sible scripts were used as a basis for the applied colour-map
diagnostics and to make the file conversion to .tbl and .act for-
mats.

Please acknowledge the free use of the colour maps.

e.g., "The scientific colour map cork (Crameri 2018) is used in this
study to prevent visual distortion of the data and exclusion of read-
ers with colour-vision deficiencies (Crameri et al., 2020 ).”

The software : Crameri, F. (2018a), Scientific colour-maps. Zenodo. http:/

doi.org/10.5281/zen0do.1243862

The research : Crameri, F.,, G.E. Shephard, and P.J. Heron (2020), The mis-

use of colour in science communication, Nature Communi-
cations, 11,5444, doi: 10.1038/5s41467-020-19160-7
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http://www.climate-lab-book.ac.uk/2014/end-of-the-rainbow/
http://colorbrewer2.org
https://bids.github.io/colormap/
https://doi.org/10.1371/journal.pone.0199239.s002
https://doi.org/10.1371/journal.pone.0199239.s002
https://matplotlib.org/cmocean/
https://peterkovesi.com/projects/colourmaps/
https://www.peterkovesi.com
https://www.peterkovesi.com/matlabfns/index.html#colour
https://www.peterkovesi.com/matlabfns/index.html#colour
http://doi.org/10.5281/zenodo.1243862
http://doi.org/10.5281/zenodo.1243862
https://doi.org/10.1038/s41467-020-19160-7

4 |Instructions
41 ArcGIS Pro
411 style file

Download the style file for the ArcGIS Pro provided by Craig
Williams on https:/www.arcgis.com/home/.

42 d3
421 xml format

An instruction to convert the .xml format to d3’s internal repre-
sentationis provided by Philippe Riviere at https:/beta.observablehqg
.com/@ fil/colormaps.

4.3 Ferret
4.31 .spk format

To use the .spk colour map files in Ferret, follow the instructions
given on the official homepage: https:/ferret.omel.noaa.gov/Ferret/
documentation/users-guide/customizing-plots/COLOR#_VPID_247.

4.4 Fledermaus & Qimera
4.41 .cmap format

To use the .cmap colour map files in the QPS software Fle-
dermaus and Qimera, download the external package from
www.fabiocrameri.ch/colourmaps or via the direct link.

45 GIMP/Inkscape
451 .gpl format

To import the .gpl palettes, launch GIMP and go to Windows >
Dockable Dialogs > Palettes to open the Palettes dialog. Then
right-click anywhere on the list of palettes and select Import
Palette. In the *Import a New Palette* dialog, select the *Palette
file* radio button and then the button just to the right of the
folder icon.

Then, navigate to and select the desired .gpl file in the corre-
sponding folder. Clicking the *Import* button will add the scien-
tific colour map to the existing list of palettes.

46 GMT

Note: GMT 6.0.0 and later offers built-in scientific colour maps
(see Section 5).

461 .cpt format

The file davos.cpt can be resampled for a given z-value range
with the Generic Mapping Tools (GMT; http:/www.generic-mapping-
tools.org) command “makecpt”.

6 Scientific Colour Maps


https://twitter.com/williamscraigm
https://twitter.com/williamscraigm
https://www.arcgis.com/home/item.html?id=db36aff062ec4218a9bd384b74dc6e9d
https://beta.observablehq.com/@fil/colormaps
https://beta.observablehq.com/@fil/colormaps
https://ferret.pmel.noaa.gov/Ferret/documentation/users-guide/customizing-plots/COLOR#_VPID_247
https://ferret.pmel.noaa.gov/Ferret/documentation/users-guide/customizing-plots/COLOR#_VPID_247
http://www.fabiocrameri.ch/colourmaps
http://www.fabiocrameri.ch/resources/ColourMaps/QPS_cmap_ScientificColormaps.zip
http://www.generic-mapping-tools.org
http://www.generic-mapping-tools.org

For example to resample for an array from -2000 to 2000 in 100
increments you could generate a new file with:

$makecpt -Cdavos.cpt -T-2000/2000/100 > davos_resampled.cpt

4.7 Gnuplot
471 .pal format

Launch the Gnuplot shell and load the specific .pal file (e.g., bat-
low) into Gnuplot with:

user@computer gnuplot
gnuplot> load "batlow.pal"

4.8 ImagedJ/Fiji
481 lut format

The .lut colour-map file (e.g., *batlow.lut*) can be imported to
Imaged or Fiji by placing it in the *luts* folder (to reveal folder
location in Fiji: File > Show Folder > LUTs). Upon restart of Im-
aged, the scientific colour map(s) should then be available under
Image > Lookup Tables.

Alternatively, the colour-map .Iut file may be applied using either
(a) File > Open, (b) File > Import > LUT, or (c) drag and drop
the .lut file onto the Imaged window. To view available LUTs:
Image > Color > Display LUTs.

4.8.2 NeuroCyto LUTs add-on

Detailed information about how to use a simple add-on that adds
a handy LUTs drop-down menu to the Fiji user interface is given
on https:/forum.image.sc/t/neurocyto-luts-update-site/26244.

49 Kingdom
491 .clm format

On any screen, select Show color bar from the toolbar. Above
the colour bar that appears, select Select?, then under Files of
type choose Color Bars (*.CLM), then navigate to the location
the colour-map files are stored.

The continuous Scientific Colour Maps are also provided exter-
nally in Kingdom'’s native file format, .clb, for easier implementa-
tion. The clb files are available separately on www.fabiocrameri.ch/
colourmaps. To import them in Kingdom, select, on any screen,
Show color bar from the toolbar. Above the colour bar that ap-
pears, select Select?, then navigate to the location the colour-
map files are stored.

410 Mathematica
4101 .mat format

ColorMapSuitePath = "/Path/To/ColourMapSuite/";

Scientific Colour Maps 7


https://forum.image.sc/t/neurocyto-luts-update-site/26244
http://www.fabiocrameri.ch/resources/ColourMaps/SCM6_clb_for_Kingdom.zip
http://www.fabiocrameri.ch/resources/ColourMaps/SCM6_clb_for_Kingdom.zip

ColorMapSuite [name_String] := ColorMapSuite[name, -1]
ColorMapSuite[name_String, el_] := With[{
list =
Transpose@{Subdivide[0, 1, 255],
RGBColor @QQ
First@Import [
ColorMapSuitePath <> "/" <> name <> "/" <> name <> ".mat"]}

},
Blend[list, {##}[[ell]] &
]
The function call ColorMapSuite["name", i = -1] returnsalambda

function whose ith argument is used to define color (see the
Manual for ColorFunction for details). "name" should be replaced
with the name (in quotes) of the color scheme, e.g. "davos". Be
sure to set the variable ColorMapSuitePath to the path where your
ColorMapSuite is installed.

General rules are:

* 1D plots of 1D functions/data: no (default) argument *i* suf-
fices

+ 2D plots of 2D functions/data: no (default) argument *i* suf-
fices

* 3D plots of 2D functions/data: use *i* = 3

* 3D plots of 3D functions/data: use *i* = 4 (results might be
worse than default Mathematica color functions, possibly
due to lack of surface normal mapping)

ContourPlot [Sin[x] Sin[y]l, {x, 0, 2 Pi},
{y, 0, 2 Pi}, ColorFunction -> ColorMapSuite["davos"]]

411 MatlLab
411 .mat format)

Load the colour map into MatlLab, either by adding the .mat file
to the MatLab search path and using the command:

load('davos.mat');

or by specifying the full file path to the .mat file:
load (' ~/work/Colormaps/davos.mat');

Then use it, for example, with:

figure(1)
colormap(davos)
colorbar

411.2 File-exchange app

A convenient MatlLab package provided by Chad Greene con-
taining the full scientific colour-map suite is available on MatlLab
file exchange.

8 Scientific Colour Maps


https://se.mathworks.com/matlabcentral/fileexchange/68546-crameri-perceptually-uniform-scientific-colormaps
https://se.mathworks.com/matlabcentral/fileexchange/68546-crameri-perceptually-uniform-scientific-colormaps

412 Ncview
4121 .ncmap format

The colour map .ncmap files can live in the following places:

1. NCVIEW_LIB_DIR, which is determined at installation time. A rea-
sonable choiceis /usr/local/lib/ncview. 2. In a directory named
by the environmental variable NCVIEWBASE. 3. If there is no envi-
ronmental variable NCVIEWBASE, then in $HOME. 4. In the current
working directory.

Then when you open Ncview, it should automatically have all of
the colour maps available.

413 Originlab
4131 .pal format

To use the .pal colour map files in the Originlab software, down-

load the external package from www.fabiocrameri.ch/colourmaps
or via the direct link. The .PAL files can then be copied to the

origin palette folder and used similarly to the Originlab default

color palettes.

414 Paraview
4141  xml format

Using Scientific colour maps in Paraview is done via the following
procedure:

Click Edit color map panel. Once the colour map settings open,
click the folder with the heart (i.e., Choose Preset), then Import,

and then choose the PARAVIEW.xml format (e.g., batlow_PARAVIEW.xml).
The colour map is now loaded and saved in Paraview, so one can

now simply search for the colour map name (e.g., batlow) in the
search field for the colour maps. Click on the desired colour map

and hit Apply.

415 Petrel
4151 .alut format

To import colour maps, select the templates pane and colour
tables folder.

Then select the folder to import into (or insert a new folder) and
right click import on selection.

Select colour tables (alut files) (*.alut) to view and select
all suitable colour maps for import.

Accept default settings trim colour control points and trim
opacity control points and finally use as any other colour table
within Petrel.
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http://www.fabiocrameri.ch/colourmaps
http://www.fabiocrameri.ch/resources/ColourMaps/Originlab_PAL_ScientificColourMaps.zip

416 Photoshop
4161 .grd format

The .grd format to read into Photoshop provided by Steven
Reddy can be found at: www.geoscienceatomprobe.org/downloads.html

417 Plotly
4171 py format

Plotly versions of the scientific colour maps are provided by
Emilia are available at https:/github.com/empet/scientific-colorscales.

The plotly scientific colour maps (see the file scicolorscales.py)
were created by converting the provided .py file of each colour
map.

Direct applications and some scientific tests are illustrated in this
Jupyter Notebook: http:/nbviewerjupyter.org/github/empet/
scientific-colorscales/blob/master/Tests-for-scientific-colorscales.ipynb.

418 Python
4181 Package (pip and anaconda)

The convenient python package, https:/pypi.org/project/cmcrameri/,
by Callum Rollo is available through pip and anaconda.

Install with pip:
pip install cmcrameri

Install with conda:

conda config --add channels conda-forge
conda install cmcrameri

Usage example:

from cmcrameri import cm

import matplotlib.pyplot as plt

import numpy as np

x = np.linspace(0, 100, 100) [None, :]

plt.imshow(x, aspect='auto', cmap=cm.batlow) # or any other colourmap
plt.axis('off"')

plt.show()

418.2 init file

A simple init file located in ScientificColourMaps6/+T0O0LS/ can
be used to make the whole suite of colour maps readily avail-
able in python: Place the __init__.py file in the main directory
ScientificColourMaps7/ and update your PYTHONPATH environ-
ment like this:

(for linux/bash)

export PYTHONPATH=$PYTHONPATH:/full/path/to/ScientificColourMaps7/

10 Scientific Colour Maps


http://www.geoscienceatomprobe.org/downloads.html
https://github.com/empet/scientific-colorscales
http://nbviewer.jupyter.org/github/empet/scientific-colorscales/blob/master/Tests-for-scientific-colorscales.ipynb
http://nbviewer.jupyter.org/github/empet/scientific-colorscales/blob/master/Tests-for-scientific-colorscales.ipynb
https://pypi.org/project/cmcrameri/

Then, in any python, you can import the palette collection, by
using import ScientificColourMaps7 as SCM7, which allows for
example commands like

plt.imshow(some_data, cmap=SCM7.berlin) # Linear palette
plt.imshow(some_data, cmap=SCM7.berlin_r) # Reversed, linear
plt.imshow(some_data, cmap=SCM7.berlin25_r) # Reversed, 25 steps, discrete

418.3 txt format

Step 1: Load colour-map data

Load the colour-map data into Python using numpy.loadtxt():

import numpy as np
cm_data = np.loadtxt("cork.txt")

Step 2: Set up colour map

Use matplotlib.colors.LinearSegmentedColormap() to create a
colour map that can be used with matplotlib.

from matplotlib.colors import LinearSegmentedColormap
cork_map = LinearSegmentedColormap.from_list(?cork?, cm_data)

Complete example:

import numpy as np
import matplotlib.pyplot as plt
from matplotlib.colors import LinearSegmentedColormap

cm_data = np.loadtxt("cork_RGB(0-1).txt")
cork_map = LinearSegmentedColormap.from_list(?cork?, cm_data)

x = np.linspace(0, 100, 100) [None, :]
plt.imshow(x, aspect=7auto?,cmap=cork_map)
plt.axis(?0ff?)

plt.show()

418.4 palettable library
The palettable library provides the Scientific Colour Maps (and
other scientific colour maps) in a convenient way for use with
e.g., matplotlib. Palettable is available on PyPI for installation

via pip: pip install palettable. Palettable is compatible with
Python 2.6, 2.7, and Python 3. For more instructions see here.

419 QGIS
4191 xml format
Load the colour map into QGIS in:

Settings > Style manager > Import/Export > Import symbol(s)
> select the xxx_QGIS.xml file.

Scientific Colour Maps 1


https://github.com/jiffyclub/palettable
https://jiffyclub.github.io/palettable/#documentation

4.20

4201

4.21

4211

4.22

4221

R

scico package

SKUA-GOCAD

xcmap format

Vislt

ct format

‘scico’ (https:/travis-ci.org/thomasp8&5/scico) - pronounced as
“psycho” - is a small package developed by Thomas Lin Peder-
sen that provides access to the scientific colour maps within R. It
provides colour palettes for ‘ggplot2’) without requiring ‘ggplot2’
to be installed.

scico can beinstalled from CRAN with install.packages('scico').

If you want the development version then install directly from
GitHub:

# install.packages("devtools")
devtools::install_github("thomasp85/scico")

For further details and user instructions are included in a README
file within ‘scico’.

To import a colormap into a SKUA-GOCAD project, navigate to
File > Import > GOCAD Resources > Colormaps.

Alternatively, for advanced users, to include a colormap as a re-
source in all new projects, insert the .xcmap text into the *col-
ormaps.xml* file located in */Gocad/1ib/app-defaults.

The file davos.ct can imported to Vislt by placing the .ct file in
the wisit directory, which can be found on macOS under e.g.,:

/Applications/VisIt.app/Contents/Resources/ ...
. 2.12.3/darwin-x86_64/resources/colortables

The colour map should appear in the built-in list after Vislt has
been restarted.

5 Software with built-in versions

GMT 6.0 and later

* TopoToolbox 2.2 and later
* Staglab 3.0 and later

* SubMachine

* Geoscience ANALYST 2.80 and later
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https://travis-ci.org/thomasp85/scico
https://github.com/tidyverse/ggplot2
https://travis-ci.org/thomasp85/scico
https://travis-ci.org/thomasp85/scico
https://docs.generic-mapping-tools.org/latest/cookbook/cpts.html
https://topotoolbox.wordpress.com/2018/08/13/overview-of-scientific-colormaps/
http://www.fabiocrameri.ch/StagLab.php
https://www.earth.ox.ac.uk/~smachine/cgi/index.php
http://www.mirageoscience.com/our-products/software-product/geoscience-analyst

6 References

7 Version history

Included colour-map diagnostics are based on:

Kovesi (2015), Good Colour Maps: How to Design Them, CoRR,
abs/1509.03700, http:/arxiv.org/abs/1509.03700* and related
MatLab functions available at https:/www.peterkovesi.com/ mat-
labfns/index.html#colour.

For further details see:

Crameri, F. (2018), Geodynamic diagnostics, scientific visual-
isation and StaglLab 3.0, Geosci. Model Dev. 1, 2541-2562,
doi:10.5194/gmd-11-2541-2018

Crameri, F., G.E. Shephard, and P.J. Heron (2020), The misuse
of colour in science communication, Nature Communications, 11,
5444. doi: 101038 /541467-020-19160-7

Version 1: Original colour-map suite (bilbao, broc, cork, davos, devon,

grayC, lajolla, oslo, vik)

Version 2 : Additional colour-map file formats (.ct, .py, .svg)

Version 3 : Additional colour-map file format (.txt)

Dark background palettes (berlin, lisbon, tofino)
Additional sequential palettes (lapaz, tokyo, turku)
Surface topography special palette (oleron)

Seismic tomography special palette (roma)

Version 4 : Additional sequential palettes (acton, bamako, buda, hawaii,

imola, nuuk)
Scientific rainbow palette (batlow)

Additional colour-map file formats (xmIQGIS, .clr)

Version 5 : Discrete colour maps (e.g., batlowl0)

Improved perceptual uniformity of the original (v1) palettes
Minor colour adjustment to vik

Additional colour-map file formats (.alut, .ct, lut, .ncmap,
pal, .spk, .xcmap)

Version 6 : Categorical colour maps (batlowS, devonS, davosS, osloS,

lapaz$S, actonS, lajollas, bilbaoS, grayCS, tokyo S, turkuS, ba-
makoS, nuukS, hawaiiS, budas, imola$S)

Cuyclic colour maps (romaO, brocO, corkO, vikO)

Improved colour-map diagnostics for perceptual uniformity
Additional colour-map file formats (.cIm)

Improved User guide

Change to MIT License

Scientific Colour Maps
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https://www.peterkovesi.com/matlabfns/index.html#colour
https://www.peterkovesi.com/matlabfns/index.html#colour
https://doi.org/10.5194/gmd-11-2541-2018
https://doi.org/10.1038/s41467-020-19160-7

Version 7 :

Additional diverging palettes (bam, vanimo)

Additional cyclic palette (bamO)

Additional multi-sequential palettes (bukavu, fes)
batlow W: batlow with white ending

batlowK: batlow with black ending

cork: Improved lightness symmetry

roma: Improved lightness symmetry

More formats (e.g., .pal for OriginLab)

Updated __init__.py to flip colour gradients by Tobias Staal
New Python package by Callum Rollo

Colour map type and class flow chart
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8 License

The Scientific Colour Maps are licensed under a MIT License
Copyright (c) 2021, Fabio Crameri

Permission is hereby granted, free of charge, to any person ob-
taining a copy of this software and associated documentation
files (the "Software”), to deal in the Software without restric-
tion, including without limitation the rights to use, copy, modify,
merge, publish, distribute, sublicense, and/or sell copies of the
Software, and to permit persons to whom the Software is fur-
nished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be
included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS I1S”, WITHOUT WARRANTY OF
ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR
ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN AC-
TION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT
OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
OTHER DEALINGS IN THE SOFTWARE.

e
Scientific
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https://choosealicense.com/licenses/mit/

	Creators
	Sources of inspiration
	Acknowledgement
	Instructions
	ArcGIS Pro
	d3
	Ferret
	Fledermaus & Qimera
	GIMP/Inkscape
	GMT
	Gnuplot
	ImageJ/Fiji
	Kingdom
	Mathematica
	MatLab
	Ncview
	Originlab
	Paraview
	Petrel
	Photoshop
	Plotly
	Python
	QGIS
	R
	SKUA-GOCAD
	VisIt

	Software with built-in versions
	References
	Version history
	License

