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1 Creators, supporters & sources of inspiration
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Grace Shephard – Conversion to .cpt and .ase formats, promo-Contributors:
tion of Scientific colour maps, and other contributions

Phil Heron – Promotion of Scientific colour maps

Clint Conrad – Wider compatibility of .cpt format

Matteo Albano – Conversion to .clr format; QGIS compatibility

Casper Pranger – Mathematica compatibility

Alexis Plunder – Wider compatibility of .xml format

Krister Stræte Karlsen – User instruction for use with python

Philippe Rivière – Conversion instruction for d3

Emilia – Plotly versions

Thomas Lin Pedersen – The ‘scico’ package for use with R

PaulWessel – Built-in version for ‘GMT’

Wolfgang Schwanghart – Built-in version for ‘TopoToolbox’

Chad Greene – MatLab file exchange version

Sean Trim – Conversion to .pal format
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Jennifer Levett – Conversion to SKUA-GOCAD .xcmap format

Sam Hatfield – Conversion to Ncview .ncmap format

Patrick Brockmann – Conversion to Ferret .spk format

Thomas Morrow – Conversion to QPS .cmap format

MarkWieczorek – Import init file for Python

Anthony Jamelot – Additions to import init file for Python

Andy Emery – Conversion to Kingdom .clm and .clb format

BenjaminWitschas – Conversion to Originlab .pal format

Steven Reddy – Conversion to Photoshop .grd format

Callum Rollo – Python package via pip and anaconda

Pierre Lanari – Built-in version for ‘XMapTools’

Kaspar Merz – Importable package for ‘OpendTect’

Fabrizio Magrini – Built-in version for ‘SeisLab’

Amando Lasabuda – User instruction for GlobalMapper & MOVE

Megan Brown – Updated __init__.py for SCM 7.0 and 8.0
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Katrin Hättig – Conversion to ODV .pal formats

Alan Baxter, TheFlatType, Gian Maria, Marina von Tscharner, LiSupporters:
Fucheng, Anthony Lanati

4 Scientific Colour Maps

https://www.fabiocrameri.ch/
http://www.mn.uio.no/geo/english/people/aca/ceed/gracees/
https://philheron.com
http://www.mn.uio.no/geo/english/people/aca/ceed/clinton/
https://twitter.com/matteo_albano?lang=en
https://www.geophysik.uni-muenchen.de/de/Members/pranger
https://sites.google.com/site/alexisplunder
http://www.mn.uio.no/geo/english/people/aca/ceed/krikarls/
https://twitter.com/recifs?lang=en
https://twitter.com/mathinpython?lang=en
https://twitter.com/thomasp85?lang=en
http://www.soest.hawaii.edu/GG/people/gg_profile_wessel_p.html
https://twitter.com/wschwanghart?lang=en
http://www.chadagreene.com
http://www.seantrim.com
https://twitter.com/geobellward
https://twitter.com/christlet
http://www.rocksandwiggles.com
https://twitter.com/williamscraigm
http://www.mirageoscience.com
https://samhatfield.co.uk/
https://github.com/PBrockmann
https://twitter.com/thethomasmorrow
http://www.oca.eu/fr/mark-wieczorek
mailto:jamelot@labogeo.pf
https://twitter.com/AndyDoggerBank
https://www.dlr.de/pa/desktopdefault.aspx/tabid-2357/3477_read-19538/sortby-lastname/
http://www.geoscienceatomprobe.org/contact.html
https://github.com/callumrollo
http://pierre-lanari.com
https://www.linkedin.com/in/kasparmerz/?originalSubdomain=ch
https://github.com/fmagrini
https://amandolasabuda.com/about/
https://orcid.org/0000-0002-7195-5969
http://luciaperezdiaz.com
https://www.nioz.nl/en/about/organisation/staff/katrin-hattig
https://www.luciaperezdiaz.com


Sources of inspiration:

The ‘endrainbow’ campagn initiated by Ed Hawkins.

The Colorbrewer colour maps, the MPL colour maps, the cividis
colourmap, theCMOcean colourmaps, and theCET colourmaps.

Peter Kovesi’s work, in particular, has helped to develop the Sci-
entific colour maps: some of the many excellent, openly acces-
sible scripts were used as a basis for the applied colour-map
diagnostics and to make the file conversion to .tbl and .act for-
mats.

References:

Included colour-map diagnostics are based on:

Kovesi (2015), Good Colour Maps: How to Design Them, CoRR,
abs/1509.03700, http://arxiv.org/abs/1509.03700* and related
MatLab functions available at https://www.peterkovesi.com/mat-
labfns/index.html#colour.

For further details see:

Crameri, F. (2018), Geodynamic diagnostics, scientific visual-
isation and StagLab 3.0, Geosci. Model Dev., 11, 2541-2562,
doi:10.5194/gmd-11-2541-2018

Crameri, F., G.E. Shephard, and P.J. Heron (2020), The misuse
of colour in science communication, Nature Communications, 11,
5444. doi: 10.1038/s41467-020-19160-7

2 Acknowledgement

Please acknowledge the free use of the colour maps.! →
e.g., ”The Scientific colour map batlow (Crameri 2018) is used in
this study to prevent visual distortion of the data and exclusion of
readers with colour-vision deficiencies (Crameri et al., 2020).”

The software : Crameri, F. (2018a), Scientific colour maps. Zenodo. http://
doi.org/10.5281/zenodo.1243862

The research : Crameri, F., G.E. Shephard, and P.J. Heron (2020), The mis-
use of colour in science communication, Nature Communi-
cations, 11, 5444. doi: 10.1038/s41467-020-19160-7

Contributions like these are absolutely essential for science,
and the scientific community.

Thank you. – Fabio
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3 Instructions

3.1 Adobe Illustrator

3.1.1 .ase format

The .ase format to read into Adobe Illustrator provided by Grace
Shephard can be found at: www.fabiocrameri.ch/colourmaps.
To import the colour palettes, go to: Adobe Illustrator > Open
New File > Window > Swatches > Swatches Library Menu > Other
Library > #.ase

3.2 Adobe Photoshop

3.2.1 .grd format

The .grd format to read into Adobe Photoshop provided by
Steven Reddy can be found at: www.geoscienceatomprobe.org/
downloads.html

3.3 ArcGIS Pro

3.3.1 style file

Download the style file for the ArcGIS Pro provided by Craig
Williams on https://www.arcgis.com/home/.

3.4 COMSOL Multiphysics

3.4.1 .txt format

Put the .txt colour map files in COMSOL4.0a > data > colortables
(adjust version number, if necessary) Then restart COMSOL and
the Scientific colour maps should be available within the pro-
gram.

3.5 d3

3.5.1 .xml format

An instruction to convert the .xml format to d3’s internal repre-
sentation is provided by Philippe Rivière at https://beta.observablehq
.com/@fil/colormaps.

3.6 Ferret

3.6.1 .spk format

To use the .spk colour map files in Ferret, follow the instructions
given on the official homepage: https://ferret.pmel.noaa.gov/Ferret/
documentation/users-guide/customizing-plots/COLOR#_VPID_247.

3.7 GIMP/Inkscape

3.7.1 .gpl format

To import the .gpl palettes, launch GIMP and go to Windows >
Dockable Dialogs > Palettes to open the Palettes dialog. Then
right-click anywhere on the list of palettes and select Import
Palette. In the *Import a New Palette* dialog, select the *Palette
file* radio button and then the button just to the right of the
folder icon.

Then, navigate to and select the desired .gpl file in the corre-
sponding folder. Clicking the *Import* button will add the scien-
tific colour map to the existing list of palettes.
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3.8 GlobalMapper

To use the Scientific colour maps with GlobalMapper 18 (64 bit),
one can use the .PAL format provided as follows:

• Select Configure

• Select Shader

• Under Custom Shaders, select New

• Select Initialize from palette file

• Choose the Scientific colour map’s “...ORIGINLAB.PAL” file
version

3.9 GMT

Note: GMT 6.0.0 and later offers built-in Scientific colour maps
(see Section 4).

3.9.1 .cpt format

The file davos.cpt can be resampled for a given z-value range
with theGenericMapping Tools (GMT; http://www.generic-mapping-
tools.org) command “makecpt”.

For example to resample for an array from -2000 to 2000 in 100
increments you could generate a new file with:

$makecpt -Cdavos.cpt -T-2000/2000/100 > davos_resampled.cpt

3.10 Gnuplot

3.10.1 .pal format

Launch the Gnuplot shell and load the specific .pal file (e.g., bat-
low) into Gnuplot with:

user@computer gnuplot
gnuplot> load "batlow.pal"

3.11 GPlates

3.11.1 .cpt format

To use the Scientific colour maps with GPlates, select the layer
you would like to symbolise on the ‘layers’ panel and click ‘open
.cpt file’, under the ‘options’ tab.

For sequential colour maps, inverted versions are available with
the postfix “_I”: the inverted batlow is, for example, named
batlow_I.cpt.

3.11.2 Convenience package

To conveniently import the entire suite of Scientific colour maps
into GPlates at once, use the external package provided via
www.fabiocrameri.ch/colourmaps, which also contains inverted
gradients, as this option seems to be lacking in GPlates.
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3.12 ImageJ/Fiji

3.12.1 .lut format

The .lut colour-map file (e.g., *batlow.lut*) can be imported to
ImageJ or Fiji by placing it in the *luts* folder (to reveal folder
location in Fiji: File > Show Folder > LUTs). Upon restart of Im-
ageJ, the scientific colour map(s) should then be available under
Image > Lookup Tables.

Alternatively, the colour-map .lut file may be applied using either
(a) File > Open, (b) File > Import > LUT, or (c) drag and drop
the .lut file onto the ImageJ window. To view available LUTs:
Image > Color > Display LUTs.

3.12.2 NeuroCyto LUTs add-on

Detailed information about how to use a simple add-on that adds
a handy LUTs drop-down menu to the Fiji user interface is given
on https://forum.image.sc/t/neurocyto-luts-update-site/26244.

3.13 iolite

The software iolite offers a built-in version of batlow. To im-
port other Scientific colour maps, go to: Custom Colour Maps >
Add and then navigate to the Scientific colour map folder and
select the colour map’s .lut or .txt format.

3.14 Julia

The programming language Julia has built in Scientific colour
maps in its colour map libraries, which makes them readily use-
able. The Julia file containing the colour maps is scicolor.jl:
github.com/JuliaGraphics/ColorSchemes.jl/tree/master/data.

3.15 Kingdom

3.15.1 .clm format

On any screen, select Show color bar from the toolbar. Above
the colour bar that appears, select Select?, then under Files of
type choose Color Bars (*.CLM), then navigate to the location
the colour-map files are stored.

The continuous Scientific colour maps are also provided exter-
nally in Kingdom’s native file format, .clb, for easier implementa-
tion. The .clb files are available separately onwww.fabiocrameri.ch/
colourmaps. To import them in Kingdom, select, on any screen,
Show color bar from the toolbar. Above the colour bar that ap-
pears, select Select?, then navigate to the location the colour-
map files are stored.

3.16 Mathematica

3.16.1 .mat format

ColorMapSuitePath = "/Path/To/ColourMapSuite/";

ColorMapSuite[name_String] := ColorMapSuite[name, -1]
ColorMapSuite[name_String, el_] := With[{

list =
Transpose@{Subdivide[0, 1, 255],
RGBColor @@@
First@Import[
ColorMapSuitePath <> "/" <> name <> "/" <> name <> ".mat"]}
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},
Blend[list, {##}[[el]]] &
]

The function call ColorMapSuite["name", i = -1] returns a lambda
function whose ith argument is used to define color (see the
Manual for ColorFunction for details). "name" should be replaced
with the name (in quotes) of the color scheme, e.g. "davos". Be
sure to set the variable ColorMapSuitePath to the path where your
ColorMapSuite is installed.

General rules are:

• 1D plots of 1D functions/data: no (default) argument *i* suf-
fices

• 2D plots of 2D functions/data: no (default) argument *i* suf-
fices

• 3D plots of 2D functions/data: use *i* = 3

• 3D plots of 3D functions/data: use *i* = 4 (results might be
worse than default Mathematica color functions, possibly
due to lack of surface normal mapping)

ContourPlot[Sin[x] Sin[y], {x, 0, 2 Pi},
{y, 0, 2 Pi}, ColorFunction -> ColorMapSuite["davos"]]

3.17 MatLab

3.17.1 .mat format)

Load the colour map into MatLab, either by adding the .mat file
to the MatLab search path and using the command:

load('davos.mat');

or by specifying the full file path to the .mat file:

load('~/work/Colormaps/davos.mat');

Then use it, for example, with:

figure(1)
colormap(davos)
colorbar

3.17.2 File-exchange app

A convenient MatLab package provided by Chad Greene con-
taining the full scientific colour-map suite is available on MatLab
file exchange.

3.18 MOVE Petroleum Experts

3.18.1 .cpt format

To use the Scientific colour maps with MOVE (tested with version
IPM 13):

1. Go to Program Files
2. Select Petroleum Experts
3. Select IPM 13
4. Select Data
5. Copy and paste the desired Scientific colour maps in .CPT
format
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3.19 Ncview

3.19.1 .ncmap format

The colour map .ncmap files can live in the following places:

1. NCVIEW_LIB_DIR, which is determined at installation time. A
reasonable choice is /usr/local/lib/ncview.
2. In a directory namedby the environmental variable NCVIEWBASE.
3. If there is no environmental variable NCVIEWBASE, then in $HOME.
4. In the current working directory.

Then when you open Ncview, it should automatically have all of
the colour maps available.

3.20 Ocean Data View (ODV)

3.20.1 .pal format

Download and save the xxx_ODV.pal colourmap file in the “Palettes”
folder within the main “ODV” folder, which can be found on Win-
dows and macOS usually in the “Documents” folder:

Documents > ODV > palettes

From within the running ODV, select properties then general to
choose a new palette. Restart ODV and the imported scientific
colour maps should appear in the properties panel.

3.21 OpendTect

For Import to OpendTect follow these steps:

1. Download the OpendTect package by Kaspar Merz from this
direct link or via the separate link on www.fabiocrameri.ch/
colourmaps under the section “Usable with:”
2. Click on Survey/Manage/ColorTables...
3. Click on Import...
4. Select file; navigate to directory and open this file
5. Select desired colour maps
6. Import

3.22 Originlab

3.22.1 .pal format

To use the .pal colour map files in the Originlab software, down-
load the external package fromwww.fabiocrameri.ch/colourmaps
or via the direct link. The .PAL files can then be copied to the
origin palette folder and used similarly to the Originlab default
color palettes.

3.23 Paraview

3.23.1 .xml format

Using Scientific colourmaps in Paraview is done via the following
procedure:

Click Edit color map panel. Once the colour map settings open,
click the folder with the heart (i.e., Choose Preset), then Import,
and then choose the PARAVIEW.xml format (e.g., batlow_PARAVIEW.xml).
The colour map is now loaded and saved in Paraview, so one can
now simply search for the colour map name (e.g., batlow) in the
search field for the colour maps. Click on the desired colour map
and hit Apply.
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3.24 Petrel

3.24.1 .alut format

To import colour maps, select the templates pane and colour
tables folder.

Then select the folder to import into (or insert a new folder) and
right click import on selection.

Select colour tables (alut files) (*.alut) to view and select
all suitable colour maps for import.

Accept default settings trim colour control points and trim
opacity control points and finally use as any other colour table
within Petrel.

3.25 Plotly

3.25.1 .py format

Plotly versions of the Scientific colour maps are provided by
Emilia are available at https://github.com/empet/scientific-colorscales.

The plotly Scientific colour maps (see the file scicolorscales.py)
were created by converting the provided .py file of each colour
map.

Direct applications and some scientific tests are illustrated in this
Jupyter Notebook: http://nbviewer.jupyter.org/github/empet/
scientific-colorscales/blob/master/Tests-for-scientific-colorscales.ipynb.

3.26 Python

3.26.1 Package (pip and anaconda)

The convenient python package, https://pypi.org/project/cmcrameri/,
by Callum Rollo is available through pip and anaconda.

Install with pip:

pip install cmcrameri

Install with conda:

conda config --add channels conda-forge
conda install cmcrameri

Usage example:

from cmcrameri import cm
import matplotlib.pyplot as plt
import numpy as np
x = np.linspace(0, 100, 100)[None, :]
plt.imshow(x, aspect='auto', cmap=cm.batlow) # or any other colourmap
plt.axis('off')
plt.show()

3.26.2 init file

A simple init file located in ScientificColourMaps8/+TOOLS/ can
be used to make the whole suite of colour maps readily avail-
able in python: Place the __init__.py file in the main directory
ScientificColourMaps8/ (adjust the single-digit version number
where necessary) and update your PYTHONPATH environment
like this:

(for linux/bash)
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export PYTHONPATH=$PYTHONPATH:/full/path/to/ScientificColourMaps7/

Adjust the single-digit version number where necessary.

Then, in any python, you can import the palette collection, by us-
ing import ScientificColourMaps8 as SCM8, which allows for ex-
ample commands like

plt.imshow(some_data, cmap=SCM8.berlin) # Linear palette
plt.imshow(some_data, cmap=SCM8.berlin_r) # Reversed, linear
plt.imshow(some_data, cmap=SCM8.berlin25_r) # Reversed, 25 steps, discrete

Adjust the single-digit version number where necessary.

3.26.3 .txt format

Step 1: Load colour-map data

Load the colour-map data into Python using numpy.loadtxt():

import numpy as np
cm_data = np.loadtxt("batlow.txt")

Step 2: Set up colour map

Use matplotlib.colors.LinearSegmentedColormap() to create a
colour map that can be used with matplotlib.

from matplotlib.colors import LinearSegmentedColormap
batlow_map = LinearSegmentedColormap.from_list('batlow', cm_data)

Complete example:

import numpy as np
import matplotlib.pyplot as plt
from matplotlib.colors import LinearSegmentedColormap

cm_data = np.loadtxt("batlow_RGB(0-1).txt")
batlow_map = LinearSegmentedColormap.from_list('batlow', cm_data)

x = np.linspace(0, 100, 100)[None, :]
plt.imshow(x, aspect='auto',cmap=batlow_map)
plt.axis('off')
plt.show()

3.26.4 palettable library

The palettable library provides the Scientific colour maps (and
other scientifically-derived colour maps) in a convenient way for
use with e.g., matplotlib. Palettable is available on PyPI for instal-
lation via pip: pip install palettable. Palettable is compatible
with Python 2.6, 2.7, and Python 3. For more instructions see here.

3.27 QGIS

3.27.1 .xml format

Load the colour map into QGIS in:

Settings > Style manager > Import/Export > Import symbol(s)
> select the xxx_QGIS.xml file.

12 Scientific Colour Maps

https://github.com/jiffyclub/palettable
https://jiffyclub.github.io/palettable/#documentation


3.28 QPS Fledermaus & Qimera

3.28.1 .cmap format

To use the .cmap colour map files in the QPS software Fle-
dermaus and Qimera, download the external package from
www.fabiocrameri.ch/colourmaps or via the direct link.

3.29 R

3.29.1 scico package

‘scico’ (https://travis-ci.org/thomasp85/scico) – pronounced as
“psycho” – is a small package developed by Thomas Lin Peder-
sen that provides access to the Scientific colour maps within R. It
provides colour palettes for ‘ggplot2’) without requiring ‘ggplot2’
to be installed.

scico can be installed fromCRANwith install.packages('scico').
If you want the development version then install directly from
GitHub:

# install.packages("devtools")
devtools::install_github("thomasp85/scico")

For further details and user instructions are included in a README
file within ‘scico’.

3.30 SKUA-GOCAD

3.30.1 .xcmap format

To import a colormap into a SKUA-GOCAD project, navigate to
File > Import > GOCAD Resources > Colormaps.

Alternatively, for advanced users, to include a colormap as a re-
source in all new projects, insert the .xcmap text into the *col-
ormaps.xml* file located in */Gocad/lib/app-defaults.

3.31 VisIt

3.31.1 .ct format

The file davos.ct can imported to VisIt by placing the .ct file in
the .visit directory, which can be found on macOS under e.g.,:

/Applications/VisIt.app/Contents/Resources/ ...
... 2.12.3/darwin-x86_64/resources/colortables

The colour map should appear in the built-in list after VisIt has
been restarted.
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4 Software with built-in versions

• GMT 6.0 and later

• TopoToolbox 2.2 and later

• StagLab 3.0 and later

• SubMachine

• Geoscience ANALYST 2.80 and later

• Igor Pro 9.0 and later

• XMapTools 3.4.2 and later

• KDE LabPlot 2.9 and later

• Gen3sis 1.5 and later

• SeisLib 0.5.1 and later

• iolite 4.8.7 and later

5 Version history

Version 1 : Original colour-map suite (bilbao, broc, cork, davos, devon,
grayC, lajolla, oslo, vik)

Version 2 : Additional colour-map file formats (.ct, .py, .svg)

Version 3 : Additional colour-map file format (.txt)

Dark background palettes (berlin, lisbon, tofino)

Additional sequential palettes (lapaz, tokyo, turku)

Surface topography special palette (oleron)

Seismic tomography special palette (roma)

Version 4 : Additional sequential palettes (acton, bamako, buda, hawaii,
imola, nuuk)

Scientific rainbow palette (batlow)

Additional colour-map file formats (xmlQGIS, .clr)

Version 5 : Discrete colour maps (e.g., batlow10)

Improved perceptual uniformity of the original (v1) palettes

Minor colour adjustment to vik

Additional colour-map file formats (.alut, .ct, .lut, .ncmap,
.pal, .spk, .xcmap)

Version 6 : Categorical colour maps (batlowS, devonS, davosS, osloS,
lapazS, actonS, lajollaS, bilbaoS, grayCS, tokyoS, turkuS, ba-
makoS, nuukS, hawaiiS, budaS, imolaS)

Cyclic colour maps (romaO, brocO, corkO, vikO)

Improved colour-map diagnostics for perceptual uniformity

Additional colour-map file formats (.clm)

Improved User guide

Change to MIT License

Version 7 : Additional diverging palettes (bam, vanimo)

Additional cyclic palette (bamO)

Additional multi-sequential palettes (bukavu, fes)

batlowW: batlow with white ending
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batlowK: batlow with black ending

cork: Improved lightness symmetry

roma: Improved lightness symmetry

More formats (e.g., .pal for OriginLab)

Updated __init__.py to flip colour gradients by Tobias Staal

Updated __init__.py adding all new colour maps by Megan
Brown

New Python package by Callum Rollo

Colour map type and class flow chart

Version 8 : Additional sequential palettes (glasgow, lipari, navia)

Additional diverging palette (managua)

grayC: Reversed standard gradient

bilbao: Improved local colour contrast; Gradient reversed

lajolla: Improved local colour contrast; Gradient reversed

acton: Improved local colour contrast & vibrancy

bamako: Improved local colour contrast & vibrancy

batlowK: Improved local colour contrast & vibrancy

tokyo: Improved local colour contrast & vibrancy

More formats (e.g., .pal for ODV, .ase for Adobe Illustrator)

Additional software with built-in versions (e.g., Gen3sis and
SeisLib)

More descriptive colour map suite figure allowing to hand-
pick ten Categorical colours for each sequential palette

Cleaner diagnostic figures
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6 License

The Scientific colour maps are licensed under a MIT License

Copyright (c) 2023, Fabio Crameri

Permission is hereby granted, free of charge, to any person ob-
taining a copy of this software and associated documentation
files (the ”Software”), to deal in the Software without restric-
tion, including without limitation the rights to use, copy, modify,
merge, publish, distribute, sublicense, and/or sell copies of the
Software, and to permit persons to whom the Software is fur-
nished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be
included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED ”AS IS”, WITHOUT WARRANTY OF
ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR
ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN AC-
TION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT
OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
OTHER DEALINGS IN THE SOFTWARE.
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